Hard Crash During pcmcia-cs Installation

Bug #35140 reported by mikeazorin on 2006-03-16
22
Affects Status Importance Assigned to Milestone
Linux
Undecided
auto-wardsandra63
linux-source-2.6.15 (Ubuntu)
Medium
dariusz

Bug Description

Installing the pcmcia-cs package tries to start PCMCIA services. The PCMCIA services crash when "Intel ISA PCIC probe: not found." This causes the entire computer to go into a hard crash, unrecoverably. The only way to restart the computer is by holding the power button.

FlagMan (flagman) wrote :

Me 2 :(

I had an up-to-date breezy SMP install running, added dapper to the sources.list and did apt-get upgrade. When dpkg configured pcmcia-cs, I experienced the exact same error as above.

This is especially annoying, since pcmcia is now in rcS.d and a single user reboot therefore not trivial.

FlagMan (flagman) wrote :

Hmm - I just noticed that my kernel was NOT upgraded because of a custom install.
While the hang should not happen anyway, maybe this is the reason for it?
People with this problem, please comment, thanks!

mikeazorin (mikeazorin) wrote :

Since it looks like more people are getting it, I'll explain exactly how it happened to me. I went through my /etc/atp/sources.list file and did a search and replace for breezy to dapper. I then did sudo apt-get update, and sudo apt-get upgrade. The particular guide I was using said that I should apt-get upgrade and then apt-get dist-upgrade. Well, in the middle of the upgrade, my computer completely crashed, so I restarted it, and it couldn't get to the login screen. So I went into recovery mode and I tried to finish apt-get upgrade. It tells me that dpkg is stuck so I have to run it. I do, and it tries to install pcmcia-cs at which point my computer completely crashes. I am on a desktop computer without pcmcia, and my network card is a realtek rtl8139, like everyone else.

Matt Zimmerman (mdz) on 2006-04-06
Changed in pcmcia-cs:
assignee: nobody → dsilvers
Matt Zimmerman (mdz) on 2006-04-11
Changed in pcmcia-cs:
status: Unconfirmed → Confirmed
Daniel Silverstone (dsilvers) wrote :

Can you please confirm the contents of your /etc/default/pcmcia and /etc/default/pcmciautils files?

Ben Collins (ben-collins) wrote :

The problem is not one I can fix in dapper. This is is the result of pcmcia-cs from dapper being started on a breezy kernel (like what happens during the upgrade process).

I firmly believe the bug and fix lies in the pcmcia-cs package itself. Only it can decide not to restart itself in this upgrade scenario.

Joshua Ochs (diamondsw) wrote :

I would disagree with "Severity - Normal". This bug can cause crashes when upgrading from Breezy to Dapper and render the system a pairtially upgraded mess (as it did on mine - thank goodness for backups). Complete OS mutilation ranks just below filesystem mutilation in my book.

Joshua Ochs (diamondsw) wrote :

I'd also like to add that I was using the Software Update manager to perform my upgrade from Breezy to Dapper, on a Dell PowerEdge 2300 server. Absolutely no need for PCMCIA that I can see, and I'm at a loss as to why it was included at all.

Since I do have a backup of my former Breezy system, I'll be glad to pull any information that may help:

/etc/default/pcmcia:
# Defaults for pcmcia (sourced by /etc/init.d/pcmcia)
PCMCIA=yes
PCIC=i82365
PCIC_OPTS=
CORE_OPTS=
CARDMGR_OPTS=

/etc/default/pcmciautils: Does not exist

Xande (xande1) wrote :

I got bitten by this bug too, and I agree that it's way more than Priority: Normal. I'm on a Dell Precision Workstation 220 - which is a desktop.

I have an Ubuntu system that started out in 2004 as a 4.10 install, and has been upgraded without problems through every release since then. I used the Update Manager to upgrade to 6.06, and the install caused the machine to hang totally while configuring pcmcia-cs. (More specifically, I couldn't switch to the terminal window I already had open, ctrl-alt-backspace did nothing, and ctrl-alt-delete did nothing. The computer was sufficiently hung that pressing caps lock would no longer toggle the indicator light for that key.)

After giving it 30 minutes, to ensure it wasn't just a slow response, I power cycled the machine, and again it hung on the Starting PCMCIA Services step. Rebooting in Recovery Mode has the same problem. So now my box is non-bootable, I have an OS upgrade that got interrupted in medias res, and I have no pre-update backup. (I know, shame on me, but the 4.10->5.04->5.10 upgrades all went so smoothly, I stopped bothering.)

I will post further information as I deal with troubleshooting this, but meanwhile, I have the following suggestion: Make the pcmcia-cs package optional (i.e., don't make ubuntu-desktop depend on it) until this bug is ironed out. At least that will keep the upgrade process from turning people's boxes into doorstops.

Xande (xande1) wrote :

I just posted a workaround for this bug to the DapperUpgrade wiki page. Here's the same thing without any handholding, in hopes it helps with the bug squashing.

 1. Reboot using a bootable rescue CD.
 2. Mount the partition containing /etc read-write.
 3. Move the files etc/init.d/pcmcia and etc/init.d/pcmciautils somewhere else (to keep them from executing on startup).
 4. Remove the CD and reboot.
 5. Before logging in select Options -> Sessions -> GNOME. (The unfinished setup process rendered the default session unusable.)
 6. Open a terminal and run sudo dpkg --configure -a. The attempt to setup the package pcmcia-cs will fail because it can't find the moved file.
 7. (Optional) Move the pcmcia init scripts back. They will no longer hang the machine.
 8. Reboot. The machine should boot normally now.

Colin Watson (cjwatson) wrote :

There's a fix for this in dapper-updates now:

pcmcia-cs (3.2.8-5.2ubuntu6) dapper-updates; urgency=critical

  * Don't start pcmcia-cs after upgrading from breezy, as the start script
    can hang breezy machines on occasion.

 -- Scott James Remnant <email address hidden> Wed, 31 May 2006 16:33:19 +0100

We recommend that upgraders include dapper-updates in /etc/apt/sources.list while upgrading.

With regard to making pcmcia-cs no longer an indirect dependency of ubuntu-desktop, we'd like to, but unfortunately it's a little complicated (and in any case it wouldn't help with this bug because pcmcia-cs was an indirect dependency of ubuntu-desktop in Breezy too).

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released
Joshua Ochs (diamondsw) wrote :

Upgrading from Breezy still locks trying to start pcmcia-cs (it appears that it locks access to the filesystem, then deadlocks), using the Software Updates GUI. If this fix only works via command line, then I'd say it's still "broken".

dariusz (dariusz-alicja) on 2006-10-13
Changed in linux-source-2.6.15:
assignee: dsilvers → dariusz-alicja
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

  • auto-wardsandra63 Edit

Bug watches keep track of this bug in other bug trackers.