Ubuntu

Resume (from RAM) fails

Reported by Mark Lord on 2006-03-15
14
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins

Bug Description

Resume from RAM (after suspend) fails, with hard disk light stuck on. This used to work fine in Breezy (no patches), and Hoary (with patched kernel).

Dapper seems to be missing something. I can make it work by installing my own patched kernels (http://rtr.ca/dell_i9300/). Specifically, Randy Dunlap's libata-acpi patch fixes this.

-ml

Mark Lord (launchpad-rtr) wrote :

Mmm.. working now after one reboot. Not sure how to get it to fail again reliably.

Matt Zimmerman (mdz) wrote :

Are you able to reproduce the problem anymore?

Changed in linux-meta:
assignee: nobody → ben-collins
Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
Mark Lord (launchpad-rtr) wrote :

Just now, I did a fresh install from the 09-April-2006 daily build, plus all current updates for Ubuntu and Kubuntu-Desktop.

Suspend-to-RAM works, but Resume-from-RAM experiences a short delay (a driver timeout in libata is suspected), and then the USB mouse lights up (working), and the hard disk light locks on solid. The display backlight never comes on, so no messages are visible, and the system is not functioning.

Alt-SysRq-B works (reboot), so it's not a total hard lockup.

It really looks like the libata hard disk device is not surviving the resume operation. I may eventually apply Randy Dunlop's libata-acpi patchset and see if that cures it.

Cheers

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed
Matthew Garrett (mjg59) wrote :

If you could try that, that would be great. Our libata resume patches are fairly old.

Matthew Garrett wrote:
> If you could try that, that would be great. Our libata resume patches are fairly old.

I'm working on it now. As a first step, I'm copying over the patched 2.6.16 kernelt
that works flawlessly for me using Breezy. If that fixes it, then we can work out
a patchset. If it fails, then there's something else at play here (different drives..).

Cheers
--
Mark Lord
Real-Time Remedies Inc.
<email address hidden>

Mark Lord (launchpad-rtr) wrote :

With my patched 2.6.16 kernel ( http://rtr.ca/dell_i9300/kernel/kernel-2.6.16/ ) the suspend/resume work perfectly, without the issue documented here.

I tried bringing Randy's newer libata-acpi stuff over to the Ubuntu 2.6.15+ kernel, but it clashed with an older version already there -- I did manage to hand-patch it in, but it only worked some of the time, not all of the time on resume.

I may try again later, by first removing the old Randy code completely, and then adding in his latest for 2.6.15, which I still have a copy of here.

On a related note: the video (ATI X300) fails resume on Dapper unless I remove the "dri" section from /etc/X11/xorg.conf. But that's a different bug, I suppose.

Cheers

jukka holm (jukka-holm-gmail) wrote :

I have the same problem. Hard disk doesnt come back alive from suspend to ram. Hard disk led stays on and I cant read or write from the disk.

I have Thinkpad X41 with Dapper and latest updates from 23th of april.

Mark Lord (launchpad-rtr) wrote :

This is now working for me with all of today's latest dapper/Kubuntu installed. BUT.. only when using the BIOS "standby" button to suspend the machine.

I think I'll open some new bugs now for the "laptop battery menu Suspend" not working.

Cheers

description: updated
Adam Niedling (krychek) wrote :

This is fixed for the original reporter. Others should open another bug reports.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers