snd-es18xx not automatically loaded (missing from kernel binaries?)

Bug #34785 reported by Fabián Rodríguez on 2006-03-13
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

Using Dapper Flight 5, fresh install.
Machine is a PIII Compaq SFF with integrated ESS Audiodriver ES1869F.

output of /proc/version:
Linux version 2.6.15-18-686 (buildd@rothera) (gcc version 4.0.3 20060304 (prerelease) (Ubuntu 4.0.2-10ubuntu1)) #1 SMP PREEMPT Thu Mar 9 15:29:22 UTC 2006

Audio was working fine in Breezy, automatically detected+installed. When installing DF5 (not dist-upgraded, fresh installed), audio is not longer configured and sound mixer applet shows a red X. This seems to be the same bug described in Bug #27384. I am filing this under udev as per Seveas advice in #ubuntu+1

After following instructions at https://wiki.ubuntu.com/DebuggingSoundProblems I was able to manually load the driver doing:
sudo mod-probe snd-es18xx irq=5 port=0x220

Sound then works normally (video, CD, applications, etc.). I also got an indication from the taskbar that a new audio peripheral was installed and it opened a dialog to select the default sound system - can't remember exactly the contents but the ESS was the only choice.

I believe ES18xx based sound cards/integrated systems are pretty common and this should be easier to configure, even if it has to be done manually. I am not sure the how-to I followed is something I would suggest anyone to follow, although it is simple.

I have attached files containing lspci and dmesg information.

Output of lspci

description: updated
description: updated

Ouput of dmesg

I don't see an snd-es18xx driver, other than in the kernel source -- did we drop this one?

Chuck Short (zulcss) on 2006-03-22
Changed in linux-source-2.6.15:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers