Ubuntu

Dell X1 fails to resume with mmc_core and sdhci modules loaded

Reported by Robert Collins on 2006-02-23
22
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

My dell X1 was failing to resume from suspend. I managed to get a console one time while doing this and saw

sdhci: timeout waiting for hardware interrupt

repeating with a email address to submit a report to..

I tried removing the mmc_core module and the sdhci modules and it resumes just fine from suspend to ram now.

Matt Zimmerman (mdz) wrote :

Is this still happening with current Dapper?

Hiroyuki Ikezoe (ikezoe) wrote :

still happen on Panasonic CF-Y4 with kernel 2.6.15-20-386.

I've got this same problem with latest Dapper on the Dell Latitude X1.

Paul Sladen (sladen) wrote :

Maybe the same as bug #44959.

Paul Sladen (sladen) wrote :

We could just mark these modules as requiring to be unloaded and reloaded on Suspend/Hibernate unless they can be fixed in the kernel.

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
Hiroyuki Ikezoe (ikezoe) wrote :

Paul,
Unloading and Reloading explicitly these modules does not solve the issue at least on my laptop. Reloading modules after resume causes hanging up.

Robert Collins (lifeless) wrote :

this works in 2.6.20 (feisty)

Changed in linux-source-2.6.20:
status: Unconfirmed → Fix Released
Jacqueline (jwegscheid) wrote :

This is broken again (still?) in Gutsy. I have a Dell Inspiron 1420, and found this bug report while trying to troubleshoot the built-in card reader (sometimes it works, sometimes not, I can give more details, but I'm not sure if they belong here or in a separate bug report?). My laptop's never been able to come back from suspend and I know it usually has these (mmc_core and sdhci) modules loaded, so I tried unloading them, suspending, and waking back up, and it went beautifully. Reloading the modules after waking back up doesn't hurt general functioning any, but does put the card reader back into the broken state that made me come looking for help - nothing happens when you stick the card in, dmesg gets several errors like this:

[ 9467.772000] mmcblk0: error 2 transferring data
[ 9467.772000] end_request: I/O error, dev mmcblk0, sector 0

Morten Siebuhr (msiebuhr) wrote :

I have not been bothered by this for the past year or so. I'd consider this bug closed...

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in linux-source-2.6.22:
status: New → Incomplete
Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid

This does not qualify for a Stable Release Update to 2.6.15 - http://wiki.ubuntu.com/StableReleaseUpdates. Closing linux-source-2.6.15 task. Thanks.

Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers