Ubuntu

tv card audio not working

Reported by Hidde Brugmans on 2006-01-26
40
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
udev (Ubuntu)
Medium
Unassigned

Bug Description

I have a bttv-television pci card.
Video capture works fine, but the audio is giving only a tearing sound since the upgrade to 2.6.15.

Card has a line-out, goes to the line-in of my audigy sound card, other sounds are working, mixer settings are right, I'm guessing it's not loading the right driver, or the driver is bugged.

-----------------------------------------

hidde@megaera:~$ lspci
0000:00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
0000:00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
0000:00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
0000:00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
0000:00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
0000:00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
0000:00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
0000:00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
0000:00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
0000:00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
0000:00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
0000:00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
0000:00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
0000:01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)
0000:05:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
0000:05:06.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 04)
0000:05:06.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
0000:05:08.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:05:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

-----------------------------

hidde@megaera:~$ lsmod
Module Size Used by
isofs 38496 1
nls_utf8 2240 1
udf 94628 0
uinput 9728 0
rfcomm 42996 0
l2cap 28096 5 rfcomm
bluetooth 54020 4 rfcomm,l2cap
powernow_k8 14400 0
cpufreq_userspace 6496 1
cpufreq_stats 6688 0
freq_table 4928 2 powernow_k8,cpufreq_stats
cpufreq_powersave 1920 0
cpufreq_ondemand 7752 0
cpufreq_conservative 9000 0
video 16324 0
tc1100_wmi 6884 0
sony_acpi 5516 0
pcc_acpi 11136 0
hotkey 11492 0
dev_acpi 11236 0
button 6704 0
battery 9668 0
container 4608 0
ac 4932 0
md_mod 76052 0
sr_mod 17988 0
sbp2 24708 0
lp 12356 0
rsrc_nonstatic 14624 0
pcmcia_core 45272 1 rsrc_nonstatic
snd_emu10k1_synth 8096 0
snd_emux_synth 39968 1 snd_emu10k1_synth
snd_seq_virmidi 8320 1 snd_emux_synth
snd_seq_midi_emul 7680 1 snd_emux_synth
snd_seq_dummy 3908 0
snd_seq_oss 37216 0
snd_seq_midi 9600 0
snd_seq_midi_event 7520 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
snd_seq 58160 9 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
bt878 10872 0
snd_emu10k1 129604 5 snd_emu10k1_synth
snd_rawmidi 26848 3 snd_seq_virmidi,snd_seq_midi,snd_emu10k1
snd_seq_device 9228 8 snd_emu10k1_synth,snd_emux_synth,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_emu10k1,snd_rawmidi
snd_ac97_codec 99520 1 snd_emu10k1
snd_pcm_oss 56448 0
snd_mixer_oss 20544 3 snd_pcm_oss
snd_pcm 96644 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_timer 26884 3 snd_seq,snd_emu10k1,snd_pcm
snd_ac97_bus 2400 1 snd_ac97_codec
snd_page_alloc 11304 2 snd_emu10k1,snd_pcm
snd_util_mem 4928 2 snd_emux_synth,snd_emu10k1
snd_hwdep 9952 2 snd_emux_synth,snd_emu10k1
tuner 44932 0
ohci1394 37524 0
tda9887 16336 0
bttv 173360 2 bt878
video_buf 22724 1 bttv
i2c_algo_bit 9800 1 bttv
snd 59972 17 snd_emux_synth,snd_seq_virmidi,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
v4l2_common 6080 1 bttv
btcx_risc 5288 1 bttv
tveeprom 15312 1 bttv
videodev 10144 2 bttv
ieee1394 306104 2 sbp2,ohci1394
soundcore 10784 3 snd
usblp 13920 0
emu10k1_gp 3904 0
gameport 16744 2 emu10k1_gp
rtc 14068 0
pcspkr 2244 0
parport_pc 37988 1
parport 39400 2 lp,parport_pc
floppy 64676 0
psmouse 39972 0
serio_raw 7748 0
ipv6 286880 20
i2c_nforce2 7104 0
i2c_core 22848 6 tuner,tda9887,bttv,i2c_algo_bit,tveeprom,i2c_nforce2
nvidia 4090832 12
agpgart 36784 1 nvidia
af_packet 24520 2
evdev 10176 0
ext3 148104 4
jbd 65876 1 ext3
dm_mod 63224 6
forcedeth 25572 0
usb_storage 79488 1
ide_generic 1504 0
ide_cd 44100 1
cdrom 41408 2 sr_mod,ide_cd
ide_disk 19200 1
generic 5124 0
usbhid 41280 0
sd_mod 20448 3
amd74xx 15068 0 [permanent]
sata_nv 10020 4
libata 64872 1 sata_nv
scsi_mod 145352 5 sr_mod,sbp2,usb_storage,sd_mod,libata
ehci_hcd 34696 0
ohci_hcd 22724 0
usbcore 137700 6 usblp,usb_storage,usbhid,ehci_hcd,ohci_hcd
thermal 13768 0
processor 26344 2 powernow_k8,thermal
fan 4836 0
capability 4968 0
commoncap 7328 1 capability
vga16fb 13768 1
cfbcopyarea 4096 1 vga16fb
vgastate 10208 1 vga16fb
cfbimgblt 3104 1 vga16fb
cfbfillrect 4352 1 vga16fb
fbcon 43904 72
tileblit 2784 1 fbcon
font 8320 1 fbcon
bitblit 6464 1 fbcon
softcursor 2304 1 bitblit
hidde@megaera:~$

Ben Collins (ben-collins) wrote :

Can you verify that the line-in on your audigy actually works with some other input, and/or that the tv card line-out doesn't work with some other device (e.g. speakers)?

Ben Collins (ben-collins) wrote :

This may be fixed in my current tree.

Keep an eye on http://people.ubuntu.com/~bcollins/kernels-daily/ for an update in about 12 hours. Please test that kernel.

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info

It's the line-out of the tv-card that is not working.
Plugged in a speaker directly, and there is nothing but static coming out.
Can't check the input of my audigy easily, unfortunatly.

For reference, the setup is the same as under warty/hoary/breezy, and it worked.
I can play music, watch videos and have perfect sound, so that works too.

Ben, last update to the kernels-daily is dated 24-01

It still does not work with the current dapper. Is there anything I can test?

just upgraded to 2.6.15-15-686, no improvement.

The problem seems to be that the bttv module is loaded, rather than snd_bt87x
I am unsure if this is udev's or the kernel's fault

The following commands fix this, so I have working sound.

$ sudo modprobe -r bt878 bttv
$ sudo modprobe snd_bt87x
$ sudo modprobe bt878

Ben Collins (ben-collins) wrote :

Seems to me this needs to be worked around in udev somehow. Since both modules need to be loaded, it's something that can't really be worked around in the kernel.

Tried blacklisting on advise from keybuk. That didn't do the trick.

hidde@megaera:~$ cat /etc/modprobe.d/blacklist |grep bttv
blacklist bttv

Hidde: please confirm that the bttv card isn't getting loaded (lsmod | grep bttv)

Thanks

Wishlist: support for a card that hasn't been supported so far.
Low priority: not a regression.

Changed in udev:
assignee: nobody → keybuk

I think you misunderstood.

The problem _is_ that the bttv module _is_ getting loaded.

hidde@megaera:~$ lsmod | grep bttv
bttv 173424 1 bt878
video_buf 22724 1 bttv
i2c_algo_bit 9800 1 bttv
v4l2_common 6080 1 bttv
btcx_risc 5288 1 bttv
tveeprom 15312 1 bttv
videodev 10144 1 bttv
i2c_core 22848 7 i2c_acpi_ec,tuner,tda9887,bttv,i2c_algo_bit,tveeprom,i2c_nforce2

My card does not work with the bttv module, but needs both the snd_bt87x and the bt878 modules.

See also my comment of 2006-02-12

You also need to blacklist bt878, which depends on bttv

Again, no.

I need bt878 in combination with snd_bt87x, as far as I can tell

bttv is there, but snd_bt87x is loaded first, so it handles the sound, rather than bttv

working configuration:
hidde@megaera:~$ lsmod | grep bt
bt878 10872 0
bttv 173424 1 bt878
video_buf 22724 1 bttv
i2c_algo_bit 9800 1 bttv
v4l2_common 6080 1 bttv
btcx_risc 5288 1 bttv
tveeprom 15312 1 bttv
videodev 10144 1 bttv
snd_bt87x 15656 0
snd_pcm 96644 5 snd_bt87x,snd_emu10k1,snd_ac97_codec,snd_pcm_osssnd_page_alloc 11304 3 snd_bt87x,snd_emu10k1,snd_pcm
snd 59972 17 snd_bt87x,snd_emux_synth,snd_seq_virmidi,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
i2c_core 22848 7 bttv,i2c_algo_bit,tveeprom,tuner,tda9887,i2c_acpi_ec,i2c_nforce2

bttv is there, but I assume

Ben, we decided this was a kernel bug in bttv, didn't we?

Changed in linux-source-2.6.15:
assignee: keybuk → kernel-team
Changed in udev:
status: Unconfirmed → Rejected
Timo Jyrinki (timo-jyrinki) wrote :

My bt878 card did work without problems in Ubuntu 5.10 when recording from the TV-card's line-out, so it'd seem like a regression. It's a weird combination of loading order and "modules handling the same thing" stuff. blacklisting bt878 allows snd_bt87x to function properly (without blacklisting snd_bt87x is loaded but nothing seems to be initialized).

A complexicating thing is also the amount of methods that may be used for recording. Recording from line-out shouldn't require snd_bt87x at all, snd_bt87x is for directly recording from the tv card either the analog way or digital way (both provided by snd_bt87x, and supported only by some cards). In 5.10, I didn't even try the direct recording, but now some of this new ALSA/DVB (?) stuff is breaking even the sound output from line-out to line-in depending on the modules loaded. And if that's not enough, I have recording problems even using Gnome's sound recorder with my HDAudio sound, but at least the sound should be heard when the TV card is connected to line in.

Also, there isn't even a good documentation available about what _is_ the relationship between bttv, bt878, btaudio (gone?), snd-bt87x... modules. I don't even have a digital TV card but still apparently some DVB stuff is also included in some of those modules? And some forum messages are indicating that that "dvb stuff" is also trying to "handle" the audio part.

I hope there is at least someone that actually understands the whole picture.

The easiest "quick fix" for this is to do the following:

  echo bt878 > /etc/modprobe.d/blacklist-bt878
  echo bt878 >> /etc/modules

This blacklists bt878 (and thus bttv, which is what breaks snd_bt87x) from being automatically loaded for the device, leaving only snd_bt87x loaded; and then causes bt878 to be loaded manually later in the boot sequence, thus forcing the load order.

This is a "hack" though, the correct fix is to stop bttv from breaking snd_bt87x in the first place and allow them to be loaded in any order.

Matt Zimmerman (mdz) wrote :

It should work to use snd_bt87x with bttv (which drives the video portion of the card)

Ben Collins (ben-collins) wrote :

I have a question though, does bttv still work under these conditions? The problem I have is that the bttv driver doesn't seem to bind to the Video Capture device, it only binds to the Audio Capture pci device (or rather, it only matches, and becomes autoloaded when it sees a Bt878 or Bt879 Audio Capture device).

So I can't just disable this in the bttv driver, else it just plain breaks it.

Same bug, still present in current edgy

Changed in linux-source-2.6.17:
status: Unconfirmed → Needs Info
geneo93 (cps1966) wrote :
Changed in linux-source-2.6.15:
assignee: kernel-team → nobody
importance: Wishlist → Medium
status: Needs Info → Confirmed
Changed in linux-source-2.6.17:
importance: Untriaged → Medium
status: Needs Info → Confirmed
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Rejected
Suzan (suzan72) wrote :

Very sad, bug is still present with Feisty's actual kernel 2.6.20-6-generic.

Pensacola (pensacola) wrote :

I can confirm the bug in Feisty 2.6.20-6-generic and 2.6.20-6-386
Anyone has a quick fix?

Miguel (miguel-glug) wrote :

I have the same bug in a Pinnacle PCTV with a bt878A chip in Feisty. Anyone has a clean solution?

Josip Rodin (joy) wrote :

Hi,

I have been experiencing the same problem on my bttv card there is no longer
any sound (it stopped working some time ago, I can't remember exactly when
and how). The bttv driver identifies it correctly as:
Terratec TerraTValue Version Bt878 [card=33,autodetected]

The TV card is physically linked with the line-in of the sound card.
The mixer settings are fine, the line volume is pumped up.
It doesn't appear to be a hardware problem because:
* if I plug the speaker system directly into the TV card I can hear TV sound
  normally
* the same audio cable worked just fine in Linux some time ago, and still
  works today in Windows

It's as if nothing is going through the line-in of this snd-intel8x0.
alsamixer describes it as:

Card: NVidia CK804
Chip: Realtek ALC850 rev 0

Maybe that's the actual culprit for some of these problems?

I backtracked and it's not working with kernel 2.6.21.1, 2.6.19.1, 2.6.18.
I haven't kept any older ones :/

I'm not sure if this is the right bug number, because here people are
talking about snd-bt87x. I tried loading that module, had to use the force
option, it said:

unknown card 0x878-0x153b:0x1118, using default rate 32000
please mail id, board name, and, if it works, the correct digital_rate option to <email address hidden>

alsamixer -c 1 says there's a "Capture" setting, but I can't adjust
anything, so it seems pretty much useless to me.

I also hear that buzzing sound that the #38497 submitter mentioned, but that sounds like some sort of generic
TV tuner noise to me, that otherwise gets drowned when the normal TV audio is working.

I wouldn't describe the noise as 'tearing' (as the #29789 submitter did).

Maybe these are not duplicates. #58969 mentions snd-intel8x0.
The submitter of #38497 didn't note his sound card - if it's also a snd-intel8x0,
then we may have a pattern there.

Changed in linux:
status: Invalid → Fix Released
Josip Rodin (joy) wrote :

Upstream bug #7109 has a single comment dated 2007-01-22 which says "This regression has been resolved in 2.6.18.1 and 2.6.19". Unfortunately, then it is clear that we are talking about several different bugs in these several (Ubuntu) bug reports. One bug is the interaction of snd_bt87x with bttv, and the other bug is the interaction of bttv with the line-in of a sound card (possibly only snd_intel8x0). Somebody should clone/unmerge this one from the rest.

Josip Rodin (joy) wrote :

Three people noted below that they see this in Feisty which has linux-source-2.6.20; and I see it as well on the stock kernels up to .21.

Bart Libert (lapino) wrote :

I have the same problem with a Hauppauge WinTV in feisty.

On Sat, Jul 28, 2007 at 12:20:44PM -0000, Bart Libert wrote:
> I have the same problem with a Hauppauge WinTV in feisty.

What audio card do you have? Is it using the snd-intel8x0 driver?

--
     2. That which causes joy or happiness.

It's not his soundcard. I still have the original problem on feisty with either my onboard ac'97 soundcard or an audigy1/2 pci card.

I get the distinct impression people here are talking about multiple bugs.

Bart Libert (lapino) wrote :

Onboard ac 97 and audigy 2 zs here, and neither works.

Josip Rodin (joy) wrote :

On Sat, Jul 28, 2007 at 01:48:37PM -0000, Hidde Brugmans wrote:
> It's not his soundcard. I still have the original problem on feisty with
> either my onboard ac'97 soundcard or an audigy1/2 pci card.
>
> I get the distinct impression people here are talking about multiple
> bugs.

Yes, I agree, but Launchpad doesn't seem to have the ability to clone bugs,
so we can't nicely separate them as we could in debbugs :)

--
     2. That which causes joy or happiness.

Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. Thanks!

Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: New → Incomplete
wip (wipinmtl) wrote :
Download full text (3.2 KiB)

i have 7.10 with kernel 2.6.22-14-rt using a wintv card. i have the same problem: the line out of the wintv card is not working. well almost cause i can hear a little bit if i really boost the sound on my amplifier (+30db).

i was hoping to use btaudio to driver the 32000 hertz to /dev/dsp2 (or so). but modprobe btaudio is not present. locate btaudio gives nothing. maybe it's my configuration.

[ 45.692860] bttv: driver version 0.9.17 loaded
[ 45.692868] bttv: using 8 buffers with 2080k (520 pages) each for capture
[ 45.692954] bttv: Bt8xx card found (0).
[ 45.692983] ACPI: PCI Interrupt 0000:02:0a.0[A] -> GSI 22 (level, low) -> IRQ 20
[ 45.692998] bttv0: Bt878 (rev 17) at 0000:02:0a.0, irq: 20, latency: 64, mmio: 0xf8ffe000
[ 45.693015] bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
[ 45.693019] bttv0: using: Hauppauge (bt878) [card=10,autodetected]
[ 45.693052] bttv0: gpio: en=00000000, out=00000000 in=00ffffdb [init]
[ 45.695773] bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
[ 45.753326] tveeprom 0-0050: Hauppauge model 44811, rev C323, serial# 2631909
[ 45.753332] tveeprom 0-0050: tuner model is Philips FM1236 (idx 23, type 2)
[ 45.753336] tveeprom 0-0050: TV standards NTSC(M) (eeprom 0x08)
[ 45.753340] tveeprom 0-0050: audio processor is None (idx 0)
[ 45.753343] tveeprom 0-0050: has radio
[ 45.753346] bttv0: Hauppauge eeprom indicates model#44811
[ 45.753349] bttv0: using tuner=2
[ 45.753354] bttv0: i2c: checking for MSP34xx @ 0x80... not found
[ 45.753946] bttv0: i2c: checking for TDA9875 @ 0xb0... not found
[ 45.754528] bttv0: i2c: checking for TDA7432 @ 0x8a... not found
[ 45.802424] bttv0: i2c: checking for TDA9887 @ 0x86... not found
[ 45.854762] tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
[ 45.854803] tuner 0-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
[ 45.854808] tuner 0-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
[ 45.863597] bttv0: registered device video0
[ 45.863647] bttv0: registered device vbi0
[ 45.863689] bttv0: registered device radio0
[ 45.863713] bttv0: PLL: 28636363 => 35468950 .. ok
[ 45.886293] bttv: Bt8xx card found (1).
[ 45.886319] ACPI: PCI Interrupt 0000:02:0d.0[A] -> GSI 21 (level, low) -> IRQ 21
[ 45.886334] bttv1: Bt878 (rev 17) at 0000:02:0d.0, irq: 21, latency: 64, mmio: 0xf8ffc000
[ 45.886360] bttv1: detected: Osprey-200 [card=88], PCI subsystem ID is 0070:ff01
[ 45.886364] bttv1: using: Osprey 200/250 [card=88,autodetected]
[ 45.886394] bttv1: gpio: en=00000000, out=00000000 in=00ffffff [init]
[ 45.943203] bttv1: osprey eeprom: card=89 name=Osprey 210/220/230 serial=3081860
[ 45.943209] bttv1: using tuner=-1
[ 45.943214] bttv1: i2c: checking for TDA9887 @ 0x86... not found
[ 45.944303] bttv1: registered device video1
[ 45.944669] bttv1: registered device vbi1
[ 45.944695] bttv1: PLL: 28636363 => 35468950 .. ok

also i halsa an osprey for capturing video from composition or svideo.
[ 45.753340] tveeprom 0-0050: audio processor is None (idx 0):
not looking good?

i can see video perfectly with tvtime

xawtv fail on me:
xinerama 0: 1280x1024+0+...

Read more...

nzadLithium (cmaster2) wrote :

i've been using my card which may be the same card as other peoples here. Its a pixelview playtv pro2. I have used both edgy and feisty and my card works absolutely fine. Are you people sure your using the write card option for the bttv driver?
My card is card=70 and my tuner is tuner=43 although it works with tuner=37 and tuner=38 as well.
My card is also connected to the line-in like everyone elses. All i have to do is unmute line in and turn the volume up. The problems i have though is i have a radio so i set radio=1 its sets up a radio device but if i get any radio program to play from it it produces no sound. if i set it to the video device however it works. I get alot of static on most stations but on two i get perfect sound. When i get lots of static it seems to be playing a second station at the same time it plays mine? I'm not sure whats up with that but the tv card worked fine in edgy and feisty.

nzadLithium (cmaster2) wrote :

i think i should add i did not need a snd_bt87x or bt878 module. i did have a bt_audio module loaded but today i found out i didnt need that one either. And i have an audigy 2 zs soundcard

Sergey Prokhorchuk (stager13) wrote :

 I have the same problem with MediaForte PV951 card (video is ok, but no sound) on 7.10 Gutsy Gibbon. This card works ok on Mandriva 2007.0 (2.6.17 kernel I think) and worked before on previous Mandriva versions... My PC configuration: AMD X2 3800+ (939), ASUS nForce4 chipset, amd64-version of Ubuntu installed. It looks like problem does not depend on proprietary/free driver selection for my NVIDIA 7600GT card (i tested both configuration). I've tried different bttv,tvaudio modules options but didn't solve a problem.

 So 7.10 still have this problem :(

Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Confirmed
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Confirmed

The Hardy Heron Alpha2 release should be available shorty (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with the LiveCD and verify if this issue still exists or not. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete
Sergey Prokhorchuk (stager13) wrote :

  I've installed Hardy Alpha 2 kernel into my Gutsy Gibbon 7.10 (I know it is not very wise step, but I wanted to test if bug still present). Sadly, after booting with new kernel I still have a problem with sound :( And another problem with tuner appeared - I can't switch channels... May be new 2.6.24-rc6 will solve problem? As far as I see many v4l-related fixes have been made in rc6 (http://lwn.net/Articles/262978)).
 For information, my "uname -a" gives:
Linux stager-home 2.6.24-2-generic #1 SMP Thu Dec 20 17:58:55 GMT 2007 x86_64 GNU/Linux

 /etc/modprobe.conf:
 options bttv radio=1 tuner=28 card=72 gbuffers=4

 dmesg result is in attach...

 Feel free to ask me about additional information if you need some...

Sergey Prokhorchuk (stager13) wrote :

  I solved a problem passing i2c_udelay parameter for bttv module. Now my /etc/modprobe.conf looks like this:

  options bttv radio=1 tuner=28 card=72 gbuffers=4 i2c_udelay=128

  Perhaps i2c_udelay=16 will be enough too - need to check. With this parameter sound from tv works ok on 2.6.22 (from Gutsy) as well as on 2.6.24rc5 (from Hardy Alpha2).

  Hope this info will be useful...

Thanks for the update Sergey. For anyone else who is interested, Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. Please verify if this bug still exists or not and report back your results. Thanks!

Jelle De Loecker (skerit) wrote :

Unfortunately it's not enough ...

Could someone post a complete workaround? I'm asking much, sure, but there are dozens of different "solutions" out there, try sorting them out...

And none work!

bdowd (bdowd) wrote :

Increasing the bttv buffer size makes a large difference in length of time audio will play back successfully using the BT878 (in the Hauppauge WinTV PVR-350). I am using an Audigy 2 sound card. The CPU is an Intel 3Ghz with only 512K RAM.

sudo gedit /etc/modprobe.conf and change the value of gbuffers to 512

mplayer /dev/video0

Lengths of time audio and video interleave properly until "Cannot sync MAD frame" error occurs. Both video and audio stop; then the video restarts but the audio does not:

gbuffers=16 (29 seconds)
gbuffers=32 (1 minute 10 seconds)
gbuffers=128 (5 minutes 11 seconds)
gbuffers=256 (18 minutes 33 seconds)

SO I kept increasing gbuffers and rebooting the machine. Didn't work. Even backing the values down again ... it now hangs after 5 seconds to a minute. Heat?

The single line in /etc/modprobe.conf now reads "options bttv radio=1 tuner=28 card=72 gbuffers=128 i2c_delay=128"

Just a note that we'll keep this report open against the actively developed kernel but this will be closed against the older kernels as it does not qualify for a stable release update. Thanks.

Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.17:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
El_Matthews (fb517255) wrote :

Hello, now a couple of months later. Did anybody made this work? I still have no sound with my WinTV-GO (bt878).

bojohan (bojohan+launchpad) wrote :

I use this workaround.

I created the file /etc/modprobe.d/pinnacle-pctv with this content:

# Sound is broken when modules are loaded in the default order
install bttv modprobe tuner ; modprobe --ignore-install bttv $CMDLINE_OPTS

canatella (dam-cosinux) wrote :

That work around does not work for me. I have sound for 20 minutes than it stop. I get errors like: Error: Only read -1 bytes of 4096 bytes from '/dev/dsp
read audio: Input/output error

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

canatella (dam-cosinux) wrote :

Hello,

On Thu, Aug 28, 2008 at 07:05:02PM -0000, Leann Ogasawara wrote:
> 1) If you are comfortable installing packages on your own, the linux-
> image-2.6.27-* package is currently available for you to install and
> test.

Is this an image for Hardy and where to find it ?

Best,

Damien

--
Damien�MERENNE <email address hidden>
http://blog.cosinux.org/

The 2.6.27 kernel is only available through the Intrepid repository. However, since Alpha5 was released last week, I assume you should be able to test via a LiveCD. Thanks.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Bryan Wu (cooloney) wrote :

Since this is long story and keep in silence for a long time, we plan to set this bug to "won't fix". Please move to Jaunty release. if you find the same issue, please fire new bug to us.

-Bryan

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.