gdm locks up system in few seconds after load

Bug #29368 reported by cruiseoveride on 2006-01-22
This bug report is a duplicate of:  Bug #23445: iMac G5 will freeze after booting up. Edit Remove
16
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

version: Ubuntu 5.10 for Mac (ppc64)
While booting the ppc64 version of this os on a iMac g5,
the machine boots normally, it loads gdm, and then in a few seconds the machine locksup completely, if i disable gdm at boot, the machine works fine in the console.

The other problem is with the liive cd. when booted on a iMac g5, it repeatedly display the following message.

"Please release keys to continue...."

even after disconnecting the keyboard the msg occurs.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Does Ctrl-Alt-Fn works when gdm hangs? Do you have anything to /var/log/messages or /var/log/syslog about the hang?

Changed in gdm:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
cruiseoveride (cruiseoveride) wrote :

Ctrl-Alt-Fn Does not work, the entire systems locks up.
I havent looked at the logs, but if at boot time you set the init level to 3, it boots, and one can logon to the system, but if you type too quickly the system will lockup again, thats why i ssh into the machine and work on it from another machine (well another keybord).

Daniel Holbach (dholbach) wrote :

Could you please try to get the logs? /var/log/gdm/ and /var/log/Xorg.0.log might be useful too.

cruiseoveride (cruiseoveride) wrote :

the machine has been formatted, and mac os X tiger has been installed, as ubuntu was not working, sorry :(

Dennis Kaarsemaker (dennis) wrote :

Then I'm afraid we'll have to reject this bug - without more information we cannot even guess what is going wrong.

Changed in gdm:
status: Needs Info → Rejected
Torrance (torrance123) wrote :

I can confirm this bug on my iMac G5 17inch system.

It's been discussed as well on the Ubuntu Forums:
http://ubuntuforums.org/showthread.php?t=89712

I have read elsewhere that it is related to the sound on iMacs. I have successfully installed Linux on this machine only with installations that allowed me to disable the sound before it was tried. Those other reports also noted that this is likely since the Gnome login screen makes a sound just as it loads up.

I was able to Ctrl-Alt-F1 just before the login screen loaded up. The terminal froze too, and I was presented with the following timeout errors every 30 seconds or so:

timeout errors every 30 seconds or so, such as follows:

Ubuntu 5.10 "Breezy badger" ubuntu tty1

ubuntu login: [ 108.648803] ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
[ 138.648794] ata1: command 0x35 timeout, stat 0x50 host_stat 0x4
[ 139.576955] mpic_enable_irq timeout
[ 168.648798] ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
[ 198.648789] ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
[ 199.715012] mpic_enable_irq timeout
[ 228.648800] ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
[ 258.648792] ata1: command 0x25 timeout, stat 0x50 host_stat 0x4

Changed in gdm:
status: Rejected → Confirmed
Torrance (torrance123) wrote :

This problem remains unresolved in Ubuntu 6.10 Flight 4, having just tried that now.

Torrance (torrance123) wrote :

One last note:

The link below suggests the freeze is due to the "aRts" or "artsd" desktop sound daemon. They suggest renaming the file as bakartsd. (This is all quite beyond me, and it seems too difficult to do myself considering my system won't let me access any terminals)

Link: http://www.suseforums.net/index.php?showtopic=19034

Torrance (torrance123) wrote :

Here are some of those log files you were after. I had to copy these out by hand - the first one is verbatim except for the areas marked "etc. etc.", the second is just the last few lines (it was over 600 line in length!).

/var/log/gdm/:0.log.4

X Window System Version 6.8.2
Release date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12 ppc [ELF]
Current Operating System: Linux revolution 2.6.12-9-powerpc64-smp #1 SMP Mon Oct 10 15:38:27 BST 2005 ppc64
Build Date: 10 October 2005
Module loader present.
OS Kernal: Linux version 2.6.12-9-powerpc64-smp (buildd@adare) etc. etc.

Markers: etc. etc.

(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 11 16:45:42 2006
(==) Using config file: "/etc/X11/xorg.conf"

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
Skipping "/usr/X11R6/lib/modules/libfb.a:fbmmx.o": No symbols found

/var/log/Xorg.0.log

--> 600 or so lines that seem OK, last few lines below... <--

Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0

cruiseoveride (cruiseoveride) wrote :

I have replaced the OS with fedora 4, and have give the machine back to my friend. I will not be able to give any further information on the machine.

Sebastien Bacher (seb128) wrote :

Please don't play with the settings of a bug to put aberant values like that. That's making prioritizing work harded for the distro team and can create some tensions because you are trying to push your own issue without any good reason over the maintainer choice

Torrance (torrance123) wrote :

A temporary work-around has been detailed here:
http://ubuntuforums.org/showpost.php?p=817651&postcount=22

It is definitely a sound problem driver problem, as the only way to login was to stop all login sounds, and disbale the ESD sound server from starting up. Even with this work-around, the system still freezes when accessing the sound panel and logging out (but this is only in Dapper 5, so may not be related).

sam tygier (samtygier) wrote :

the problem seems to be more to do with esd than gdm. (is esound the correct package to file against?)

Torrance (torrance123) on 2006-04-09
Changed in esound:
status: Unconfirmed → Confirmed
Torrance (torrance123) wrote :

I am not sure this is esound. Other distros (notably openSUSE 10.1) are loading OK with esound, but they are not loading any sound drivers. Ubtunu, on the other hand, is installing a pmac sound driver (from memory).

It may in fact be a problem with an incorrect sound driver being installed. This may be the case as it was not only attempts by esound to play sound that brought the system to a halt, but also the attempts by the GDM to play sound. And I don't think GDM uses esound (but I could be wrong).

Needless to say, there is no sound with the iMacG5 (should this be filed as a separate bug??).

Sebastien Bacher (seb128) wrote :

Not sound is a different issue so a different bug should be opened. gdm doesn't use esound by aplay, rejecting that task

Changed in esound:
status: Confirmed → Rejected
cruiseoveride (cruiseoveride) wrote :

I dont have the G5 anymore, but i remember that even if i booted the machine to init 3, and worked on the console, the machine would hang up, after a few mins. If you hold down a few keys together the machine freezes, if you type too fast the machine freezes, but on the native keyboard only.
If u ssh into the machine, u can work on it forever without any issues.

Torrance (torrance123) wrote :

This looks like the same bug as #23445 (both are generating the same time-out messages, occuring on the same machine, and at the same booting stage).

Should they be linked? The other one has a "fix committed" status.

https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.15/+bug/23445

Sebastien Bacher (seb128) wrote :

thank you for pointing that, marking as duplicate

Changed in gdm:
assignee: desktop-bugs → nobody
status: Confirmed → Rejected
cruiseoveride (cruiseoveride) wrote :

The machine works fine with Fedora Core (tested with version 4). Everything works except sound and Direct Hardware rendering.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers