Include OSS driver for Ralink wireless chipset?

Bug #28464 reported by David Silverkors on 2006-01-13
22
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Baltix)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Ralink just recently released a oss(sortof) driver for their rt61 chipset found in f.e. d-links wireless products. It would be very beneficial if this driver were included in dapper.

It would really be a bummer if it was missed since Ubuntu is striving so hard to be easy for laptop and wireless setups.

The driver can be downloaded from http://www.ralinktech.com/supp-1.htm

Greetz

Changed in kernel-package:
assignee: nobody → ben-collins
status: Unconfirmed → Confirmed
Chuck Short (zulcss) wrote :

I have added this driver to my git tree.

Gaëtan Petit (gaetanp) wrote :

the status of this still confirmed
or the fix have been realesed?
Because some users are experiencing problems with rt61 chipset

look at #28464
https://launchpad.net/distros/ubuntu/+bug/35474

Gaëtan Petit (gaetanp) wrote :

ok sorry #35474

-_-'

gregrs (gregrs) wrote :

A generic driver for RT2x00 (including RT2500 and RT61 amongst others) is being developed here:

http://rt2x00.serialmonkey.com/

This driver is currently in beta testing, but should greatly increase support for RT61 cards. Could this be incorporated into Dapper? (Not sure of timescale of this driver)

Cheers.

Gaëtan Petit (gaetanp) wrote :

think it should be a great thing.
It very frustrating to reboot under windows to have access to internet...

Aldous Peñaranda (dous) wrote :

Hmm... How come in #35474, the poster says that Dapper can detect a card that uses the RT61 module? Has this bug been fixed?

Gaëtan Petit (gaetanp) wrote :

i have no previoux experience with the rt61
but ralink had released their drivers under GPL.
So yes Dapper can detect the card,
bug the kernel module is buggy and don't work.

So i d'ont know if this bug should be close because ben collins had done it,
or it has to be down ...

Alexander Rødseth (alexanro) wrote :

I have a rt61-card. In order to make it work for both Ubuntu Festy and Gutsy I had to:
* blacklist rt61pci in /etc/modprobe.d/blacklist
* download the latest driver from http://rt2x00.serialmonkey.com/ (I had no luck with the one from Ralink!)

Here's my card (from lspci):
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

In addition, I have to shut down NetworkManager in order to enable the dhcp-client to fetch an address.

My /etc/network/interfaces looks like this, if it will save someone the many hours it took to figure out how to make WPA2 work:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 192.168.0.111
        netmask 255.255.255.0

auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up sleep .1
pre-up /sbin/iwpriv wlan0 set NetworkType=Infra
pre-up sleep .1
pre-up /sbin/iwpriv wlan0 set AuthMode=WPA2PSK
pre-up sleep .1
pre-up /sbin/iwpriv wlan0 set EncrypType=AES
pre-up sleep .1
pre-up /sbin/iwpriv wlan0 set essid YOUR_ESSID_GOES_HERE
pre-up sleep .1
pre-up /sbin/iwpriv wlan0 set WPAPSK=YOUR_PASSWORD_GOES_HERE
pre-up sleep .1

#auto eth1
iface eth1 inet dhcp

#auto eth2
iface eth2 inet dhcp

#auto ath0
iface ath0 inet dhcp

---

Anyways, I vote for including the drivers from http://rt2x00.serialmonkey.com/ and removing rt61pci!

Alamar (robinorman) wrote :

Similar to the last post, but RT61 card worked fine in Feisty (with the included RT61 module), but is unusable in Gutsy (and previously Edgy) with the RT61pci module. Would prefer that the working RT61 module was included instead!

My working, Feisty /etc/network/interfaces file is in http://ubuntuforums.org/showpost.php?p=2825485&postcount=54 but is essentially the same as that in the previous post - although note that this was with the RT61 module included with the 2.6.20-16-generic kernel, not one downloaded separately.

WillSmith (undertakingyou) wrote :

As the previous post said, It worked fine in feisty, now broken in Gutsy. Would love this to work like it did before. I added it as a bug in the 2.6.22 kernel source. Sorry I don't know if it affects baltic also or not. Pushed ok to fast. Happy to supply what may be needed.

Francesco Duraccio (odo.) wrote :

I have the same problem with rt61pci if i blackshit the mod, and load the rt61 mod of serialmonkey all stuck! so i can't boot with kernel 2.16.22.14 of gutsy
If I boot with kernel 2.6.20.16 i can use rt61 and gutsy.

!quote Anyways, I vote for including the drivers from http://rt2x00.serialmonkey.com/ and removing rt61pci!

I'm closing this report as it appears support for this chipset has been added. If you're having issues with this driver, that belongs in a different bug report. If the issue has already been reported, please add any additional useful comments there. Otherwise, open a new report. Thanks.

Changed in linux-source-2.6.22:
status: New → Fix Released
status: New → Invalid
admarginem (admarginem) wrote :

Leann,

you are wrong - the current hardy does not include rt61.ko driver. It includes unoperational rt61pci...

Changed in linux-source-2.6.22:
status: Fix Released → Confirmed
Javier Jardón (jjardon) wrote :

admarginem,

And rt61pci driver is the OSS driver that this bug request ;-). See bug 134660. So Leann close safely this bug report ;-)

Changed in linux-source-2.6.22:
status: Confirmed → Fix Released
Changed in linux-source-2.6.15 (Ubuntu):
status: Confirmed → Invalid
assignee: Ben Collins (ben-collins) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers