Kubuntu "Dapper Drake" flight2 kernel won't start on Turion64 laptop

Bug #27563 reported by SC on 2005-12-24
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Jonathan Jesse

Bug Description

Attempting to boot the AMD64 flight2 install CD: system locks hard at "io
scheduler cfq registered". Flight2 i386 LiveCD seems to work fine (don't
currently have AMD64 Flight2 liveCD or i386 Flight2 installCD available to test.)

System is a Compaq Presario V2410US (AMD Turion64 "ML-30" 1.6Ghz. 512MB Ram -
video uses shared memory, if that makes a difference.)

Download full text (11.4 KiB)

I'm having a similar problem on my system. Until recently I could force it to work by using 'acpi=off noapic nolapic', but now it will only boot if I unplug all my usb devices, then plug them back in once the kernel has finished booting. Otherwise it will lock up on the 'io scheduler cfq registered'. There's definately been a weird problem with usb in the past few releases of the kernel but now it is even worse.

System is an AMD 3800+ X2, ASUS A8N32-SLI Deluxe (nforce4), root installed on a SATA2 drive, usb devices are a Logitech Cordless Desktop S510, a Logitech G7 mouse, a Dell 2405FPW monitor (has a CF/SD/etc reader), and a Logitech Fusion webcamera plugged into the monitor's usb hub as well.

Original install was from a beta2 textmode cd and has been dist-upgraded to current.

Snippet of dmesg WITHOUT USB DEVICES PLUGGED IN follows this post. I have no way to capture the dmesg of the kernel when it doesn't boot.

[ 0.000000] Bootdata ok (command line is root=/dev/sda2 ro quiet splash)
[ 0.000000] Linux version 2.6.15-22-amd64-generic (buildd@crested) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Sun May 7 15:56:20 UTC 2006
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e9b90 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000007ffb0000 (usable)
[ 0.000000] BIOS-e820: 000000007ffb0000 - 000000007ffbe000 (ACPI data)
[ 0.000000] BIOS-e820: 000000007ffbe000 - 000000007ffe0000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000007ffe0000 - 0000000080000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fef00000 (reserved)
[ 0.000000] BIOS-e820: 00000000ff700000 - 0000000100000000 (reserved)
[ 0.000000] ACPI: RSDP (v002 ACPIAM ) @ 0x00000000000fb520
[ 0.000000] ACPI: XSDT (v001 A M I OEMXSDT 0x01000602 MSFT 0x00000097) @ 0x000000007ffb0100
[ 0.000000] ACPI: FADT (v003 A M I OEMFACP 0x01000602 MSFT 0x00000097) @ 0x000000007ffb0290
[ 0.000000] ACPI: MADT (v001 A M I OEMAPIC 0x01000602 MSFT 0x00000097) @ 0x000000007ffb0390
[ 0.000000] ACPI: MCFG (v001 A M I OEMMCFG 0x01000602 MSFT 0x00000097) @ 0x000000007ffb0400
[ 0.000000] ACPI: OEMB (v001 A M I AMI_OEM 0x01000602 MSFT 0x00000097) @ 0x000000007ffbe040
[ 0.000000] ACPI: DSDT (v001 A0371 A0371001 0x00000001 INTL 0x02002026) @ 0x0000000000000000
[ 0.000000] Scanning NUMA topology in Northbridge 24
[ 0.000000] Number of nodes 1
[ 0.000000] Node 0 MemBase 0000000000000000 Limit 000000007ffb0000
[ 0.000000] Using 63 for the hash shift.
[ 0.000000] Using node hash shift of 63
[ 0.000000] Bootmem setup node 0 0000000000000000-000000007ffb0000
[ 0.000000] On node 0 totalpages: 516022
[ 0.000000] DMA zone: 3020 pages, LIFO batch:0
[ 0.000000] DMA32 zone: 513002 pages, LIFO batch:31
[ 0.000000] Normal zone: 0 pages, LIFO batch:0
[ 0.000000] ...

Martin Bergner (martin-bergner) wrote :

Hi. is this still a problem on Dapper or Edgy?

Martin Bergner wrote:
> Hi. is this still a problem on Dapper or Edgy?
>
> ** Changed in: Ubuntu
> Assignee: (unassigned) => Martin Bergner
> Status: Unconfirmed => Needs Info
>

Currently still a problem on dapper. I work around it by using
'pci=conf1' in the kernel boot parameters.

- Dan

Martin Bergner (martin-bergner) wrote :

Reassigning then.

Jonathan Jesse (jjesse) wrote :

Good morning,

I just wondered what the status of this bug was as it referenced flight2 and the kernel. Marking it as incomplete and assigning it to myself so I can track the bug

Changed in linux-source-2.6.15:
assignee: nobody → jjesse
status: New → Incomplete
Jonathan Jesse (jjesse) wrote :

I see there hasn't been any update on this bug? Are you still having problems with this? If not please update this bug otherwise it will be marked as invalid.

Thanks,

JOnathan

SC (smc+ubugzilla) wrote :

Sorry about the delay:

I haven't had a chance to re-test this yet, but I did download the 7.10 beta for amd64 install image. Once I get a chance to burn it, I'll see if it boots on my system.

Beyond that I can't tell you much. At the time this bug was filed, I was choosing an amd64 distribution for my (then new) laptop, and trying to decide between Kubuntu and Gentoo. Gentoo booted :-)

If there haven't been numerous other complaints like this since then, I'm guessing the problem is either solved, or there's something exotic about my laptop in particular and it doesn't affect anybody else right now. I'll post another update when I have a chance to test booting the new image.

Jonathan Jesse (jjesse) wrote :

Thanks for updating, I'll follow your future update to see if 7.10 fixes the problem.

Thanks again,

JOnathan

Jonathan Jesse (jjesse) wrote :

Good evening,

I noticed the last update on 2007-10-11 was that you were going to be installing the 7.10 update and I am wondering if you are still having problems with this? Could you please update this bug status-wise or it will be closed out?

Thanks,

Jonathan

Jonathan Jesse (jjesse) wrote :

Good evening,

I am marking this bug as Invalid due to lack of response from the initial requestor. At one time the requestor was going to be updating to 7.10 and I am hoping this bug has been solved with a newer version of the kernel. If however this has not the problem of your laptop not starting please re-open this bug.

Thanks again for reporting the bug,

Jonathan

Changed in linux-source-2.6.15:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.