Sound on ibook only works after (un)plugging headphones

Bug #25634 reported by Brian Campbell on 2005-11-11
16
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Ben Collins
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins

Bug Description

With my Late-2001 Apple iBook the sound doesn't work until headphones are
plugged in,
or unplugged if they were already plugged in when the machine was booted up.
This is
with Breezy, it used to work with Hoary. It uses the "Tumbler" sound hardware.

The only oddity with the alsa mixer settings is that the 'Headphone',0 setting is
always on at bootup, even if nothing's plugged in and /var/lib/alsa/asound.state
had
it off. My guess is that something has broken in the headphone detection code
between
the kernel version in Hoary and Breezy.

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

Brian Campbell (bacam) wrote :

I installed Dapper Flight 2 with 2.6.15-8-powerpc and the bug is still there.

Brian Campbell (bacam) wrote :

Playing with current Dapper a bit more, I notice that suspending the machine (by
closing the lid), resuming, then changing the volume causes sound to start
working. (Also, with the Breezy kernel patched to allow suspend, suspending and
resuming works, I don't have to touch the volume.)

Brian Campbell (bacam) wrote :

I've found that backing out the patch "ppc64: improve g5 sound headphone mute" at

http://www.kernel.org/git/?p=linux/kernel/git/bcollins/ubuntu-2.6.git;a=commitdiff;h=4be8dc7ff69182610b40a078b9815bcdf27e0c49

makes sound work on my iBook again.

Ben Collins (ben-collins) wrote :

When booting into the non-working kernel, attach the output of this command please:

cat /proc/acpi/processor/CPU0/throttling

Hrm... so once it works, it behaves normally ? That is you can plug/unplug the
jack and it does as expected ? Looks like it's only the initial setting at boot
that is wrong...

Can you send me by email a tarball of /proc/device-tree ?

Ben.

Brian Campbell (bacam) wrote :

There's no /proc/acpi, presumably because there's no ACPI.

After you've plugged and unplugged the jack it works fine. (The only oddity is
that the system beep seems to vary in volume, but it's always done that in Linux
as far as I can remember.) I've sent /proc/device-tree by email.

Ben Collins (ben-collins) wrote :

(In reply to comment #7)
> There's no /proc/acpi, presumably because there's no ACPI.
>
> After you've plugged and unplugged the jack it works fine. (The only oddity is
> that the system beep seems to vary in volume, but it's always done that in Linux
> as far as I can remember.) I've sent /proc/device-tree by email.

Sorry, wrong bug report.

Upgrading to 2.6.15-13.18 from 2.6.15-11.16 appears to have made matters worse. Now it gets an oops in the sound code. Log messages attached.

Brian Campbell (bacam) wrote :

With 2.6.15-15.20 there's no oops, but I can't get any sound output, even with the old workaround.

Alessio Caiazza (nolith) wrote :

on 2.6.15-15-powerpc I can't play anu audio on my ibook

today I've noticed that if you resume the ibook from sleep sounds works (if you are logged on kde, after restarting arts).

Bye

Brian Campbell (bacam) wrote :

Trying it again (2.6.15-15.21), the workarounds do work. There weren't any relevant changes from 15.20, so it's likely that I was mistaken.

Carthik Sharma (carthik) wrote :

Marking this fix released as the original reporter seems to find it working fine now. Please reopen this if this is still an issue.

Thank you for reporting this bug.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released
Brian Campbell (bacam) wrote :

I don't know where the idea that I think it's working fine came from. Checking with an up-to-date system, it's still a problem.

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed
Brian Campbell (bacam) wrote :

Curiously, on a fresh dapper release install the sound works at startup. However, it still behaves oddly (it's silent after a suspend until I adjust the volume a little), and nothing in the most relevant part of the kernel has changed, so it looks like the underlying bug is still there.

Sergous (sergous) wrote :

I use iBook g3 500 and ubuntu dapper. Confirm the bug, I comment it hear - https://launchpad.net/distros/ubuntu/+source/alsa-utils/+bug/33520/comments/4.

Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.15:
status: Confirmed → Fix Committed
Timothy Smith (tas50) wrote :

Seems like this should be alsa instead of the kernel.

Daniel T Chen (crimsun) wrote :

(Please don't misadjust the assigned source package; it's linux-source-2.6.15 because the code affected lies by default in l-s.)

Timothy Smith (tas50) wrote :

Can anyone test this out with a Feisty nightly and/or a currently updated Edgy so we can see if this bug still exists?

Sergous (sergous) wrote :

2 month ago I faund way to make sound works after plugging/unplugging phones, boot and suspend.

The reason was in /etc/apm/scripts.d/alsa.

Now it works for me. Hope patch in attach helps U.

As a bonus in patch added feature to almost instant sound off then close notebook and go to sleep, as it made in Mac OS X.

To try it:
cd /etc/apm/scripts.d
sudo cp alsa alsa~
sudo patch alsa alsa_suspend.patch

Marco Rodrigues (gothicx) wrote :

Isn't this bug already fix released ?

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules-2.6.15:
assignee: nobody → ben-collins
status: New → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: Fix Released → Invalid
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed

This bug was marked "Fix Committed" a while ago, but there has been no confirmation from Brian Campbell if this bug is actually resolved. Brian, care to comment if this is fixed for you? If so, we'll go ahead and close this report and mark this "Fix Released". Thanks.

Changed in linux-source-2.6.15:
status: Fix Committed → Incomplete

On Wed, Feb 27, 2008 at 03:51:41PM -0000, Leann Ogasawara wrote:
> This bug was marked "Fix Committed" a while ago, but there has been no
> confirmation from Brian Campbell if this bug is actually resolved.
> Brian, care to comment if this is fixed for you? If so, we'll go ahead
> and close this report and mark this "Fix Released". Thanks.

I'm afraid I haven't used Ubuntu for some time. Debian stable's kernel
certainly works at the moment, for what that's worth.

Thanks for the update Brian. Since this had been marked "Fix Committed" I'm going to go ahead and mark this 'Fix Released' on good faith. Thanks.

Changed in linux-source-2.6.15:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.