Wrong video resolution on Powerbook G3 Lombard

Bug #24372 reported by Thomas on 2005-10-21
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins

Bug Description

(Powerbook G3 Lombard (SCSI & USB, no Firewire), 333 MHz, 384 MB RAM, 20 GB HD,
external 15" TFT with 1024x768@60 resolution)

It is impossible to change the video resolution. There is only 640x480 @ 30 or
29 Hz available. Posted the issue in this thread:

http://ubuntuforums.org/showthread.php?t=79413

Daniel Stone (daniels) wrote :

per private mail, the original classification was right:
This might be false because the problem occurs in console video on boot
first and is not related to the X-server.

I have Ubuntu running on an i386 PIII using Onboard-video (S3), PowerMac
G3 DT using Onboard-video (ATI), Mac-Mini (radeonfb) and the PB G3
Lombard (ATI Rage DT - should use the Mach64 kernel video driver). All
videos run well and have 1024x768 from boot on, but the PowerBook does
not despite of different kernel boot parameters I had tested!

BenH imagined that someone could have broken "atyfb" (again) when I
talked with him about that issue. This in mind.

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

Thomas (tjm-gmx) wrote :

OK, I'll going to check the newer kernel with the PowerBook and give report what
I received.

Thomas (tjm-gmx) wrote :

Hello Ben

I downloaded the latest Dapper ISO before Flight2 and tried a new install. There
was a little difference. After booting into console video and displaying "arch:
exit" shortly an Open Firmware screen was shown that displayed that the ATI Rage
LT Pro has been found at its OF-address. Then booting went back to console video
and went on.

But unfortunately whatever modeline I tried, the only one that worked was
video=ofonly. All other approaches lead to 'Out of Sync' or 'Out of Range'
errors on the external monitor. Using another VGA-cable made no difference!

The resolution in console and X11 was still stuck at 640x480@2930 Hz.... no way
to change it.

I gave up and installed Ubuntu Server on the PowerBook G3 Lombard so I do not
need the display anymore...

Btw.: The Dapper installer did not check for other OSes on my drive and forgot
to add my OS X partition to the yaboot.conf, but this is another bug to file)

Unfortunately this renders my PowerBook unusable as a mobile Ubuntu-Desktop
device to show others in order to convince them to switch to Ubuntulinux with
their Old-G3-Mac-Mobiles too... :-(((

Hopefully this gets fixed in the Dapper final release...

Ben Collins (ben-collins) wrote :

Ok, the X display I can do nothing about. That's a seperate bug. What I need to
know is if the stock boot (no video options) works with dapper.

Thomas (tjm-gmx) wrote :

Console video does not change by using ANY modline parameter. It does only work
with video=ofonly. Using other parameters, video=atyfb e.g., the screen gets
'Out of sync' or 'Out of range'. With ofonly it remains at 640x480 in console
but is useable so far.

Ben Collins (ben-collins) wrote :

Ok, if I understand correctly, the standard mode works ok, it's just the
alternative modes that don't?

How are you supplying this alternate mode? Proper format would be
video=atyfb:vmode:16

This would choose the macintosh 1024x768@60 video mode. This is the proper usage
for a PPC.

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.15:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.