Thinkpad R31 requires 'i8042.nomux=1' on kernel commandline

Bug #21558 reported by Paul Sladen on 2005-09-13
44
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Chuck Short
Hardy
Undecided
Unassigned
Intrepid
Medium
Chuck Short

Bug Description

The ThinkPad R31 (really an Acer) requires passing 'i8042.nomux=1' on the kernel
commandline to stop erratic pointer movement caused by the buggy embedded
controller/keyboard combp chip.

This movement occurs approximately every 60seconds if the pointer is being used
at the same time as `batt-applet` queries state. With ACPI in use, this occurs
approximately every 60 seconds. With ACPI disabled, the erratic movement is
continous, rendering the machine completely unusable with no way to switch to a
virtual-terminal.

This occurs on the TP R30 and other Acer-based machines, as that was where the
solution was pin-pointed from. See other laptops requiring this parameter:

  http://www.google.co.uk/search?q=i8042.nomux+required

As well as machines from Sharp and HP.

http://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadR31: http://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadR31

Chuck Short (zulcss) wrote :

Blacklisted in my git archive.

Paul Sladen (sladen) wrote :

Thanks, though unfortunately I can't test it as the laptop in question died a week ago...

Paul Sladen (sladen) wrote :

Chuck, did this go in upstream from your git archive?

Paul Sladen (sladen) wrote :

I don't have working R31 hardware to test anymore; could you confirm if this "i8042.nomux=1" workaround went into the main kernel and close this bug if it did.

Chuck Short (zulcss) wrote :

Please attach the output of sudo dmidecode if the workaround does work.

Thanks

Paul Sladen (sladen) wrote :

I don't have working R31 hardware to test anymore; could you confirm if this "i8042.nomux=1" workaround went into the main kernel and close this bug if it did.

Paul Sladen (sladen) wrote :

This fix is known to work. Globbing against the following DMI should catch it:

  system-manufacturer: IBM
  system-product-name: 2656*

Shoichi Chou (mgdesigner) wrote :

Hi my Thinkpad is just R31.After testing ,it really works!my model is 2656KT2

Paul Sladen (sladen) wrote :

Can we get this blacklist into the kernel please, it's been getting on for 9 months and has missed the last two releases.

Chuck Short (zulcss) wrote :

linux-source-2.6.15 (2.6.15-25.44) UNRELEASED; urgency=low

* i8042-x86ia64io: Blacklist IBM 2656.

Changed in linux-source-2.6.15:
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

Hugs and kisses! :)

Chuck Short (zulcss) wrote :

This should have been changed already

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Rob (rob1101) wrote :

CONFIRMED this solution worked for me.

IBM Thinkpad R31
type 2656
Ubuntu 7.10

Colin Macdonald (cbm755) wrote :

I think this patch might have got lost. It is not in the current Hardy kernel (2.6.24-12) and IIRC, it wasn't in Gutsy either.

https://lists.ubuntu.com/archives/kernel-team/2006-June/000916.html

Also, is there a particular reason why wasn't this submitted upstream? If not, I'll submit an upstream bug report with the patch.

Confirmed. This is still a problem in Hardy. I have added the mentioned kernel option and didn't have any problems so far since then.

Reassigning to the "linux" source package since beginning with Hardy, kernel bugs should be reported against the "linux" package instead of "linux-source-2.6.24". Thanks.

Changed in linux-source-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
jerrylamos (jerrylamos) wrote :

If the problem is a "buggy chip", then why didn't Edgy and Dapper have this difficulty? It only showed up when Feisty picked up a bunch of Debian code.
If Edgy & Dapper didn't have the bug, then there does exist ubuntu code that will run without patches and without command line additions. What's the problem with using the Edgy & Dapper ubuntu code?

Jerry

Changed in linux:
assignee: ubuntu-kernel-team → colin-king
Changed in linux:
status: Triaged → Fix Committed
Martin Pitt (pitti) on 2008-06-04
Changed in linux-source-2.6.15:
status: New → Invalid
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in linux:
status: New → Fix Committed
jerrylamos (jerrylamos) wrote :

Thinkpad R31, 512 MB memory, feedback;

1. Was running well with Feisty and feisty workaround on kernel line: noapic acpi=off irqpoll
2. For feedback on 8.04, went to Ubuntu main site and downloaded fresh copy of Ubuntu on June 5.
3. CD got many failures as booted, could not even manage an install. Suddenly it would get 11 false shutdown menus. Unmanageable.
4. CD booted with i8042,nomux=1 did run, seemed to me the slowest install I've done.
5. Booted Hardy without changes on kernel line. Ran O.K. so long as track point cursor stayed away from the borders.
6. Updates installed - 210 of them! on a fresh install!
7. Tried the noapic acpi=off irqpoll. This worked on Feisty. Hardy boot crashed.
8. Tried i8041,nomux=1. Better behaved as far as cursor was concerned, however visibly slower on internet videos.
9. Conclusion: run with kernel as is, be careful. On occasion, false shutdowns occur, but only one, easy to cancel. Another common instance is the bottom border jumps to the top. Position easily restored.

So I'm O.K. with running the kernel as installed, no added commands, willing to take occasional erratic actions as a trade off on getting faster internet videos. Note System, Preferences, Appearance, Visual Effects set to none. I'm into applications not eye candy.

If Hardy changes to some default of i8042,nomux=1 for the R31, can I set it to i8042,mux=1? What would be the command?

Jerry

jerrylamos (jerrylamos) wrote :

External USB mouse seems less likely to cause problems than using the built-in trackpoint mouse. I haven't done extensive testing on this however that's my impression.

Jerry

Martin Pitt (pitti) wrote :

Copied to hardy-updates. The new kernel was tested extensively by many people, who reported back in other bug reports. Due to lack of feedback, this particular bug was not confirmed to be tested, though. Please report back here if the bug still occurs for you with the new kernel packages, then we will reopen this bug.

Changed in linux:
status: Fix Committed → Fix Released

This patch seems to be missing in Intrepid. I'll ping the kernel guys.

I'll resubmit this patch to the mailing list to get picked up for Intrepid.

Changed in linux:
assignee: colin-king → nobody
status: Fix Committed → Triaged
Changed in linux:
status: Triaged → Fix Committed
jerrylamos (jerrylamos) wrote :

Still occurs on Intrepid Beta on IBM Thinkpad R31 updated to yesterday - today's update is a "partial upgrade" which I avoid because "partials" have bombed my install before.

Linux version 2.6.27-5-generic (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu8) ) #1 SMP Fri Oct 3 00:38:23 UTC 2008
root@Thinkpad:~# cat /proc/version_signature
Ubuntu 2.6.27-5.8-generic

I get around the problem by using a USB mouse which does not have the problem the track point does.
I'd prefer using the track point if it didn't keep coming up with spurious actions like multiple closes whenever the tracpoint pointer gets near a border.

Jerry

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.10

---------------
linux (2.6.27-7.10) intrepid; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: do transaction from interrupt context
    - LP: #277802

  [ Ben Collins ]

  * build/d-i: Change virtio-modules udeb to prio standard

  [ Colin Ian King ]

  * SAUCE: Blacklist IBM 2656 in serio/i8042
    - LP: #21558

  [ Henrik Rydberg ]

  * Revert "SAUCE: applesmc: Add MacBookAir"
  * SAUCE: [PATCH 1/5] hwmon: applesmc: Specified number of bytes to read
    should match actual
  * SAUCE: [PATCH 2/5] hwmon: applesmc: Fix the 'wait status failed: c !=
    8' problem
  * SAUCE: [PATCH 3/5] hwmon: applesmc: Prolong status wait
  * SAUCE: [PATCH 4/5] hwmon: applesmc: Allow for variable ALV0 and ALV1
    package length
  * SAUCE: [PATCH 5/5] hwmon: applesmc: Add support for Macbook Air
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 4
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 3
  * SAUCE: hwmon: applesmc: Lighter wait mechanism, drastic improvement

  [ Leann Ogasawara ]

  * Add automatic model setting for Samsung Q45
    - LP: #200210

  [ Tim Gardner ]

  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: Update Wacom tablet driver to 1.49
    - LP: #260675
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643
  * SAUCE: Fix Wacom tablet 1.49 porting errors
  * SAUCE: Enable an e1000e Intel Corporation 82567 Gigabit controller
  * SAUCE: Fix Oops in wlan_setup
    - LP: #263309

  [ Upstream Kernel Changes ]

  * ath9k: fix oops on trying to hold the wrong spinlock
  * [Bluetooth] Fix double frees on error paths of btusb and bpa10x drivers
  * [Bluetooth] Add reset quirk for new Targus and Belkin dongles
  * [Bluetooth] Add reset quirk for A-Link BlueUSB21 dongle
  * Revert "ax25: Fix std timer socket destroy handling."
  * ax25: Quick fix for making sure unaccepted sockets get destroyed.
  * netrom: Fix sock_orphan() use in nr_release
  * Revert "V4L/DVB (8904): cx88: add missing unlock_kernel"
  * SLOB: fix bogus ksize calculation
  * net: only invoke dev->change_rx_flags when device is UP
  * tcp: Fix possible double-ack w/ user dma
  * net: Fix netdev_run_todo dead-lock
  * tcp: Fix tcp_hybla zero congestion window growth with small rho and large cwnd.
  * [MIPS] Sibyte: Register PIO PATA device only for Swarm and Litte Sur
  * eeepc-laptop: Fix hwmon interface
  * hwmon: (it87) Prevent power-off on Shuttle SN68PT
  * hwmon: Define sysfs interface for energy consumption register
  * hwmon: (adt7473) Fix some bogosity in documentation file
  * hwmon: (abituguru3) Enable reading from AUX3 fan on Abit AT8 32X
  * hwmon: (abituguru3) Enable DMI probing feature on Abit AT8 32X
  * [CPUFREQ] correct broken links and email addresses
  * SLOB: fix bogus ksize calculation fix
  * Don't allow splice() to files opened with O_APPEND
  * Linux 2.6.27

 -- Tim Gardner <email address hidden> Wed, 08 Oct 2008 21:19:34 -0600

Changed in linux:
status: Fix Committed → Fix Released
Colin Macdonald (cbm755) wrote :

I submitted this upstream. Committ #5bd8a05e937b3ab88cd7ea569e32738f36c42bd0. It'll be in 2.6.28.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.