SD card in laptop reader does not work

Bug #20320 reported by Martijn vdS
18
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins

Bug Description

My SD-card reader does not work. lspci tells me it's this device:

0000:02:06.3 Unknown mass storage controller: Texas Instruments: Unknown device 8033
 Subsystem: Hewlett-Packard Company: Unknown device 0934
 Flags: bus master, medium devsel, latency 64, IRQ 10
 Memory at c8408000 (32-bit, non-prefetchable) [size=8K]
 Capabilities: [44] Power Management version 2

Revision history for this message
Martijn vdS (martijn) wrote :

It could also be this device:

0000:02:06.4 0805: Texas Instruments: Unknown device 8034
 Subsystem: Hewlett-Packard Company: Unknown device 0934
 Flags: bus master, medium devsel, latency 64, IRQ 10
 Memory at c840a000 (32-bit, non-prefetchable) [size=256]
 Memory at c840b000 (32-bit, non-prefetchable) [size=256]
 Memory at c840c000 (32-bit, non-prefetchable) [size=256]
 Capabilities: [80] Power Management version 2

Revision history for this message
Matt Zimmerman (mdz) wrote :

SD readers are generally unsupportable under Linux due to the manufacturers'
unwillingness to open the specification

Revision history for this message
Andreas Schildbach (schildbach) wrote :

I'm adding the SD card reader of the Dell Latitude X1 to this list, just for
completeness.

It's either this device:

0000:02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
        Subsystem: Dell: Unknown device 01a3
        Flags: bus master, medium devsel, latency 168, IRQ 19
        Memory at 50000000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
        Memory window 0: 50400000-507ff000 (prefetchable)
        Memory window 1: 50800000-50bff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
        16-bit legacy interface ports at 0001

...or this device:

0000:02:01.2 0805: Ricoh Co Ltd: Unknown device 0822 (rev 17) (prog-if 01)
        Subsystem: Dell: Unknown device 01a3
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at dfcfe700 (32-bit, non-prefetchable) [size=256]
        Capabilities: <available only to root>

Revision history for this message
Chuck Short (zulcss) wrote :

*** Bug 20322 has been marked as a duplicate of this bug. ***

Revision history for this message
Ben Collins (ben-collins) wrote :

Nothing we can do about these devices. We can only blame the vendors.

Revision history for this message
Andreas Schildbach (schildbach) wrote :

Just for the records:

There is a project that develops a Linux driver for the Secure Digital Host
Controller Interface. They claim that their driver is in a fully functional state.

http://mmc.drzeus.cx/wiki/Linux/Drivers/sdhci

Revision history for this message
Martijn vdS (martijn) wrote :

This driver (which claims to be 'fully working'), and which seems to be in the current Dapper kernels (sdhci version 0.8) doesn't work on my HP NW8240.

I'll attach a new dmesg

Revision history for this message
Matthew Garrett (mjg59) wrote :

Can you test with the latest Dapper kernel?

Revision history for this message
Martijn vdS (martijn) wrote :

It works now.

Revision history for this message
Andreas Schildbach (schildbach) wrote :

Why has this bug been rejected? It is fixed now.

Revision history for this message
Martijn vdS (martijn) wrote :

Because it was a WONTFIX in bugzilla. But apparently it was easier to fix than expected :)

Changed in linux-source-2.6.15:
status: Rejected → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.