SATA HDD not recognized during Breezy Colony 4 install or Dapper Flight 3 or Edgy Eft or Feisty Fawn

Bug #19749 reported by Aaron Waite on 2005-08-16
110
This bug affects 18 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

Machine is a Canonical supplied Toshiba Portege S100 - S113TD. Intel Pentium M
Processor 740 [1.73Ghz, 2MB L2 cache, 533Mhz FSB]. Mobile Intel 915PM Express
Chipset. Intel PRO/Wireless 2200BG WiFi. 512MB PC4200 DDR2 RAM. 60GB, 5400RPM
Serial-ATA HDD.

Jeff Waugh pretty much told me that Hoary wouldn't run on this machine, so I
went straight to Breezy Colony 2. I'm able to boot the CD, choose my location
and language, and the installer stops because it's unable to detect a HDD. I've
tried passing all the various ACPI options during boot with no success. The
machine also supports Intel's software RAID, which I've tried disabling via
Toshiba's own sparse BIOS settings with no success.

I was able to mount a USB thumbdrive while in the installer and save some
diagnostic stuff and the logs in /var/log. They can be found at the URL I
provided. Additionally, ArminRonacher has added some notes to my Laptop Testing
Team page confirming what I've also found - that nobody has been able to install
Linux on this machine yet. That page can be found here:

https://wiki.ubuntu.com/LaptopTestingTeam/ToshibaPortegeS100

I can get to a console while in the installer if there are additional
diagnostics that would be helpful. Just let me know.

breezy log files: http://www.volvoguy.net/ubuntu/laptop-breezy/
dapper log files: http://www.volvoguy.net/ubuntu/laptop-dapper/

Aaron Waite (volvoguy) wrote :

Per Corey Burger, added "laptop" and "installer" to the keywords section.

Armin Ronacher (mitsuhiko) wrote :

What happens if you try to deactivate the Software RAID?

Armin Ronacher (mitsuhiko) wrote :

arr. I've forgotten to give you these links:
http://linux.toshiba-dme.co.jp/linux/index.htm <-- japanese, cummunity based
toshiba support for linux
http://www.freed.net/opensource/R100.html <-- installation information for
portégé R100

On the toshiba linux page is also a mailing list, maybe they can help you

Hope I could help you

Aaron Waite (volvoguy) wrote :

Armin: If you deactivate RAID in the BIOS it warns you that it will destroy all
your data. While I could try this, I've been asked to try NOT to do this, so I'd
want confirmation from the Laptop Team leaders first. I've also spent lots of
time on the two sites you mentioned and both are extremely out of date. The only
mention of the S100 on either was on the Japanese Toshiba site and their only
suggestion is "doesn't SATA show up as SCSI - meaning /dev/hd* instead of
/dev/sd*. I knew this was the case before I opened the box. Thanks for the
suggestions though! :)

One other option I've seen (not Ubuntu specific) is to use a Windows version of
GRUB and put a few files (kernel, vmlinuz, initrd) into C:\boot\. I've not seen
this suggested specifically for the S100 either and I'm not convinced that it
would solve the drive recognition issue anyway.

For the record, don't count me as lazy because I don't want to try a *very*
alternative way of installing Linux. It's my understanding at this point that
the whole reason for the Laptop Team was to get these machines working correctly
right out of the box. If the powers that be tell me to wipe the drive and start
from scratch, I'd be happy to do it, but it seems that would defeat the purpose.
Windows users unfamiliar with Linux aren't very likely to go to that extreme to
play around with Ubuntu. (and also for the record, the Colony 2 live cd doesn't
start X and just freezes on the "do you want to see the X server output?" screen
- perhaps due to the PCI-E video card which I think this machine has - Toshiba
is very sketchy on technical details).

Aaron Waite (volvoguy) wrote :

I booted up Colony 3 today and have a bit of good news. My DVD/CDRW drive and
wireless hardware and network were all detected this time around. There's no
error this time about not finding any hard disks, but the disk partitioning step
isn't really clear about how I should proceed. My options are "Configure
software RAID", "Configure Logical Volume Manager" or "Guided partitioning"
(which just tells me I need to do it manually). I've followed both the RAID and
LVM options, but neither lets me access the partitions on the physical disk, and
warn that if I proceed, changes to the physical disk won't be possible. There's
only one disk in the machine and it currently has an NTFS partition on it that I
need to resize before installing Breezy. Although this sounds like a
functionality issue now, the folks in both the #ubuntu and #ubuntu-laptop IRC
channels said I should just add this info to this bug.

The only thought I've had is that in the BIOS I can switch between "RAID0" and
"JBOD" for the hard drive, but that warns that all data will be destroyed. If
that's what I need to do though, I will. I'll just reinstall WinXP first again
so I can test the NTFS resizing functionality in Breezy. Waiting for
confirmation on how to proceed.

Doug Holton (edtechdev) wrote :

Yeah I have a Dell 8400 with SATA hd and the colony 3 CD installer fails while
installing the base system.
I previously had Hoary with the 2.6.11 kernel (inotify disabled) and everything
worked fine.
So I don't know if this is a SATA problem, inotify problem, or what. But I
can't install Breezy at all or upgrade from Hoary to Breezy using apt-get/synaptic.

Aaron Waite (volvoguy) wrote :

Thanks for the info Doug. I'm not sure either if this is actually an SATA issue
or a problem with the Intel (software?) RAID controller that it's attached to.

For an update to the developers, this problem still occurs with Colony 3 and
daily iso's as recent as 08-27-2005. Interestingly enough, I grabbed the latest
Knoppix DVD just to see what it would do and it ran fine in live mode (using the
fb1024x768 boot option for video) and recognized/mounted my drive and existing
NTFS partition just fine. QTParted also gave me the ability to
resize/repartition the drive, but I haven't done so yet, just because we should
be able to do this in Breezy without relying on another distro for partitioning.
If there's any log files or other data that might be helpful while booted into
Knoppix, let me know and I'll make it available ASAP.

Aaron Waite (volvoguy) wrote :

Issue remains with a Breezy Daily from 09/04/2005. Last night I officially tried
everything possible to get Ubuntu installed on this laptop. It was suggested
that I change the BIOS settings on the drive from RAID to JBOD. I did so, which
wiped the hard drive, and attempted to reinstall WinXP (so I still test the NTFS
resize and such in the Breezy installer). Unfortunately Toshiba's recovery cd
would ONLY work with the hard drive in RAID mode. I also tried with my own copy
of a "real" XP disc and it didn't recognize the hard drive at all. (Sounds
familiar, huh?). I tried the Breezy daily in this mode as well and it didn't
recognize the hard drive either. At this point I think I'll just set a fan in
front of the laptop and use it to heat my office this winter. heh.

Knoppix 4.0 DVD still runs in live mode on the machine. I don't know how similar
it is to Debian anymore, but they're obviously doing something different that
allows it to recognize all the hardware (in RAID or JBOD mode).

Matthew Garrett (mjg59) wrote :

Colin, there aren't any known circumstances where a SATA device would fail to
show up, are there?

Colin Watson (cjwatson) wrote :

(In reply to comment #9)
> Colin, there aren't any known circumstances where a SATA device would fail to
> show up, are there?

<Kamion> mjg59: I don't know of a reason that would happen; but that stuff is
mostly the responsibility of hotplug these days, not of the installer itself
<mjg59> Kamion: Ok
<mjg59> Kamion: I've no idea what the right debugging steps are there
<Kamion> my inclination would be to boot the install CD with init=/bin/sh, 'nano
/etc/hotplug/hotplug.functions', uncomment the DEBUG= line near the top, 'exec
/sbin/init'
<Kamion> then look at /var/log/syslog after it fails

Matthew Garrett (mjg59) wrote :

Ok, the debug logs show:

Sep 6 23:01:39 kernel: [4294753.022000] ata_piix version 1.03
Sep 6 23:01:39 kernel: [4294753.022000] ACPI: PCI Interrupt 0000:00:1f.2[B] ->
GSI 19 (level, low) -> IRQ 19
Sep 6 23:01:39 kernel: [4294753.022000] PCI: Setting latency timer of device
0000:00:1f.2 to 64
Sep 6 23:01:39 kernel: [4294753.022000] ata1: SATA max UDMA/133 cmd 0xBF28 ctl
0xBF26 bmdma 0xBF00 irq 19
Sep 6 23:01:39 kernel: [4294753.022000] ata2: SATA max UDMA/133 cmd 0xBF18 ctl
0xBF16 bmdma 0xBF08 irq 19
Sep 6 23:01:39 kernel: [4294753.183000] ATA: abnormal status 0xFF on port 0xBF2F
Sep 6 23:01:39 kernel: [4294753.183000] ata1: disabling port
Sep 6 23:01:39 kernel: [4294753.183000] scsi0 : ata_piix
Sep 6 23:01:39 kernel: [4294753.345000] ATA: abnormal status 0xFF on port 0xBF1F
Sep 6 23:01:39 kernel: [4294753.345000] ata2: disabling port

ata_piix seems to be failing to handle this machine. ahci can also drive this
part, but we don't seem to be trying it (and, indeed, ata_piix doesn't bail out,
so there's no real indication that it's gone wrong). I think we should be trying
ahci first, before falling back to ata_piix.

Colin Watson (cjwatson) wrote :

14:38 < mjg59> Kamion: We should be including ahci, and ahci should be loaded
before ata_piix is

Please add ahci to the sata-modules udeb. How we're going to ensure that ahci is
loaded before ata_piix, I'm not quite sure ...

Matthew Garrett (mjg59) wrote :

Has this been done?

Kernel side is committed in bazaar and it will be part of the next breezy kernel.

Reassigning to initramfs to sort out the load order problem that needs to be
done in userland.

Fabio

Doug Holton (edtechdev) wrote :

I just tried the Colony 5 installer, and this time it didn't even recognize my
CD-ROM drive. I'll try with AHCI turned off in the BIOS.

Matthew Garrett (mjg59) wrote :

Colin, does the current daily have a new d-i build?

Doug Holton (edtechdev) wrote :

Ubuntu RC1 works for me, just an unrelated xorg issue. Great work!

Aaron Waite (volvoguy) wrote :

Sorry for the lack of feedback, but there really hasn't been anything to report.
I've tried Colony 4 and 5, a handful of daily builds and now RC1 and the
symptoms are still exactly the same as when we started. I'm sure it's still the
same issue. When I get to the partitioning stage, my only option is manual
partitioning, and on the next screens I can only configure RAID or LVM and not
modify the partitions on the disk. On the plus side, both my wired and wireless
connections are recognized earlier in the install process now. :)

Being a bugzilla newbie, I'm not going to touch all the stuff up top (like
changing the summary to "RC1"), but if that's cool just leave a note and I'll
know to do it next time. Also, I haven't gone to the trouble of getting any more
logs or diagnostic stuff from the newer builds. If that would be helpful, just
let me know and I'd be happy to do so.

Aaron Waite (volvoguy) wrote :

Just two weeks out from my spinal fusion surgery I wasn't quite ready to attempt
a Dapper Flight 1 install yet, but I fired up the live cd and poked around a
bit. I'm now told that my hard disk isn't detected and asked to pick a driver if
I know it. I've tried everything I think could be applicable with no luck -
ahci, ata_piix, libata, all the sata_* options, scsi_mod, sd_mod.

Perhaps the installer works differently. Give me a week or so to heal a bit more
and I'll give it a run. If there's any diagnostics gathering I can do, let me
know and I will as I'm able.

As a side note, and no offense to the Ubuntu/Debian devs, but I'm a bit sad that
Knoppix, Slax, Freesbie (the live FreeBSD thing) all run on this machine, and I
was even able to do a Knoppix > Ubuntu hack-install, but it wouldn't boot
(kernel panic). I'm REALLY looking foraward to getting this to work before the
hardware is outdated. :) I'm confident!

Aaron Waite (volvoguy) wrote :

I'm up to Flight 2 now. Instead of taking me to the "configure RAID or LVM?"
screen, the installer now tells me that a disk/controller can't be detected and
gives me a list to choose one manually. I've run through all that (I think)
apply, and a few besides, but I can't get past that point in the installer.
Perhaps this bug could be wrapped up if someone more knowledgable than myself
could take a look at some of the logs (see the URL up top) and shed some light
on disk/controller info. Perhaps there are some quirks with this hardware that I
just haven't been able to uncover with Google yet.

Matthew Garrett (mjg59) wrote :

If you've still got a USB stick, could you boot Flight-2, wait until it
complains about a missing drive, press alt+f2 and hit enter to get a shell then
dump dmesg and cat /proc/modules to the stick and attach those? It'd be good to
find out what drivers are actually binding to it now.

grabbed a few log files for this issue. i didn't have the net available while i was playing so i forgot a few - but i'll get them added ASAP. i could be wrong but I think the files i DID grab contain the same info you're looking for.

i'm getting the same thing as flight 2. the installer can't find a disk/controller and it prompts me to select one manually. if there's a workable one in that list, it doesn't work without any special parameters passed to it, as i tried all of them (as i'm sure the installer does as well).

i'm off to grab a few more log files for ya'll. let me know if you prefer attachments rather than a link to the files on my website.

Aaron Waite (volvoguy) wrote :

ok. lots of log files at the second web address given above.

Changed in initramfs-tools:
assignee: adconrad → ben-collins
Ben Collins (ben-collins) wrote :

Thanks for all the reports. I did find this:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123087

Seems this is an age old problem. I'm trying to contact Jeff Garzik to see if he has any comments.

Changed in linux-source-2.6.15:
status: Unconfirmed → In Progress
Matthew Garrett (mjg59) wrote :

It's still trying to use ata_piix rather than ahci. Aaron, when the installer gets stuck, can you switch to a console (alt+F2) and do

rmmod ata_piix
modprobe ahci

and then save the dmesg that that produces?

Aaron Waite (volvoguy) wrote :

Hey Matthew. There's no rmmod at that point in the installation (unless I'm doing something wrong). Is there another way to unload that module? Neither the main or laptop IRC channels had any suggestions (or even acknowledgement of my question. doh!).

Matthew Garrett (mjg59) wrote :

Hmm. Try

modprobe -r ata_piix

and if that doesn't work, we'll have to build rmmod into a d-i image for you.

Aaron Waite (volvoguy) wrote :

That didn't work, but I didn't have my USB thing handy. I'll try it again and get you some logs. Stand by...

Aaron Waite (volvoguy) wrote :

Ok... threw a few more logs on my site. I did dmesg and lsmod and added a "adjustedmodules" to the filename to differentiate them.

http://www.volvoguy.net/ubuntu/laptop-dapper/

I tried going back to the installer after the modprobe stuff and it still didn't detect anthing. Well, except for the USB key I forgot to remove. :o)

Let me know what's next and I'll try to get it done yet tonight.

Matthew Garrett (mjg59) wrote :

That shows ata_piix getting unloaded, and ahci is loaded. However, ahci hasn't bound to anything. Did you unload ata_piix before loading ahci? It won't work otherwise.

Matthew Garrett (mjg59) wrote :

Ah, I know - ahci may have been loaded by hotplug. When you unload ata_piix can you also unload ahci, and then try loading ahci again?

Aaron Waite (volvoguy) wrote :

Please don't tell me it was that easy all along. :-|

I got Flight 3 installed and I'm updating it now. I'm guessing we don't want to close this bug though since Joe Enduser won't know to look for this workaround. The issue still needs to be fixed. That's someone else's call though I guess.

Let me know if you need any more logs from me. I'm sure I'll be visiting the IRC channel soon to start ironing out minor issues. :o)

Matthew Garrett (mjg59) wrote :

So the problem /seems/ to be that the BIOS has left the hardware in a state where ata_piix thinks it can drive it (but can't). ahci is capable of driving it, but is loaded after ata_piix has bound to the PCI device. Ben, any idea if this can be avoided? Aaron, there's a BIOS update available from toshiba.co.uk - any chance that you can try that and see if it magically fixes things?

On Thu, 2006-02-02 at 06:53 +0000, Matthew Garrett wrote:
> So the problem /seems/ to be that the BIOS has left the hardware in a
> state where ata_piix thinks it can drive it (but can't). ahci is capable
> of driving it, but is loaded after ata_piix has bound to the PCI device.
> Ben, any idea if this can be avoided? Aaron, there's a BIOS update
> available from toshiba.co.uk - any chance that you can try that and see
> if it magically fixes things?

Question is, is ata_piix really supposed to be driving it? If it is,
then the brokeness is there. If it isn't then I suspect the PCI device
table needs to be adjusted to reflect that it can't.

The next kernel has an updated ata_piix driver synced from 2.6.16-git.
Hopefully there will be an updated daily iso to test within a week.

--
Ben Collins
Kernel Developer - Ubuntu Linux

It depends - the hardware can be driven either way depending on how the BIOS sets it up. In both cases, it has the same device ID. I'll check the specs to see if we have any way of telling which mode it's in from userspace, and if so Scott says we can make sure udev only loads the correct module.

On Thu, 2006-02-02 at 16:22 +0000, Matthew Garrett wrote:
> It depends - the hardware can be driven either way depending on how the
> BIOS sets it up. In both cases, it has the same device ID. I'll check
> the specs to see if we have any way of telling which mode it's in from
> userspace, and if so Scott says we can make sure udev only loads the
> correct module.

The alternative (which I prefer) is if we can get the ata_piix module to
detect that it is in this state and just ignore the device (not bind to
it) so that ahci can grab it. Would also need ahci to have the same
detection.

This prevents users from doing weird things. The udev approach would
allow users to break things on their own.

--
Ben Collins
Kernel Developer - Ubuntu Linux

Matthew:

Would you like me to do a clean install after the BIOS update or is there another way to get the information you need? If you do want me to reinstall, should I use a daily build at this point?

*booting into Windows for BIOS update (Toshiba recommended method). ugh*

Aaron

Ben Collins (ben-collins) wrote :

Anyway you can restest with dapper?

Aaron Waite (volvoguy) wrote :

Hey Ben. I got Dapper Flight 3 installed with Matthew's help with loading/unloading modules. I've been keeping it up to date and haven't run into any issues related to this bug. Would you like me to reformat and do a fresh install of Flight 4? A daily build? Just let me know. I haven't added any extra stuff to make the machine usable to me yet (Inkscape & a few other graphics tools), so I'm not out anything if I need to reformat.

Thanks.

> Hey Ben. I got Dapper Flight 3 installed with Matthew's help with
> loading/unloading modules. I've been keeping it up to date and haven't
> run into any issues related to this bug. Would you like me to reformat
> and do a fresh install of Flight 4? A daily build? Just let me know. I
> haven't added any extra stuff to make the machine usable to me yet
> (Inkscape & a few other graphics tools), so I'm not out anything if I
> need to reformat.

Yes, a clean install would help find out if things were fixed. Thanks.

Changed in linux-source-2.6.15:
status: In Progress → Needs Info

I can confirm that this bug still exists in Dapper flight 5.

I attempted an install on one of these laptops last night, laptop was running the most recent bios supplied on the Toshiba website (v1.50 as of this writing). I experienced the same problems as above, you get to the partitioning step and are unable to view or modify any partition information.

I was able to get around this using the info from Matthew Garrett of:
alt+f2 (drop to shell)
modprobe -r ata_piix
modprobe -r ahci
modprobe ahci
alt+f1 (back into installer)

once this was done the installer can successfully view and edit the partitions, I was able to get through the rest of the install and the laptop can now boot normally.

Aaron Waite (volvoguy) wrote :

Sorry for the delay folks. I'm having some issues related to my back surgery and haven't been able to do much lately. I'm downloading Flight 6 right now and hope to give you some install feedback soon. FWIW, the Flight 3 install Matthew helped get working is still working great. Nvidia binary drivers (and "nv" for that matter) work fine on this new(er) mini pci-e video card, and I've even been running Xgl with great results.

I'll get the new install notes in here ASAP.

Aaron Waite (volvoguy) wrote :

I'm not sure if this applies at all, but I thought I'd give the Kubuntu LiveCD installer a run. I can get all the way to a desktop now and I couldn't with earlier Flight releases. One big ouch though (and I was warned, so I won't complain) - going through the install wizard, once I got past the timezone page, the wizard just disappeared. Fearing the worst, I started up QTParted to see if it still recognized my Windows and previous Dapper install and it reported the disk as completely empty (although it DID see the disk. that's an improvement!). Rebooting of course I got a GRUB Error 22, which I don't *think* is fixable. If it's truly hosed I guess I'll have to start from scratch and install Windows and attempt an install again with the regular install cd.

Aaron Waite (volvoguy) wrote :

Quick note... Thank God for gpart. :-) Burning a regular Ubuntu install CD now.

Aaron Waite (volvoguy) wrote :

No go with the Dapper Beta (Ubuntu, install cd). Same symptoms as before. I'm asked to manually partition the hard drive and when I select "ok", the only options I have are for configuring RAID or LVM.

Unloading/loading of modules by hand again allowed me to get things installed.

Matthew Garrett (mjg59) wrote :

Aaron, could you possibly attach the output of

sudo lspci -vxxx

? I'm in the process of trying to track this down.

On 5/9/06, Matthew Garrett <email address hidden> wrote:
> Aaron, could you possibly attach the output of
>
> sudo lspci -vxxx
>
> ? I'm in the process of trying to track this down.

Sure Matthew. Do you want the output from my current install (Beta 1 I
think) or when I'm trying to do an install with Flight 7 that I just
downloaded? (or both). I'm short one network cable at the moment but
I'll try to get this for you before I crash tonight.

Aaron

Either is fine - they should be identical.

--
Matthew Garrett | <email address hidden>

Download full text (23.0 KiB)

On 5/10/06, Matthew Garrett <email address hidden> wrote:
> Either is fine - they should be identical.

Ok. This is Beta 2 with updates applied as of May 10th. If you'd
prefer an attachment I can do that too.

0000:00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML
Express Processor to DRAM Controller (rev 03)
 Subsystem: Toshiba America Info Systems: Unknown device 0001
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] #09 [2109]
00: 86 80 90 25 06 00 90 20 03 00 00 06 00 00 00 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 79 11 01 00
30: 00 00 00 00 e0 00 00 00 00 00 00 00 00 00 00 00
40: 00 50 00 f0 00 00 00 f0 00 00 00 e0 00 40 00 f0
50: 00 00 02 00 03 00 00 b8 00 00 00 00 00 00 00 00
60: 01 30 d1 fe 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
90: 10 11 11 10 01 11 33 00 00 00 00 00 20 4a b8 00
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 09 00 09 21 42 e8 eb b0 0a 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 04 00 10 00 00 00

0000:00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI
Express Root Port (rev 03) (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
 Memory behind bridge: ce000000-cfffffff
 Prefetchable memory behind bridge: b0000000-bfffffff
 Capabilities: [88] #0d [0000]
 Capabilities: [80] Power Management version 2
 Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable+
 Capabilities: [a0] #10 [0041]
00: 86 80 91 25 07 04 10 00 03 00 04 06 08 00 01 00
10: 00 00 00 00 00 00 00 00 00 01 01 00 f0 00 00 20
20: 00 ce f0 cf 00 b0 f0 bf 00 00 00 00 00 00 00 00
30: 00 00 00 00 88 00 00 00 00 00 00 00 0a 01 08 00
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 02
80: 01 90 02 c8 00 00 00 00 0d 80 00 00 79 11 01 00
90: 05 a0 01 00 00 00 e0 fe c9 40 00 00 00 00 00 00
a0: 10 00 41 00 00 00 00 00 00 00 01 00 01 2d 01 02
b0: 40 00 01 11 80 25 00 00 c0 01 48 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 07 00 00 00
f0: 00 00 01 00 00 00 00 00 00 00 04 00 00 00 80 b3

0000:00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
 I/O behind bridge: 0000c000-0000cfff
 Memory behind bridge: cdf00000-cdffffff
 Capabilities: [40] #10 [0041]
 Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable+
 Capabilities: [90] #0d [0000]
 Capabilities: [a0] Power Management version 2
00: 86 80 60 26 07 04 10 00 03 00 04 06 08 00 81 00
10: 00...

Right, despite repeatedly being told that this is an ahci device, ata_piix attempts to go ahead and use it anyway. I'm talking to upstream about this to try to sort a fix.

Drew Woodard (drew-woodard) wrote :

I installed Dapper Drake RC1 on a Toshiba S100 laptop this weekend using the graphical installer "Desktop CD" and did not experience any of the previously mentioned drive detection issues.

I had installed Flight5 on this laptop previously and ran into the same old bug with the installer getting confused when it ran into the raid controller. I decided to try RC1, the installer correctly identified the drive and existing partitions, formatted the partitions and installed correctly.

I am reluctant to claim this bug has been fixed due to my very limited understanding of the specific issue. But given that I had run into this issue with flight5 on this exact same laptop and can now install fine using RC1 this bug may be history.

Colin Watson (cjwatson) wrote :

Any chance you could try the alternate install CD as well? We're continuing to support that, so I don't want to close bugs on the basis that they don't occur when using the desktop CD.

Aaron Waite (volvoguy) wrote :

My last install was RC1 of the traditional installer CD and the bug was still there. As Matthew pointed out, the wrong modules are still getting loaded. Once I switch them around (as mentioned earlier in this report), and do my ritual "please work" dance, the install works as expected.

I haven't downloaded a daily build since RC1. If you think a fix has been attempted on this bug since then I'd be happy to do an install.

Drew Woodard (drew-woodard) wrote :

You were right, while I was able to partition and install using the graphical "desktop cd" I was unable to get the current text-based cd to work.

I booted off:
ubuntu-6.06-rc-server-i386.iso
chose text install, and it sits there endlessly at the partition step till you break out.

Aaron Waite (volvoguy) wrote :

Just a quick note - you guys might want some log files to confirm....

I just installed Eft Knot 1 with the desktop CD and everything seemed to install fine. There was no unloading/loading/reloading of modules to get the hard disk recognized this time around. If you'd like some logs or prefer to see what the "alternative install" disc does, let me know and I'll report back. Otherwise it seems this bug may be officially squished. Yay!

Changed in linux-source-2.6.17:
importance: Untriaged → High
status: Unconfirmed → Confirmed
status: Confirmed → Fix Released
Froggy (thrabalek) wrote :

Isn't it the same bug as in #56441?

Rocco Stanzione (trappist) wrote :

Either way, is it still a problem with dapper final?

Aaron Waite (volvoguy) wrote :

Rocco:

In my experience - yes. The bug still existed with Dapper final. With my good luck with Edgy though I'm hoping it's been squashed finally. Yay!

Aaron

Drew Woodard (drew-woodard) wrote :

There appears to be a new problem with this notebook under Edgy.

My previous experience had been that the text based Dapper installer still had problems but the graphical installer worked fine. With the release of the Edgy betas neither seem to work.

When I attempted to install Edgy beta1:

During the graphical install process it gets stuck at 94%, at the step:
installing grub boot loader
running "update-grub"...

If I try doing the text based install I get:
installing the base system
debootstrap warning
warning: failure trying to run: chroot /target mount -t proc proc /proc

The first time I was trying to install over top of an existing Dapper, when that didn't work I zeroed the entire drive (including mbr) and left everything on the defaults, allowing the Edgy installer to wipe the drive and create the swap and ext3 partitions on its own, it still gets stuck on "update-grub".

Aaron Waite (volvoguy) wrote :

I apologize for the delay. That pesky "real life" has really been messing with my Ubuntu fun-time lately. :-\

Unfortunately I can concur with Drew. The exact same thing happened to me when I tried to install the latest Beta. Everything just stops at "update-grub". I haven't done a whole lot of troubleshooting yet. Are there any logs or diagnostics I (we) can do to help figure out what's going on? I'm missing Ubuntu on the laptop so I've been tempted to install with the last Knot release and update from there. (I know, that kinda misses the point.)

Matthew Garrett (mjg59) wrote :

Colin?

Changed in linux-source-2.6.17:
status: Fix Released → Confirmed
Drew Woodard (drew-woodard) wrote :

I tried doing another install using the Edgy RC1 nightly build from Oct 17 2006. Using the graphical installer I selected the clean install option (delete existing partitions and create new ext3 and swap partitions) and this time the installation completed successfully.

Edgy beta1 had gotten stuck at "update-grub" under the same conditions.

Drew Woodard (drew-woodard) wrote :

I tried doing an install with the "alternative" text based installer last night and that also completed successfully. So I have now done a successful install of Edgy Eft on this laptop with both the graphical install cd and the text based install cd.

It looks like this bug may be solved, let me know if any additional information is needed.

Aaron Waite (volvoguy) wrote :

I concur with Drew (although just with the live/install cd). I didn't run into any problems at all. The only reason I'd worry about closing the bug is because this has happened before - a few good builds, the a few bad builds. If the cause of the bug is known and definitely fixed though, by all means - close this ancient bug!

Hi,

I tried to install Ubuntu GNU/Linux on my brand new computer (not laptop) and ran into a problem similar to the one described here: my sata hdd was not detected.

I use a VIA VT6420 SATA RAID Controller with the RAID option disabled in the BIOS (thus selecting SATA).

I think the problem is related to bug 7415 of linux: http://bugzilla.kernel.org/show_bug.cgi?id=7415
There is stated that the bug is fixed in version 2.6.20.1 of linux. Ubuntu 6.10 livecd is running with a 2.6.17 kernel.

So, I am afraid this 'ancient bug' isn't fixed yet :-(

regards,
  Maarten Faddegon

hi,

I downloaded and burned Ubuntu Feisty Fawn Herd 4 running on a 2.6.20-8-generic kernel.

In the output of dmesg I could see a report of an abnormal status 0x7F on port 0xFD07 (see attachment and search for "ATA").

And my SATA HDD is still not detected.

regards,
  Maarten Faddegon

I filed bug report 86635 against Herd 4 which continued to Herd 5 including every other daily build since Herd 5, they seem to be the same.

Colin Watson (cjwatson) wrote :

Wow, I looked at this and am so horribly confused, particularly as to why it's filed against ubiquity. Is there any chance that the *original reporter* could provide a summary of what's still broken?

If anybody else who isn't the original reporter of this bug is tempted to chip in with similar-sounding problems that you also have, please file new bugs instead. It's much easier to mark bugs as duplicates than it is to disentangle multiple problems from a single bug.

On 3/19/07, Colin Watson <email address hidden> wrote:
> Wow, I looked at this and am so horribly confused, particularly as to
> why it's filed against ubiquity. Is there any chance that the *original
> reporter* could provide a summary of what's still broken?

Hey Colin,

As this laptop is mine now, I've temporarily loaned it to my sick
brother who's laptop recently died. I'll see if I can borrow it back
and install Herd 5 to see if the bug exists still for me. It seems as
though the last time I installed Edgy Final, things worked ok - but
this bug has disappeared and reappeared with almost every dev release
since I got the laptop. I'll let you know as soon as humanly possible.

Aaron

Aaron Waite (volvoguy) wrote :

Ok. Attempted the install tonight. It seemed to go fine, sans the broken keyboard, and it even successfully resized the existing NTFS partition. The problems now are showing up after the install. When I rebooted, the Ubuntu logo just hung there with the progress bar at zero - even after several attempts at unplugging extra mouse/keyboard I was using. I finally let it just sit there for about 5 minutes and it spit out lots of errors about ata_piix, missing modules, missing devices, and then dropped me down to a shell prompt. I suppose the next step is having you tell me how/which log files you'd like me to attach again. I'm not sure what I can do at this simple prompt it gives me, but I can boot back into the LiveCD again and do some logging. Just let me know.

Aaron

Luise Kunkle (sem-pa) wrote :

I posted this as 4427 a few days ago, in German on the forum.

Here is the same in English.

edgy does not recognize my SATA HD's

For the last 1 1/2 years I have tried to install the then current versions of ubuntu with always the above-mentioned failure. The same is happening with edgy, although the error reports on the screen have improved.

NO RAID

--------------------

hardware:

Hardware (as per bios)

Primary IDE-master HL-DT-ST DUDRAM GS ([DVD-LW]
" " slave LITE-On [CD-LW]
Secondary IDE master ---------
    " " slave ---------

Third IDE master SAMSUNG HD 120 IJ [S ATA 2]
Third IDE slave SAMSUNG HD 120 IJ [ß ATA 2]

Intel (R) celeron (R) D CPV 2.80 GHZ

----------------

lspci report

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub
Inte
rface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev
02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Contr
oller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Contr
oller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Contr
oller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Contr
oller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Cont
roller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Brid
ge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE
Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev
02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER
(ICH5/ICH5R) A
C'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce
6600/GeForce
 6600 GT] (rev a2)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139
C+ (rev 10)

--------------

Problem:

Practically right after booting the installation CD - appr. third screen- (after longish wait)

17179614.644000 ata 1: failed to set xfer mode (err mask=0x4)

further waiting (why I could copy down above number)

the same report with a different number - no time to copy this

it goes on right away: language, keyboard, network. conf..... hd and other hardware searched for

Report: no harddrives found

The listing of drivers for harddrives.

Asked someone more knowledgeable than myself, he found the following possibilities for driver:

 ***

SATA mit AHCI SATA support and support for Intel PIIX/ICH SATA support (

************

At next installation attempt I found among the drivers in the list AHCI and PID (without ICH). With both (and also with ataPIIC) after activating first blue screen, than without further comment back to list of drivers.

---------------

Since neither debian nor gentoo (nor windows xp) have any problem installing, I suppose that this is bug with ubuntu-

I suspect that ubuntu, after not finding any hd at the first and second master/slave position does not look further.

siucdude (siucdude) wrote :

I can confirm same bug, I have a toshiba qosmio g25 with 2 sata drives on it, While I tried to install 6.10 which did find the HD's with no problem, i ran into a grub error where after install reboot, grub was poining to /dev/hda1 while it should /dev/sda1, a manual change before boot was all it took,
Now Feisty, B1 can't even see the HD's, I am loaded to livecd and i can run everything but no HD to install to.

Let me know what reports to you want and I can provide.

TJ

siucdude (siucdude) wrote :

Some logs from my system,

thanks

siucdude (siucdude) wrote :

syslog

siucdude (siucdude) wrote :

dmesg

siucdude (siucdude) wrote :

I compared few of my logs from Edgy and Feisty Daily today and found that its a direct hit of ata_piix loading, first.

Lee Packham (lee-packham) wrote :

In Feisty on a Toshiba S100 laptop this occurs.

I ended up putting a init-premount script in the ramfs boot image to do:

modprobe -r ata_piix
modprobe ahci
modprobe -r ahci
modprobe ahci
modprobe ata_piix

This little dance fixes the problem and makes my laptop usable with Feisty.

Aaron Waite (volvoguy) wrote :

I'm still having this issue with Gutsy Tribe 2 on the Portege. Same end-user workaround seems to work - removing ata_piix and ahci and reloading them in the proper order.

Is a permanent fix for this something that will break most other systems? It seems as though we've know the problem and solution for years now (yes, literally!), and it was fixed for one release (Edgy I think), but keeps coming back to haunt us.

I have this machine in my possession again and a liberal application of "Deoxit" (electrical contact cleaner/protector) and some scrubbing of the ribbon cable seems to have fixed my dead keyboard problem so I can do a bit more testing again. I can't imagine the devs need any additional log files, but let me know if you do.

Aaron

John Morgan (mojoh81) wrote :

I don't have much to add to the above post except to say that I'm currently running Ubuntu 6.06 on my portege s100 since it's the only version I can install. I'd really like to upgrade and I'm happy to help with testing.

Failing that, if anyone could post a step-by-step guide to the workaround mentioned above, that would be very much appreciated.

John

Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. Thanks!

Changed in linux-source-2.6.20:
status: New → Incomplete
gmerrick (at903) wrote :

Ditto on this. This is a problem for my Tecra S3, I can get 6.10 working fine, but anything higher will not intall due to lack of proper sata support.

I am more than willing to assist in testing fixes and patches. This issue seems to effect anyone with an ICH6M chipset.

Aaron Waite (volvoguy) wrote :

Leann, I just finished downloading 7.10 and I'll try to do an install this weekend. I'm still running a little slow due to my medical problems, but I promise I WILL do it ASAP! Luckily my aforementioned homemade keyboard fix has worked on this laptop and after sitting idle for nearly a year I've been able to keep it busy again lately. I just need to do some shuffling to make room for a basic Ubuntu install - or at least an attempt. That should tell us whether or not the modules are being recognized in the right order or not.

Aaron Waite (volvoguy) wrote :

Still experiencing the bug with 7.10 Final. This time when I try the workaround, I get a "fatal error - module in use" (or similar - I can't find my USB drive right now to get you all the log files), when I try and unload "ata_piix". Just reloading "ahci" doesn't do anything either. This is with the alternate install CD.

FWIW, with the GUI installer everything *seems* to go smoothly but after the reboot, GRUB fails because it can't find the partition Ubuntu is installed on.

I'll get you developers some logs when I can. If you have any suggestions for me to try before that, let me know.

Julian (perlsite) wrote :

I've just tried to install for the first time Kubuntu 7.10 Final (never tried any Ubuntu/Kubuntu dist so far) and I stuck on the same place.

I'm not able to complete instalation due unrecognized SATA HDD.
My laptop is Toshiba Tecra S3 with Intel's ICH6.

I can confirm that ata_piix mess up the hole thing. If I run
sudo rmmod -w ata_piix
sudo modprob -r ahci

and after that:

sudo modprobe ahci
sudo modprobe ata_piix

in system log (dmesg) I can see my hdd correctly detected (/dev/sdb3 in my case).

However this is possible only if I quit X session (interrupt installation), but after that I get a lot of ugly messages that breaks squashfs mount.

Anyway I've never had a such problems with my previously installed distro (Slackware 12) and I don't know what to do to workaround this issue, because I can't complete installation of Gutsy.

If I try "text mode installation" and run "bash console" in installer menu then I can perform from console above (modprobe) commands and continue with installation (exit in console) - then it detects my SATA HDD and seems installs some core apps, but after first reboot that installer ask from me seems that installation is not complete (for example if I issue "sudo lsmod" I get an empty list!).

Please let me know what I can do or I shoud give up?

Julian (perlsite) wrote :

Ok, here is my workaround:

1. Download Alternative CD or complete DVD image
2. Chose text install -> press F6 and add (space separated) new option:

ata_piix.blacklist=yes

3. Install (K)ubuntu as usual (in text mode).

Note: above command will add ata_piix module in (/target)/etc/modprobe.d/blacklist.local which means that after installation ata_piix will continue to be NOT loaded (blacklisted).

4. After installation, be good and add ata_piix at the end of /etc/modules on a single line, so this module will be loaded after the normal boot.

5. Fix /etc/fstab to use /dev/scd0 instead of /dev/hda
  Normally ata_piix (on my machine) handle CD/DVD drive as /dev/scd0, but while installation and because ata_piix was blacklisted CDROM drive was auto detected as /dev/hda, so in order /media/cdrom to become available just fix fstab as I've noted.

Cheers!

Aaron Waite (volvoguy) wrote :

I gave the install another go tonight (with alternate install CD) and with the old installer trick with the modules I was able to get 7.10 installed. Not sure what my problem was the other night - probably a typo or something on my end. The only thing I did differently tonight was unload/reload the modules right at the start and not at the partitioning step. The install took significantly longer than any previous installations, but I'm not sure that's related.

Julian's suggested workaround didn't work for me, but again I may have done something wrong. I just got something like "invalid boot option" or something (and yes I did add a space after the existing boot options when pressing F6).

If someone wants log files, let me know - but I'm assuming that whatever the problem has been this whole time is still going on. It still breaks in the same place and works with the "usual" fix.

Julian (perlsite) wrote :

Yes, kernel tells that this is invalid boot option, but as you may know unrecognized options are passed through the chain..
According documentation on the install disk ( /media/cdrom0/doc/install/manual/en/ch05s02.html )

Section "5.2.1.3. Blacklisting kernel modules", you can read:

"You can blacklist a module using the following syntax: module_name.blacklist=yes. This will cause the module to be blacklisted in /etc/modprobe.d/blacklist.local both during the installation and for the installed system.

Note that a module may still be loaded by the installation system itself. You can prevent that from happening by running the installation in expert mode and unselecting the module from the list of modules displayed during the hardware detection phases."

So, if I add on the boot line:

ata_piix.blacklist=yes

and after boot I quit text mode installer and type:

lsmod |grep ata_piix

I don't see this module loaded which confirms that module is blacklisted. I can try to dig more, but currently at least I have working Kubuntu after all this.

Hedley Finger (hfinger) wrote :

Can this bug be upgraded to critical?

I tried installing Ubuntu 7.04 from a liveCD/installer onto a Gigabyte board GA-K8NNXP with a Silicon Image Sil 3512A onboard SATA controller chip.

Initially the installer recognised only the ATA/IDE drives (all with insufficient space), including a removable Zip drive, so I had to disconnect all ATA drives to get the installer moving.

When the installer did start properly, once it got to the partitions page, no drives were shown. I was attempting a dual-boot installation on a Seagate SATA drive on which Windows is also installed (it is the main disk).

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux:
status: New → Incomplete
Aaron Waite (volvoguy) wrote :

Hedley: I could only wish. :-) Considering Canonical's investment in this laptop and my time, I really assumed it would have been flagged as critical 2+ years ago. Apparently in spite of the fact that everyone knows what's wrong, no one has been able to fix it in that amount of time.

Leann: It'll probably be after the new year now before I can test it, but I will. My ongoing physical disability and lack of income is taking it's toll on my stock of blank CDs. If anyone wants to donate some, I'd gladly accept. :-)

Out of curiosity - It's been said many times that the misbehaving bit of software we're dealing with has been updated/fixed and it hasn't. This may be a silly question, but is someone actually trying to fix this issue or is development just pushing forward and hoping it'll get ironed out in the process? A apologize if I sound a bit jaded, but literally - we've known what's wrong and how to fix it for over two years now and it just never seems to get done. Perhaps what sounds simple to a non-developer is really a big issue in an area that's difficult to mess with - which would obviously explain why the fix is taking so long. Again - not mad or irritated or anything - just curious. Ubuntu is still my beloved distro and I promote it locally every chance I get! :-)

P.S. - would adding the current development name in the bug's title/subject make it a little more visible after all these years? I opened the bug, but I'm never sure which bits I should be adding/changing.

Aaron Waite (volvoguy) wrote :

Well, I have some good news. :-) Hardy Heron Alpha 2 LiveCD installed just fine this time. Recently the problem hasn't been during install with the live cd, but with booting into the system after install. With Alpha 2 everything seems to work great!

If possible though I'd like to hold off closing this bug until further into development or the final release. We've had things working during development before, only to have them broken for the final release. That's just my opinion - you guys are the bosses.

If there's any logs or anything you need from me, let me know and I'll get them for you.

Good work!

Hi Aaron,

Thanks for testing and the update. I'm glad to hear things are working with the newer Hardy Alpha release. Regarding keeping the bug open, we usually follow a different procedure. Once we get confirmation that the bug is resolved we mark the bug as "Fix Released" against the appropriate package. If it is the case that you notice a regression with subsequent releases, feel free to reopen the bug (ie change the status back to 'New') and post a comment about the regression. Those subscribed to the bug will be notified accordingly. Thanks.

Changed in linux:
status: Incomplete → Fix Released

Just adding a note that this bug is being closed against 2.6.15 and 2.6.20. Thanks.

Changed in linux-source-2.6.15:
status: Incomplete → Won't Fix
Changed in linux-source-2.6.20:
status: Incomplete → Won't Fix
Mackenzie Morgan (maco.m) wrote :

In Hardy 8.04.1 or in Intrepid, are the Ubiquity and initramfs components fixed?

Changed in initramfs-tools:
status: New → Incomplete
Aaron Waite (volvoguy) wrote :

My last install was the default (via live cd) with Hardy final and I didn't have any problems with that particular build. I'll note though that this has happened in the past - it'll look like it's fixed in a late beta or final release, and then be broken again when the next version comes around. I assume this means that the problem is farther upstream, but I'm not a developer-type so I can't say for sure. :-)

I'm a bit swamped right now with medical problems and a death in the family, but I'll try a nightly build (or one that someone suggests) as soon as I'm able. Now I have to go find out what animal is "Intrepid". Heh. Let me know if there's anything else I can do.

Changed in initramfs-tools:
status: Incomplete → Fix Released
Changed in ubiquity:
status: Confirmed → Fix Released
akew howhow (bellazatnika) wrote :

problem booting

Changed in initramfs-tools (Ubuntu):
assignee: nobody → Anuradha ishan (123ishan)
Changed in linux (Ubuntu):
assignee: nobody → Anuradha ishan (123ishan)
Changed in linux-source-2.6.15 (Ubuntu):
assignee: Ben Collins (ben-collins) → Anuradha ishan (123ishan)
Changed in linux-source-2.6.20 (Ubuntu):
assignee: nobody → Anuradha ishan (123ishan)
Changed in ubiquity (Ubuntu):
assignee: nobody → Anuradha ishan (123ishan)
Phillip Susi (psusi) on 2018-05-08
Changed in linux-source-2.6.15 (Ubuntu):
assignee: Anuradha ishan (123ishan) → Ben Collins (ben-collins)
Changed in linux (Ubuntu):
assignee: Anuradha ishan (123ishan) → nobody
Changed in initramfs-tools (Ubuntu):
assignee: Anuradha ishan (123ishan) → nobody
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Anuradha ishan (123ishan) → nobody
Changed in ubiquity (Ubuntu):
assignee: Anuradha ishan (123ishan) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.