ipw2200 kernel module working erratically in linux-image-2.6.10-5-686 version 2.6.10-34.2

Bug #17978 reported by Eric van der Vlist on 2005-06-10
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Fabio Massimo Di Nitto

Bug Description

The machine is a Sony VAIO VGN-S2XP laptop.

lspci -v gives:

0000:02:0b.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)
        Subsystem: Intel Corp.: Unknown device 2753
        Flags: bus master, medium devsel, latency 64, IRQ 9
        Memory at d0206000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2

The wireless that used to work beautifully under Ubuntu Warty is using the
ipw2200 kernel module (I am using WEP and managed mode).

After upgrading to Ubuntu Hoary, linux-image-2.6.10-5-686 version 2.6.10-34
introduced a slight degradation: the wireless that comes up OK at boot time
stops working after a while without any error message in the logs. However, if I
type the following commands:

sudo rmmod ipw2200
sudo modprobe ipw2200
sudo ifup eth1

the wireless can then work for days without any problem.

After upgrading to linux-image-2.6.10-5-686 version 2.6.10-34.2, I have the same
issue after rebooting with the difference that after bringing the wireless down
and up again, it remains unstable and stops working after 10 minutes or so.

Thanks,

Eric

Eric van der Vlist (vdv) wrote :

I don't know if that can help, but I am now testing the -386 flavor of the same
version (ie linux-image-2.6.10-5-686 version 2.6.10-34.2) and this one seems to
be more stable.

Any reason why the ipw2200 module of -686 kernels might not work on a Pentium M?

Eric

This is pretty strange given that the ipw2200 hasn't been touched at all.

from -34 to -34.2 there have been only security updates.

Matt Zimmerman (mdz) wrote :

The version of the driver which released with Hoary has always been somewhat
flaky, and we should consider an update

(In reply to comment #3)
> The version of the driver which released with Hoary has always been somewhat
> flaky, and we should consider an update

That would have a pretty high cost since ipw2200 depends on ieee80211 that would
require
to be updated too.. and as a consequence ipw2100.

Fabio

Edwin Shin (eddie) wrote :

This is a "me too", although I can't confirm if it was do to updating to
2.6.10-5-686 or not as it was one of the first updates I did.
This is on a new Hoary install on a Dell Latitude D600. But ipw2200 that ships
with Hoary is very flakey. I was running the 1.0.x series of the ipw2200 module
using another distro on this laptop and never experienced this. Now I frequently
have to reload ipw2200, and get a bunch of the following in the kernel log:

localhost kernel: ipw2200: Fatal error
localhost kernel: ipw2200: Start IPW Error Log Dump:
localhost kernel: ipw2200: Status: 0x00100101, Config: 00000140

Is (officially) updating ipw2200 for Hoary a possibility?

Eric van der Vlist (vdv) wrote :

I have this same error from time to time, but I have not seen any correlation
between this error and the failures.

To summarize what I am seeing in case that wasn't clear in my first post and to
take into account new things I have tried:

* With Ubuntu Warty, the support of ipw2200 was perfect: it had been detected
right away during the installation process and was working perfectly.
* After upgrade to Hoary and with linux-image-2.6.10-5-686 version 2.6.10-34,
the network goes up after a reboot, fails after a while and becomes then very
stable after a rmmod/modprobe/ifup. I haven't tried to do the
rmmod/modprobe/ifup before the initial failure.
* Same thing with linux-image-2.6.10-5-386 version 2.6.10-34.2.
* With linux-image-2.6.10-5-686 version 2.6.10-34.2, ipw2200 is always flakey
and I have to reload it ~ every 15 minutes or so.

I have thus two workarounds: stay with linux-image-2.6.10-5-686 version
2.6.10-34 that is optimized for the processor I am using but may have security
issues or move to linux-image-2.6.10-5-386 version 2.6.10-34.2 which should be
safer but less optimized for the microprocessor.

The error message mentioned Edwin Shin was already issued at boot time under
Warty without any visible consequence and that still seems to be the case with
Hoary.

Eric

David Rasch (rasch) wrote :

me too in linux-image-2.6.10-5-386

Eric van der Vlist (vdv) wrote :

Hmmm... I have upgraded to linux-image-2.6.10-5-686 version 2.6.10-34.2 and the
problem seems to have disappeared for me (it's working perfectly since the last
power up ~ 3 days ago).

Is there any difference in this latest version that could explain that?

Thanks,

Eric

Charles Majola (chmj) wrote :

fixed in 2.6.12-4.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.