Ubuntu 6.06not reognising onboard Nic

Bug #132515 reported by Minimos on 2007-08-14
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

Both the live-cd and a hard disk install of Ubuntu 6.06 does not recognise the on-board nic of the motherboard an MSI 6390.

It appears from the MSI website that the lan controller is an 8101 which I believe after some research is based on the 8139 family so should be supported.

I have also tried a Live-cd of 6.10 to the same effect. An attempt to use 7.04 failed with a tty error whilst booting

The nic works within Windows

Minimos (wayne-myers) wrote :

I have installed another network card in a PCI slot, this time a D-Link 538TX. It has the same result.

After further investigation disabling power management on the motherboard has got the D-Link recognised

TerryG (tgalati4) wrote :

Triaged to Incomplete. Reporter used a new nic card as a work-around. Don't know if newer kernel has better support for on-board MSI nic card.

Changed in linux-source-2.6.15:
status: New → Incomplete
TerryG (tgalati4) wrote :

Changed status to Fixed Release. Looks like there is a driver for 8139 in Gutsy:

8139cp.ko located in /lib/modules/2.6.22-14-generic/kernel/drivers/net

Perhaps reporter needs to issue:

>sudo modprobe 8139cp

to see if NIC works. If so, then place 8139cp in /etc/modules.

Closing out this bug.

Changed in linux-source-2.6.15:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers