kernel crashes on lvremove

Bug #103729 reported by Andy Wettstein on 2007-04-06
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
High
Ben Collins

Bug Description

Binary package hint: linux-image-server

During my nightly backups the kernel crashed while performing an lvremove:

Apr 6 02:02:14 phyori kernel: [57407058.930000] kernel BUG at drivers/md/kcopyd.c:145!
Apr 6 02:02:14 phyori kernel: [57407058.930000] invalid operand: 0000 [#1]

This was on dapper.

There appears to be a more information and a patch for this here:

http://lkml.org/lkml/2006/4/27/360

Changed in linux-meta:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

This was applied on the stable 2.6.16 tree and is a good target for the dapper point release.

http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.16.y.git;a=commit;h=f6a731290ca18b31fd447989319eb913d9c308d8

Changed in linux-source-2.6.15:
assignee: ubuntu-kernel-team → ben-collins
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

linux-source-2.6.15 (2.6.15-51.63) dapper-proposed; urgency=low

  * Fix kernel-versions for ABI bump
  * Fix for kernel crash on lvremove
    - LP: #103729
  * e1000: Disable MSI by default. Allow it to be enabled with module param.
    Some chip implementations seem to not work well with MSI.
    - LP: #56885
  * tg3: Backport from 2.6.16.y
    - LP: #72696
  * Add r1000 to nic-modules
    - LP: #81782
  * Add bnx2 to nic-modules
    - LP: #73647
  * usb-serial: Fix oops with pilot-link
    - LP: #39518
  * megaraid: Move AMI/Megaraid3 IDs from megaraid_mbox.ko to megaraid.ko
    - LP: #57233

 -- Ben Collins <email address hidden> Tue, 23 Oct 2007 16:57:09 -0400

Please test and give feedback here.

Henrik Nilsen Omma (henrik) wrote :

Leann writes:
"I am unable to reproduce this bug. I tried all sorts of combinations of creating/removing lvm snapshots but everything just worked. If there is
a known proven test case to flush out this bug I'd be more than willing to give it a go."

Hi Andy,

Thanks for the pointer. Unfortunately I'm still unable to reproduce the bug. I went ahead and ran the script you pointed to which repeatedly creates and removes the second snapshot. At the same time I was performing i/o to the logical volume origin. I let these run for well over 30min. Every once and a while I'd see messages like:

device-mapper: Error reading/writing snapshot
device-mapper: snapshot is marked invalid

However, I never witnessed the bug reported here. How often do you see this? And are you able to readily reproduce it? Thanks.

On Tue, Dec 18, 2007 at 12:50:43AM -0000, Leann Ogasawara wrote:
> Hi Andy,
>
> Thanks for the pointer. Unfortunately I'm still unable to reproduce the
> bug. I went ahead and ran the script you pointed to which repeatedly
> creates and removes the second snapshot. At the same time I was
> performing i/o to the logical volume origin. I let these run for well
> over 30min. Every once and a while I'd see messages like:
>
> device-mapper: Error reading/writing snapshot
> device-mapper: snapshot is marked invalid
>
> However, I never witnessed the bug reported here. How often do you see
> this? And are you able to readily reproduce it? Thanks.

Ok. I finally had some time to test it. I was able to reliably crash
the machine by running a mkfs on the logical volume while that script
was running. Updating to 2.6.15-51.64, I was no longer able to
crash it while the mkfs was running, so I think it is probably fixed.

Thanks for the testing and the update Andy. I am now able to successfully confirm the bug via Andy's suggestion of doing a mkfs to the logical volume origin while the script for creating/removing a second snapshot is running, After updating to the 2.6.15-51.64 kernel I am no longer able to trigger the Oops. I'm marking this report as 'verification-done'. Thanks!

Martin Pitt (pitti) wrote :

Thanks to all for the testing. Fixed kernel is in dapper-updates now.

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers