Dragonboard fails to boot: hangs after SMMU init

Bug #1841893 reported by Paolo Pisati
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-snapdragon (Ubuntu)
Undecided
Unassigned
Bionic
Critical
Unassigned

Bug Description

Impact:

Ubuntu-snapdragon-4.15.0-1061.68 hangs during boot:

...
[ 1.856849] arm-smmu da0000.arm,smmu: probing hardware configuration...
[ 1.859296] arm-smmu da0000.arm,smmu: SMMUv2 with:
[ 1.865845] arm-smmu da0000.arm,smmu: stage 1 translation
[ 1.870658] arm-smmu da0000.arm,smmu: address translation ops
[ 1.876121] arm-smmu da0000.arm,smmu: non-coherent table walk
[ 1.881936] arm-smmu da0000.arm,smmu: (IDR0.CTTW overridden by FW configuration)
[ 1.887760] arm-smmu da0000.arm,smmu: stream matching with 4 register groups
[ 1.895337] arm-smmu da0000.arm,smmu: 2 context banks (0 stage-2 only)
[ 1.902455] arm-smmu da0000.arm,smmu: Supported page sizes: 0x63315000
[ 1.908852] arm-smmu da0000.arm,smmu: Stage-1: 32-bit VA -> 36-bit IPA
[hangs here]

Fix:

During the Ubuntu-snapdragon-4.15.0-1061.68, the qcom smmuv2 implementation was replaced with an upstream generic version that didn't explicit clocks, power requirements and early init via IOMMU_OF_DECLARE() - reverting the upstream patch, and reapplying the original qcom patch that was dropped, fixes this hang.

How to test:

Try to boot a patched kernel and see if it reaches userspace.

Regression potential:

None, since the current kernel version doesn't boot at all.

CVE References

Paolo Pisati (p-pisati)
description: updated
Paolo Pisati (p-pisati)
description: updated
Changed in linux-snapdragon (Ubuntu):
status: New → Invalid
Changed in linux-snapdragon (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Critical
Changed in linux-snapdragon (Ubuntu Bionic):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (236.6 KiB)

This bug was fixed in the package linux-snapdragon - 4.15.0-1062.69

---------------
linux-snapdragon (4.15.0-1062.69) bionic; urgency=medium

  * bionic/linux-snapdragon: 4.15.0-1062.69 -proposed tracker (LP: #1842713)

  * Kernel hangs during msm init (LP: #1841911)
    - Revert "drm/msm: Depopulate platform on probe failure"

  * Dragonboard fails to boot: hangs after SMMU init (LP: #1841893)
    - Revert "iommu/arm-smmu: Add support for qcom, smmu-v2 variant"
    - iommu/arm-smmu: Add support for qcom,smmu-v2 variant

  [ Ubuntu: 4.15.0-62.69 ]

  * bionic/linux: 4.15.0-62.69 -proposed tracker (LP: #1842746)
  * Kernel Panic with linux-image-4.15.0-60-generic when specifying nameserver
    in docker-compose (LP: #1842447)
    - ip: frags: fix crash in ip_do_fragment()

  [ Ubuntu: 4.15.0-60.67 ]

  * bionic/linux: 4.15.0-60.67 -proposed tracker (LP: #1841086)
  * [Regression] net test from ubuntu_kernel_selftests failed due to bpf test
    compilation issue (LP: #1840935)
    - SAUCE: Fix "bpf: relax verifier restriction on BPF_MOV | BPF_ALU"
  * [Regression] failed to compile seccomp test from ubuntu_kernel_selftests
    (LP: #1840932)
    - Revert "selftests: skip seccomp get_metadata test if not real root"
  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis

linux-snapdragon (4.15.0-1061.68) bionic; urgency=medium

  * bionic/linux-snapdragon: 4.15.0-1061.68 -proposed tracker (LP: #1839979)

  * Bionic update: upstream stable patchset 2019-07-25 (LP: #1837952)
    - [Config] snapdragon: updateconfigs for CONFIG_SUN50I_ERRATUM_UNKNOWN1

  * Bionic update: upstream stable patchset 2019-08-02 (LP: #1838824)
    - [Config] snapdragon: updateconfigs for CONFIG_NOUVEAU_LEGACY_CTX_SUPPORT

  * Bionic update: upstream stable patchset 2019-07-26 (LP: #1838116)
    - [Config] snapdragon: updateconfigs for CONFIG_LDISC_AUTOLOAD
    - [Config] snapdragon: updateconfigs for CONFIG_R3964 (BROKEN)

  [ Ubuntu: 4.15.0-59.66 ]

  * bionic/linux: 4.15.0-59.66 -proposed tracker (LP: #1840006)
  * zfs not completely removed from bionic tree (LP: #1840051)
    - SAUCE: (noup) remove completely the zfs code
  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
  * [18.04 FEAT] Enhanced hardware support (LP: #1836857)
    - s390: report new CPU capabilities
    - s390: add alignment hints to vector load and store
  * [18.04 FEAT] Enhanced CPU-MF hardware counters - kernel part (LP: #1836860)
    - s390/cpum_cf: Add support for CPU-MF SVN 6
    - s390/cpumf: Add extended counter set definitions for model 8561 and 8562
  * ideapad_laptop disables WiFi/BT radios on Lenovo Y540 (LP: #1837136)
    - platform/x86: ideapad-laptop: Remove no_hw_rfkill_list
  * Stacked onexec transitions fail when under NO NEW PRIVS restrictions
    (LP: #1839037)
    - SAUCE: apparmor: fix nnp subset check failure when, stacking
  * bcache: bch_allocator_thread(): hung task timeout (LP: #1784665) // Tight
    timeout for bcache removal causes spurious failures (LP: #1796292)
    - SAUCE: bcache: fix deadlock in bcache_allocator
  * bcache: bch_allocator_thread(): hung task timeout (LP: #1784665)
    - bcache: never writeback a discard operation...

Changed in linux-snapdragon (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers