40% performance loss in Mesa with Linux 5.0

Bug #1839750 reported by Kon on 2019-08-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-signed-hwe (Ubuntu)
Undecided
Unassigned

Bug Description

Mesa's RADV performance has dropped nearly 40% across multiple applications since upgrading my HWE kernel to 5.0.0-23.

Reverting to the 4.18 kernel fixed the issue. The problem was still present when testing kernel 5.2.8 from the Ubuntu mainline PPA installed via UKUU. The latest LTS kernel release (4.19.66) worked perfectly.

My hardware:
AMD Radeon RX 570
AMD Ryzen 7 1700X
Asrock B450M Pro4 motherboard

Tested Ubuntu kernels:

4.18.0-25 (good)
5.0.0-23 (bugged)
5.0.0-25 (bugged)

Tested mainline kernels:

4.20.17 (good)
5.0.3 (bugged)
4.19.66 (good)
5.2.8 (bugged)

Tested versions of Mesa, ALL suffered performance loss under the bugged kernels:
19.0.2 from the repository
19.0.8 from the repository
19.1.2 stable from PPA
19.2-devel from PPA

Comparative performance testing was done through the benchmark tool of a native Vulkan game (Total War: Three Kingdoms), and in Steam titles using DXVK and Proton with the Steam framerate monitor.

Here is the output of sudo lshw -C:

  *-display
       description: VGA compatible controller
       product: Ellesmere [Radeon RX 470/480/570/570X/580/580X]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:23:00.0
       version: ef
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:46 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fe900000-fe93ffff memory:c0000-dffff

Thanks for taking the time to look into this.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-5.0.0-23-generic 5.0.0-23.24~18.04.1
ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
Uname: Linux 5.0.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Aug 11 04:15:28 2019
InstallationDate: Installed on 2019-02-01 (191 days ago)
InstallationMedia: Kubuntu 18.04.2 LTS "Bionic Beaver" - Beta amd64 (20190129)
SourcePackage: linux-signed-hwe
UpgradeStatus: No upgrade log present (probably fresh install)

Kon (k0n) wrote :
Kon (k0n) wrote :

I'm attaching the output of dmesg for 5.0.0-23

Kon (k0n) on 2019-08-11
description: updated
Kon (k0n) on 2019-08-11
description: updated
description: updated
Kon (k0n) wrote :

This issue persisted with the 5.0.0-25 kernel update. I later tested again after updating Mesa to 19.0.8. No change.

description: updated
Kon (k0n) wrote :

Tested additional mainline kernels installed via UKUU. 4.19.66 LTS worked great. So did 4.20.17, the last in its series. The performance regression appeared when I tested 5.0.3, and as noted above, still persists in 5.2.8.

This may be a mainline kernel bug, but I'll leave it open here for further input. I'm a complete layman in this area.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers