package linux-image-4.18.0-14-generic 4.18.0-14.15~18.04.1 failed to install/upgrade: installed linux-image-4.18.0-14-generic package pre-removal script subprocess returned error exit status 1

Bug #1813826 reported by CoderGuy on 2019-01-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-signed-hwe (Ubuntu)
Undecided
Unassigned

Bug Description

This was trigger after installing 4.18.0-14 in synaptic

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: linux-image-4.18.0-14-generic 4.18.0-14.15~18.04.1
ProcVersionSignature: Ubuntu 4.18.0-14.15~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-14-generic x86_64
NonfreeKernelModules: talpa_vfshook talpa_pedconnector talpa_pedevice talpa_vcdevice talpa_core talpa_linux talpa_syscallhook
ApportVersion: 2.20.9-0ubuntu7.5
AptOrdering:
 linux-image-4.18.0-14-generic:amd64: Purge
 NULL: ConfigurePending
 NULL: PurgePending
 NULL: ConfigurePending
Architecture: amd64
Date: Tue Jan 29 20:54:18 2019
DpkgTerminalLog:
 Removing linux-image-4.18.0-14-generic (4.18.0-14.15~18.04.1) ...
 E: Aborting removal of the running kernel
 dpkg: error processing package linux-image-4.18.0-14-generic (--remove):
  installed linux-image-4.18.0-14-generic package pre-removal script subprocess returned error exit status 1
DuplicateSignature:
 package:linux-image-4.18.0-14-generic:4.18.0-14.15~18.04.1
 Removing linux-image-4.18.0-14-generic (4.18.0-14.15~18.04.1) ...
 E: Aborting removal of the running kernel
 dpkg: error processing package linux-image-4.18.0-14-generic (--remove):
  installed linux-image-4.18.0-14-generic package pre-removal script subprocess returned error exit status 1
ErrorMessage: installed linux-image-4.18.0-14-generic package pre-removal script subprocess returned error exit status 1
InstallationDate: Installed on 2018-09-04 (147 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Python3Details: /usr/bin/python3.6, Python 3.6.7, python3-minimal, 3.6.7-1~18.04
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2.1
 apt 1.6.6ubuntu0.1
SourcePackage: linux-signed-hwe
Title: package linux-image-4.18.0-14-generic 4.18.0-14.15~18.04.1 failed to install/upgrade: installed linux-image-4.18.0-14-generic package pre-removal script subprocess returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

CoderGuy (alec-bickerton) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-signed-hwe (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers