Failure to start on 22.04

Bug #1987073 reported by s0600204
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-show-player (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

[Impact]

 * It is currently not possible to run the repository-provided version (0.5.2) of `linux-show-player` upon Ubuntu 22.04. This is caused by Ubuntu 22.04 using python 3.10, which contains some changes that breaks `linux-show-player`.

 * Linux Mint 21 has relatively recently (2022-07-31) been released, which (re)uses the Ubuntu 22.04 repositories, and as such suffers from the same issue.

 * Pop! OS 22.04 also (re)uses the Ubuntu 22.04 repositories, and as such suffers from the same issue.

 * Upstream bug reports (and backtraces) can be found at:

   - https://github.com/FrancescoCeruti/linux-show-player/issues/238
   - https://github.com/FrancescoCeruti/linux-show-player/issues/245
   - https://github.com/FrancescoCeruti/linux-show-player/issues/250
   - https://github.com/FrancescoCeruti/linux-show-player/issues/261
   - On the project's chat/discussion stream: https://gitter.im/linux-show-player/linux-show-player?at=62e657e97ccf6b6d459fc8b8

 * There exists a newer release of `linux-show-player` (0.5.3) which contains within it a fix for this issue (corrected imports and better differentiation of integer/float values).

 * Users have reported that the newer release works for them, when they install it manually.

 * The newer release is currently packaged and available in the repositories of the fledgling Ubuntu 22.10 release-to-be. (As well as the repositories of Debian 12 and Unstable.)

[Test Plan]

 * Install package from repository;

 * Attempt to run the program from the Launcher;

 * Note that it does not start, or rather: it does but crashes;

 * Attempt to run the program via a terminal [emulator]: `$ linux-show-player`;

 * Note the errors (or lack thereof with the newer release);

[Where problems could occur]

 * There are other changes contained in the gap between 0.5.2 and 0.5.3 beyond the fix for Python 3.10. That said, the other changes can be summarised as being mostly documentation and CI improvements, along with a branding update and a new translation. A full changeset may be found here: https://github.com/FrancescoCeruti/linux-show-player/compare/v0.5.2...v0.5.3

 * The changes required to get `linux-show-player` to work on python 3.10 are compatible with earlier versions of python 3.x, so there shouldn't be a problem if a user prefers to use an earlier version of python. (The project doesn't support python 2.x, and as such is not expected to run under that.)

[Other info]

 * Note that I myself do not use Ubuntu or a Ubuntu-derived distro: I am a contributor to the linux-show-player project who is filing this on behalf of our users who use Ubuntu 22.04 and Linux Mint 21. I am hoping that this is a simple case of backporting the package from 22.10 to 22.04, but lack the resources to test this.

Tags: jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-show-player (Ubuntu):
status: New → Confirmed
s0600204 (s0600204)
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers