xserver-xorg-ati driver + disk encryption + linux-rt prevents xserver start

Bug #362190 reported by Eric Hedekar on 2009-04-16
2
Affects Status Importance Assigned to Milestone
linux-rt (Ubuntu)
Low
Unassigned

Bug Description

I've tried this on Jaunty's Release Candidate and have been unable to get X running if using the linux-rt and the install option of encrypted LVM.

I have only tested this in a VM, I'll try with real hardware soon and report back.

Output of lspci | grep VGA
on my actual install: VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
on the Virtual Machine: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

Alessio Igor Bogani (abogani) wrote :

Fix that bug require to analyze plus of 2000 line of code. No way to do this in and for Jaunty Release due SRU policies. So I postponed that bug to Karminc, sorry.

Alessio Igor Bogani (abogani) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that could be fixed in the Beta release of Karmic Koala. It would help us greatly if you could test with it! Thanks again and we appreciate your help.

Changed in linux-rt (Ubuntu):
status: New → Incomplete
Eric Hedekar (stochastic) wrote :

I have briefly tested this on a VM with Ubuntu Studio Karmic's Beta (32bit version). Unfortunately it's clear that the VM was not happy after reboot, it clearly was loading, but the resolution of the VM screen was very messed (like 1600x400) and GDM did not successfully load. I am still not able to test this on physical hardware, but it's on my list of things to do before Karmic's release. I'm also not sure this bug (if valid) has much impact on Ubuntu Studio as anyone using the RT kernel probably cares more about disk access time, and encryption would just slow that down.

Changed in linux-rt (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Alessio Igor Bogani (abogani) wrote :

Eric,

Perhaps it is better open again a bug report when physical machine will be available for tests.

Thanks anyway!

Changed in linux-rt (Ubuntu):
status: Confirmed → Invalid
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers