Upgrade linux-rt to 2.6.27

Bug #281276 reported by Alessio Igor Bogani on 2008-10-10
14
Affects Status Importance Assigned to Milestone
linux-rt (Ubuntu)
Undecided
Unassigned

Bug Description

At the moment linux-rt packages are based on 2.6.26 and have a build-dep on linux-source-2.6.26.

That package don't exist anymore. Moreover Intrepid use kernel version 2.6.27 and users of rt kernel would be very happy to stick on it.

For these reasons upgrade to 2.6.27 make me sense. On my PPA there is a version of PREEMPT_RT based on 2.6.27:

https://launchpad.net/~abogani/+archive

Thanks!

This is _crucial_ for Ubuntu Studio. We are very close to have to (for the first time) make a release without a real time kernel. If we can get a freeze exception though, the linux-rt of 2.6.27 will be ready for release.

Only a few minor issues in amd64 which are being solved already.

Motin (motin) wrote :

I agree. Without linux-rt, Ubuntu Studio cannot be released... Although for me it doesn't matter if this bug is solved by upgrading all packages to .27, or downgrading all to .26 - as long as we can use a recent rt kernel in Intrepid...

What currently happens when trying to install linux-rt in Intrepid:
$ LANG=C sudo apt-get install linux-rt
...
The following packages have unmet dependencies:
  linux-rt: Depends: linux-restricted-modules-rt (= 2.6.26.1.5) but it is not going to be installed
E: Broken packages

Motin (motin) wrote :

@Alessio: You probably know this, but your version is not installable currently due to a lack of linux-restricted-modules-2.6.27-2-rt installation candidate. Log attached.

@Motin,

At the moment meta-packages as linux-rt, linux-image-rt and
linux-headers-rt are only placeholders without effects.

If you want install kernel from my PPA you should execute this command:

sudo apt-get install linux-image-2.6.27-2-rt

Luca Falavigna (dktrkranz) wrote :

Please go ahead with 2.6.27. It brings in huge improvements and we are actually unable to install -rt flavour kernels in Intrepid.

Luke Yelavich (themuso) wrote :

ACK from me, but with some reservations, hopefully which can all be fixed in SRUs.

 * On two notebooks I have here, I cannot restart/shut down with the rt kernel on either of them, one amd64, one i386.
 * Only one core of any CPU can currently be used.
 * Network Manager causes a lot of xruns at least for me, even with a high period size setting jack.

 affects ubuntu/linux-rt
 status confirmed

Changed in linux-rt:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-rt - 2.6.27-3.7

---------------
linux-rt (2.6.27-3.7) intrepid; urgency=low

  * Synced against linux-source-2.6.27 2.6.27-7.12
  * Added ext4-nrpages.patch and jbd2-nrpages.patch
  * Synced configuration

linux-rt (2.6.27-3.6) intrepid; urgency=low

  * Synced against linux-source-2.6.27 2.6.27-7.11

linux-rt (2.6.27-3.5) intrepid; urgency=low

  * Synced against linux-source-2.6.27 2.6.27-7.10
  * Bump ABI to -3

linux-rt (2.6.27-2.4) intrepid; urgency=low

  * Mistake in packaging

linux-rt (2.6.27-2.3) intrepid; urgency=low

  * Fix a FTBS

linux-rt (2.6.27-2.2) intrepid; urgency=low

  * Synced against linux-source-2.6.27 2.6.27-6.9
  * Disable CONFIG_AUFS, CONFIG_CGROUP_MEM_RES_CTLR, CONFIG_FTRACE,
    CONFIG_LATENCYTOP, CONFIG_CONTEXT_SWITCH_TRACER
  * Set timer frequency to 1000 HZ
  * Bump ABI to -2

linux-rt (2.6.27-1.1) intrepid; urgency=low

  * Initial version based on linux-source-2.6.27 2.6.27-4.6 (LP: #281276)

 -- Alessio Igor Bogani <email address hidden> Sat, 18 Oct 2008 18:08:55 +0200

Changed in linux-rt:
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

linux-rt 2.6.27-3.7 accepted into intrepid.

I hope I'm not stepping on toes reopening this. I wasn't able to find guidelines about already closed reports.

Using the linux-rt 2.6.27-3.8 released yesterday I still have at least some of the issues listed in the above comment by Luke Yelavich (https://bugs.launchpad.net/ubuntu/+source/linux-rt/+bug/281276/comments/6).

Only one CPU is used and shutdown/restart do not work. Perhaps of note is that the rt variant does not set CONFIG_NR_CPU which is set to 64 in 2.6.27-7-generic and 8 in the old 2.6.24-21-rt and also does not set CONFIG_SMP which set to y on the others.

After booting 2.6.27-3-rt dmesg contains this line:

[ 0.000000] WARNING: NR_CPUS limit of 1 reached. Processor ignored.

Compared to booting the non-rt 2.6.27-7-generic:

[ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
[ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
[ 0.000000] NR_CPUS: 64, nr_cpu_ids: 2, nr_node_ids 1

Changed in linux-rt:
status: Fix Released → Confirmed
Andrew Hunter (rexbron) wrote :

Thomas, the issues listed are more appropriate as a separate bug report.

Changed in linux-rt:
status: Confirmed → Fix Released

Makes sense. Opened #290498

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers