package linux-restricted-modules-2.6.28-8-generic 2.6.28-8.9 failed to install/upgrade:

Bug #334846 reported by thosjo on 2009-02-26
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
Undecided
Unassigned

Bug Description

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.28-8-generic
Errors were encountered while processing:
 linux-restricted-modules-2.6.27-12-generic
 linux-restricted-modules-2.6.28-8-generic
 linux-restricted-modules-generic
 linux-generic
Traceback (most recent call last):
  File "/usr/lib/python2.5/logging/__init__.py", line 753, in emit
    self.flush()
  File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
jaunty: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
Setting up linux-restricted-modules-2.6.28-8-generic (2.6.28-8.9) ...
mount: permission denied
dpkg: error processing linux-restricted-modules-2.6.28-8-generic (--configure):
 subprocess post-installation script returned error exit status 32
dpkg: dependency problems prevent configuration of linux-restricted-modules-generic:
 linux-restricted-modules-generic depends on linux-restricted-modules-2.6.28-8-generic; however:
  Package linux-restricted-modules-2.6.28-8-generic is not configured yet.
dpkg: error processing linux-restricted-modules-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-restricted-modules-generic (= 2.6.28.8.8); however:
  Package linux-restricted-modules-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
Setting up linux-restricted-modules-2.6.27-12-generic (2.6.27-12.17) ...
dpkg: error processing linux-restricted-modules-2.6.27-12-generic (--configure):

Dell Latitude C800:
thosjo@thosjo-lab:~$ lspci
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82815 815 Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801BAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801BAM IDE U100 Controller (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M4 AGP
02:03.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev 10)
02:06.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus [Cyclone] (rev 10)
02:06.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem (rev 10)
02:0f.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:0f.1 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:0f.2 FireWire (IEEE 1394): Texas Instruments PCI4451 IEEE-1394 Controller

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu jaunty (development branch)
Release: 9.04
Codename: jaunty

$ dpkg -l |grep restricted
ii linux-restricted-modules-2.6.27-10-generic 2.6.27-10.14 Non-free Linux kernel modules for version 2.
ii linux-restricted-modules-2.6.27-11-generic 2.6.27-11.16 Non-free Linux kernel modules for version 2.
iF linux-restricted-modules-2.6.27-12-generic 2.6.27-12.17 Non-free Linux kernel modules for version 2.
ii linux-restricted-modules-2.6.27-7-generic 2.6.27-7.12 Non-free Linux kernel modules for version 2.
iF linux-restricted-modules-2.6.28-8-generic 2.6.28-8.9 Non-free Linux kernel modules for version 2.
ii linux-restricted-modules-common 2.6.28-8.9 Non-free Linux 2.6.28 modules helper script
iU linux-restricted-modules-generic 2.6.28.8.8 Restricted Linux modules for generic kernels

$ uname -a
Linux thosjo-lab 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: subprocess post-installation script returned error exit status 32
Package: linux-restricted-modules-2.6.28-8-generic 2.6.28-8.9
SourcePackage: linux-restricted-modules
Title: package linux-restricted-modules-2.6.28-8-generic 2.6.28-8.9 failed to install/upgrade:
Uname: Linux 2.6.27-11-generic i686

thosjo (thomas-sjogren) wrote :
Michael Vogt (mvo) wrote :

Here is the error:

Setting up linux-restricted-modules-2.6.27-12-generic (2.6.27-12.17) ...
...
mount: permission denied
dpkg: error processing linux-restricted-modules-2.6.27-12-generic (--configure):
 subprocess post-installation script returned error exit status 32

Is there anything unusual about your system configuration that might prevent mount from
being run as root?

thosjo (thomas-sjogren) wrote :

Hi again,
no there wasn't anything unusual about the configuration. Standard installation on an Dell Latitude laptop.
This problem hasn't occured afterwards so it seems only the linux-restricted-modules-2.6.27-12-generic was affected by this issue.

tags: added: dist-upgrade
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers