Internet connection lost using hibernate or suspend mode

Bug #310158 reported by wordsmyth on 2008-12-21
This bug report is a duplicate of:  Bug #275692: ath_pci must be reloaded after resume. Edit Remove
8
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.27 (Ubuntu)
Undecided
Unassigned
linux-restricted-modules (Ubuntu)
Undecided
Unassigned

Bug Description

Internet connection lost using hibernate or suspend mode

Hi there: I've a feeling I'm not the only one with this problem. Does anyone have some advice on how to fix this?
I'm using Ubuntu 8.10 & have downloaded all updates. Had the same problem with 8.4. Frustrating...

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: ath_hal
Package: firefox-3.0 3.0.5+nobinonly-0ubuntu0.8.10.1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-9-generic i686

wordsmyth (wordsmyth-netspace) wrote :
description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't fix it because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

wordsmyth (wordsmyth-netspace) wrote :

Well, Patrick:From the desktop I clicked on HIBERNATE. The screen darkened...but went no further. Same thing happens when I press the button on my laptop, having set the power button to HIBERNATE - same result when I set the latter to SUSPEND. Windows has a similar problem, I understand. I just hoped Linux would have solved it -everything else works fine. Am a mite puzzled etc. Thanks for the prompt response.

Christian Reis (kiko) wrote :

Pretty trivial to reproduce if you have the hardware -- I get the same on a T61 with ath_pci.

Note also bug 301005, bug 317472. At least in my case it does not seem to be the same issue as bug 262516, since only ath_pci is loaded.

Hi kiko,

Can you attach the following logs:

sudo lspci -vnvn > lspci-vnvn.log
dmesg > dmesg.log

Also, if you could capture your dmesg output both before you suspend and after you resume that would be great. Thanks.

Christian Reis (kiko) wrote :

Hi Leann, will arrange this tonight. Thanks for following up!

Christian Reis (kiko) wrote :
Christian Reis (kiko) wrote :
Christian Reis (kiko) wrote :
Christian Reis (kiko) wrote :

lsmod before suspend

Hi Kiko,

Can you also test using the ath5k driver rather than the proprietary ath_pci driver? I'm hopeful the ath5k driver will resolve this issue for you. It should support the card that you have. Additionally, it would be interesting to also test the ath5k driver that is available in linux-backports-modules-intrepid. The reason I say that is because linux-backports-modules-intrepid contains an updated compat-wireless stack.

I also wanted to mention that I forgot that the issue you're seeing here was actually mentioned in the Intrepid release notes and is likely a duplicate of bug 275692. But let me know your results for testing ath5k first before I mark this as a duplicate.

https://wiki.ubuntu.com/IntrepidReleaseNotes#Wireless doesn't work after suspend with ath_pci driver

Thanks in advance.

KP Stolk (kp-stolk) wrote :

hi,

I also have this problem too: no internet connection after suspend/hibernate.

I know a solution: open a terminal and type ¨sudo dhclient¨ you can connect again.

I think that´s the problem: dhclient is terminated after suspend/hibernate and won´t restart after waking up from suspend/hibernate.

I use Xubuntu 8.10 on a Acer 5100

    Thanks for the tip!
    Damned nuisance, though.
    Hope this bug gets fixed ...

KP Stolk wrote:
> hi,
>
> I also have this problem too: no internet connection after
> suspend/hibernate.
>
> I know a solution: open a terminal and type ¨sudo dhclient¨ you can
> connect again.
>
> I think that´s the problem: dhclient is terminated after
> suspend/hibernate and won´t restart after waking up from
> suspend/hibernate.
>
> I use Xubuntu 8.10 on a Acer 5100
>
>

Christian Reis (kiko) wrote :

Leann, perfect: we just apt-get installed linux-backports-modules-intrepid and rebooted, and ath5k was already loaded -- I didn't even need to rejig the blacklist or do rmmodding. It all worked out of the box. This metapackage is a closely guarded secret!

So my issue is resolved -- is there anything else we need to do with this bug? And is it wontfix or fix released?

Hi Kiko,

Thanks for testing and the feedback. I'm going to go ahead and mark this as a duplicate of bug 275692. Again, for anyone else experiencing this issue, please install the linux-backports-modules-intrepid package which should provide you with the ath5k driver. Thanks.

Changed in linux:
status: Incomplete → Fix Released
Changed in linux-restricted-modules:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers