Atheros AR2413 wi-fi does not work after resume from suspend (regression)

Bug #295717 reported by Caleb on 2008-11-08
This bug report is a duplicate of:  Bug #275692: ath_pci must be reloaded after resume. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-restricted-modules-2.6.27-7-generic

release: Ubuntu 8.10
package version: 2.6.27-7.12
NIC: PCI D-Link WDA-1320 with an Atheros AR2413 802.11b/g chipset

After resuming from suspend, the NetworkManager applet spins for a little while, then asks for my encryption key. Even after I type this in, it refuses to connect to the network (or any network, for that matter) although the system detects the card. After unloading and reloading the ath-pci module (sudo modprobe -r ath-pci && sudo modprobe ath-pci) it connects to the network just fine.
This did not occur with the previous release of Ubuntu (Hardy Heron)
I'm wondering how I can set Ubuntu to automatically reload the module when I resume the system (or unload before suspend, and reload upon resume) for the time being, until the bug is fixed.

Michael Rooney (mrooney) wrote :

Hi Caleb, thanks for using Ubuntu and thanks for taking the time to file this bug report! Can you please look at bug #275692, as I think this may be a duplicate of that. If so we can mark it as such and get them the appropriate amount of attention. Also note the Release Notes section: https://wiki.ubuntu.com/IntrepidReleaseNotes#Wireless%20doesn%27t%20work%20after%20suspend%20with%20ath_pci%20driver.

Thanks!

Changed in linux-restricted-modules:
status: New → Incomplete
Caleb (caleb-marcus) wrote :

Thanks, Michael. It does look like it's a duplicate, so it looks like you should go ahead and mark it :)
I'll try the fix in a little while, and get back to you on that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers