missing iwlwifi-4965-2.ucode

Bug #269926 reported by Craig on 2008-09-13
16
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.27-3-generic

I just upgraded to Intrepid from Hardy, and my wireless did not work. I checked dmesg, and saw this:
[ 1653.665390] firmware: requesting iwlwifi-4965-2.ucode
[ 1653.668546] iwlagn: iwlwifi-4965-2.ucode firmware file req failed: Reason -2
[ 1653.668555] iwlagn: Could not read microcode: -2

This prevents wifi from working on my laptop (obviously). I'm trying to find a workaround now.

Craig (candrews-integralblue) wrote :

I downloaded iwlwifi-4965-ucode-228.57.2.21.tgz from http://intellinuxwireless.org/?n=Downloads and extracted the microcode to /lib/firmware/linux-image-2.6.27-3-generic and this error message went away.

Hi Craig,

Can you try installing linux-restricted-modules-common and see if that helps. Thanks.

Changed in linux:
status: New → Incomplete
Craig (candrews-integralblue) wrote :

linux-restricted-modules-common does indeed contain /lib/firmware/iwlwifi-4965-2.ucode

But should it? Or should this be held in a different package? I'm not sure if this ucode should be considered "restricted" - if it is, that's fine, and thanks!

Changed in linux:
status: Incomplete → New
Joel Stanley (shenki) wrote :

l-r-m contains some startup scripts and an executable. After reading http://lwn.net/Articles/299483/ on speeding up boot time, it sounds like it would be a good idea to not have these files run on startup, but still be able to use ones Intel wireless card and dvb tuner, for example.

Could the firmware that is only firmware be packaged separately to the firmware that needs supporting scripts?

/sbin/lrm-manager
/etc/default/linux-restricted-modules-common
/etc/modprobe.d/lrm-video
/etc/init.d/linux-restricted-modules-common

Hi Joel,

That's probably something that the kernel team could answer better via the Ubuntu kernel team mailing list - https://lists.ubuntu.com/mailman/listinfo/kernel-team .

Changed in linux:
status: New → Fix Released
Craig (candrews-integralblue) wrote :

This bug shouldn't be marked as "fix released" as no fix action was taken, and no release was made.

Changed in linux-restricted-modules:
status: Fix Released → New

This bug is resolved by installing linux-restricted-modules-common, which contains/provides the necessary firmware, so this bug should be closed in my opinion. Craig, is there a reason installing linux-restricted-modules-common is not an adequate solution for you?

Craig (candrews-integralblue) wrote :

Yes, linux-restricted-modules contains "nasty" things, like a startup script (which slows down boot up), nvidia drivers (amongst other very non-free modules), and other things. If I only need microcode for one wifi device, linux-restricted-modules seems like massive, costly, overkill.

IMHO, the wifi microcode (and microcode for other devices) should be separated into a different package, and the restricted modules should remain in the linux-restricted-modules package.

Thanks for the feedback Craig. I imagine since linux-ubuntu-modules went away for Intrepid, firmware that used to reside in that package was pushed to linux-restricted-modules. The concerns you have mentioned were also raised to the Ubuntu kernel team and will be addressed and tracked in bug 279669 . I'd encourage you to subscribe to that bug report so you are notified of any updates. I'll also post a note to that report referencing this one. Thanks.

Hans (hans-eichbaum) wrote :

My wifi stopped working with the latest interpid, when looking into dmesg I got the same error about missing microcode.
I seem to have the appropriate microcode..

/lib/firmware/iwlwifi-4965-1.ucode
/lib/firmware/iwlwifi-4965-2.ucode

Hans (hans-eichbaum) wrote :

Oops. firmware was gone, 'locate' tricked me.

WulfNStein (wulfnstein) wrote :

I am having the same issue. After updating this morning my wireless no longer works and this is in my dmesg...

[ 45.309172] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 45.309282] iwlagn 0000:0c:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
[ 45.309541] firmware: requesting iwlwifi-4965-2.ucode
[ 45.621034] iwlagn: iwlwifi-4965-2.ucode firmware file req failed: Reason -2
[ 45.621040] iwlagn: Could not read microcode: -2
[ 45.621092] iwlagn 0000:0c:00.0: PCI INT A disabled
[ 45.634075] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 45.634157] iwlagn 0000:0c:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
[ 45.634326] firmware: requesting iwlwifi-4965-2.ucode
[ 45.635987] iwlagn: iwlwifi-4965-2.ucode firmware file req failed: Reason -2
[ 45.635991] iwlagn: Could not read microcode: -2
[ 45.636037] iwlagn 0000:0c:00.0: PCI INT A disabled

WulfNStein (wulfnstein) wrote :

I'd also like to add that I'm using the 64 bit 2.6.27-7-generic kernel with linux-restricted-modules and linux-restricted-modules-common installed.

Javier García Díaz (jgd) wrote :

I can confirm this bug for the 32 bit version 2.6.27-7 kernel.
I had to manually copy the ucode file from http://intellinuxwireless.org/?n=Downloads (see attached) to /lib/firmware/iwlwifi-4965-2.ucode to solve this problem.

Javier García Díaz (jgd) wrote :

It seems that this bug has been solved: now that I have my Internet connection back, I have updated the repositories and synaptic has suggested me to install the package linux-firmware, which contains the aforementioned file.
I'm glad this is solved, but it has been a great inconvenience.

Steve Langasek (vorlon) wrote :

thanks, marking this bug as resolved.

Changed in linux-restricted-modules:
status: New → Fix Released
kelvie (kelvie) wrote :

Is linux-firmware installed by default? I had just upgraded this morning and found that I had to manually install it; it should be automated (eg. via a dependency) somehow, I would imagine.

Jason Young (a10waveracer) wrote :

I just thought I'd also add that I think this should be installed by default. After an update yesterday my wireless mysteriously vanished and I couldn't get it to work. After finding this page and installing linux-firmware it started working again on a Lenovo T61.

sp200606 (sp200606) wrote :

I confirm that the linux-firmware was missing on my install (upgrade from hardy - when wifi was fine), and now it's working again after installing linux-firmware.
A lot of aggro!

Anyway, thanks for showing the solution

wvengen (wvengen) wrote :

Same problem here after upgrading to Intrepid on 20081026. After installing linux-firmware it was ok.

Is linux-firmware a new package in Intrepid? If so, I'd think that it needs to be installed automatically on upgrade; network connectivity is pretty important and not everyone has a wired connection as well.

(*I* somehow had atmel-firmware installed which was incomaptible with linux-firmware, so that might explain the problem for me.)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers