binary assembly failures with CONFIG_MODVERSIONS present

Bug #1919315 reported by Andy Whitcroft on 2021-03-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
Critical
Andy Whitcroft

Bug Description

LRM and the end-user system are intended to assemble the package in the same manner to ensure we have reproducible binaries. This is needed so that pre-generated signatures are applicable. It seems for (at least some installations) when CONFIG_MODVERSIONS is set that though the LRM assembly completes correctly in the face of seemingly benign errors, that the final end-user assembly only works for two of the four kernel modules.

Cleaning up the errors for _only_ the end-user assembly renders the binaries identical to those produced in the main package and thus matching the signatures. It is unclear as to the trigger leading to the failure to assemble on the end-user system.

Andy Whitcroft (apw) wrote :

Fix is known. We will expedite these out.

Changed in linux-restricted-modules (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Andy Whitcroft (apw)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 5.8.0-45.51+1

---------------
linux-restricted-modules (5.8.0-45.51+1) groovy; urgency=medium

  * binary assembly failures with CONFIG_MODVERSIONS present (LP: #1919315)
    - [Packaging] quiet (nomially) benign errors in BUILD script

 -- Stefan Bader <email address hidden> Tue, 16 Mar 2021 15:09:20 +0100

Changed in linux-restricted-modules (Ubuntu):
status: In Progress → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Andy Whitcroft (apw) wrote :

End user assembly was spot checked on a number of kernels.

Andy Whitcroft (apw) on 2021-04-10
tags: added: verification-done-bionic verification-done-focal verification-done-groovy
removed: verification-needed-bionic verification-needed-focal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers