Introduce the new NVIDIA 455 series

Bug #1897751 reported by Alberto Milone
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
Undecided
Alberto Milone
nvidia-graphics-drivers-455 (Ubuntu)
Undecided
Alberto Milone

Bug Description

[Impact]
These releases provide both bug fixes and new features, and we would like to
make sure all of our users have access to these improvements.

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/NVidiaUpdates

Certification test suite must pass on a range of hardware:
https://git.launchpad.net/plainbox-provider-sru/tree/units/sru.pxu

The QA team that executed the tests will be in charge of attaching the artifacts and console output of the appropriate run to the bug. nVidia maintainers team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned system level tests are attached to this bug.

[Discussion]

Changed in nvidia-graphics-drivers-450 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
affects: nvidia-graphics-drivers-450 (Ubuntu) → nvidia-graphics-drivers-455 (Ubuntu)
Changed in linux-restricted-modules (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-455 (Ubuntu):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-455 - 455.28-0ubuntu1

---------------
nvidia-graphics-drivers-455 (455.28-0ubuntu1) groovy; urgency=medium

  * Initial release (LP: #1897751).

 -- Alberto Milone <email address hidden> Wed, 07 Oct 2020 16:58:09 +0200

Changed in nvidia-graphics-drivers-455 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-groovy' to 'verification-done-groovy'. If the problem still exists, change the tag 'verification-needed-groovy' to 'verification-failed-groovy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-groovy
Revision history for this message
Francis Ginther (fginther) wrote :

I tested basic installation of the linux-restricted-modules packages along with the associated kernel and 455 driver. Also exercised the driver with a cuda workload. This is the same testing I would execute for the nvidia server drivers (for example: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-450/+bug/1897910/comments/13).

tags: added: verification-done-groovy
removed: verification-needed-groovy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 5.8.0-26.27

---------------
linux-restricted-modules (5.8.0-26.27) groovy; urgency=medium

  * Master version: 5.8.0-26.27

  * Introduce the new NVIDIA 455 series (LP: #1897751)
    - [packaging] add signed modules for the nvidia 455 driver

  * Miscellaneous Ubuntu changes
    - debian/dkms-versions -- update from master

 -- Seth Forshee <email address hidden> Wed, 21 Oct 2020 16:24:19 -0500

Changed in linux-restricted-modules (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Andy Whitcroft (apw) wrote : Update Released

The verification of the Stable Release Update for nvidia-graphics-drivers-455 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers