Ubuntu

Update the NVIDIA driver to 173.14.12

Reported by Alberto Milone on 2008-08-04
12
Affects Status Importance Assigned to Milestone
linux-restricted-modules-envy-2.6.24 (Ubuntu)
Undecided
Alberto Milone
Hardy
Undecided
Unassigned

Bug Description

Release Highlights:
* Added support for GeForce 8600 GS.
* Fixed a problem with missing rendering in OpenGL Workstation Overlays.
* Fixed a problem with running some SDL applications and virtual terminal switching.
* Fixed a potential crash in nvidia-settings when saving to the X configuration file.
* Improved error recovery paths in the case of corruption of the commands sent to the GPU.

Changed in linux-restricted-modules-envy-2.6.24:
assignee: nobody → albertomilone
status: New → In Progress
Alberto Milone (albertomilone) wrote :

Edit: I have fixed a typo in the changelog and reuploaded the files.

Martin Pitt (pitti) wrote :

I just uploaded the new driver to intrepid, thanks Alberto!

Changed in linux-restricted-modules-envy-2.6.24:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

Changed in linux-restricted-modules-envy-2.6.24:
status: New → Fix Committed
Graham Inggs (ginggs) wrote :

I've enabled hardy-proposed on two machines previously running Nvidia driver 173.14.09 installed using Envy NG and updated to Nvidia driver 173.14.12.
On both, after restarting, running NVIDIA X Server Settings and clicking on OpenGL/GLX information gives the following error: "Fail to query the GLX server vendor".

Problem resolved by updating the symlink in /usr/lib/xorg/modules/ as follows:
# cd /usr/lib/xorg/modules
# rm libglx.so
# ln -s /usr/lib/xorg/modules/extensions/libglx.so.173.14.12 libglx.so

Alberto Milone (albertomilone) wrote :

Graham: did you use the installer from NVIDIA's website too?

Graham Inggs (ginggs) wrote :

Yes, I have used NVIDIA's installer in the past, but did use their installer's --uinstall option to subsequently remove it.

Alberto Milone (albertomilone) wrote :

Graham: NVIDIA's installer broke Ubuntu's nvidia packages and the --uninstall option doesn't solve the problem that certain symlinks were overwritten by files, etc.

This creates serious problems when performing a dist-upgrade or installing Ubuntu's nvidia packages.

In another words what you're experiencing was caused by the NVIDIA installer.

Graham Inggs (ginggs) wrote :

Thanks Alberto! Is there any way this can be fixed by Envy NG automatically, or is more than just this symlink that was broken?

Thomas Lété (bistory) wrote :

Ok, it works fine on my Laptop with a 8400M GT, Thanks !

(lspci :)
01:00.0 VGA compatible controller: nVidia Corporation G86M [GeForce 8400M GT] (rev a1)

kimsyv (minslaskmail) wrote :

Not working with 9600 GT.

EnvyNG doesn't detect 9600 GT card.

lspci -n | grep 300
02:00.0 0300: 10de:0622 (rev a1)

lspci | grep VGA
02:00.0 VGA compatible controller: nVidia Corporation Geforce 9600 GT 512mb (rev a1)

MusJet (crmeks) wrote :

I have installed new version "173.14.12" in two computers using Ubuntu 8.04 (enabled hardy-proposed).
One desktop computer with video board Zogis Geforce 8500GT 512 MB
[02:00.0 VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1)]
and other desktop computer with video board XFX Geforce 8400GS 512 MB TC (256 MB ONBOARD)
[02:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)].

On both, after rebooting, everything running 100%. Perfect install.
Also like user of SL (Second Life) I noticed that driver version is much more stable and more fast also. I have more 2 hours running (rendering direct) on SL and no crash. Viva !

Alberto, congratulations for EnvyNG tool. Really nice work !

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in linux-restricted-modules-envy-2.6.24:
status: Fix Committed → Fix Released
MusJet (crmeks) wrote :

Hello ! After update to new release of kernel "linux-image-2.6.24-21-generic", available in hardy-proposed repository, my desktop computer with "XFX Geforce 8400GS 512 MB TC (256 MB ONBOARD)" is initializing in low-graphics mode.
I am getting this message at "/var/log message":

Aug 19 20:34:49 computer2 kernel: [ 55.410790] NVRM: API mismatch: the client has the version 173.14.12, but
Aug 19 20:34:49 computer2 kernel: [ 55.410794] NVRM: this kernel module has the version 96.43.05. Please
Aug 19 20:34:49 computer2 kernel: [ 55.410795] NVRM: make sure that this kernel module and all NVIDIA driver
Aug 19 20:34:49 computer2 kernel: [ 55.410797] NVRM: components have the same version.

Any idea to solve that ?

ps: other desktop computer with "Zogis Geforce 8500GT 512 MB" is working pretty good and no problems with new version of kernel 2.6.24-21.
Sounds that nvidia video card with turbo cache is "complex" product, like says americans: "pain in the ass". :)

Alberto Milone (albertomilone) wrote :

MusJet: try this:
1) stop the xserver
2) type:
sudo rmmod nvidia
sudo modprobe nvidia
3) restart the xserver

MusJet (crmeks) wrote :

Hi Alberto ! Removed and loaded module with success, but restarting xserver, after 3 "refresh" of black screen, give me back low-graphics mode (vesa). Returning to kernel 2.6.24-20-generic, the nvidia works 100%. I will disable hardy-proposed in this computer.
I have one friend, and he has nvidia 8500 GT and is working 100% with kernel 2.6.24-21-generic like my other desktop computer. Something is different in this new version of kernel and affecting nvidia video 8400GS.

See you,

  MusJet

Graham Inggs (ginggs) wrote :

I still find I have to manually fix the softlink /usr/lib/xorg/modules/libglx.so every time I get a new Nvidia driver.
This is even after upgrading to a couple of Intrepid Alphas, and more recently the Beta.

How can I undo what the Nvidia installer broke? Couldn't this be detected or fixed when the driver is upgraded?

Alberto Milone (albertomilone) wrote :

Graham: can you attach the output of this command?
dpkg-divert --list

Graham Inggs (ginggs) wrote :

As requested. I hope this helps.

lazyfirecloud (madbox3456) wrote :

I have the same problem as MusJet with a GO 6150 on my laptop. Won't load the driver with 2.6.24-21, but loads fine in 2.6.24-19 (so I just took 21 out of the grub).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments