Ubuntu

Update the FGLRX and NVIDIA driver to 8.6 and 173.14.09

Reported by Alberto Milone on 2008-07-07
28
Affects Status Importance Assigned to Milestone
linux-restricted-modules-envy-2.6.24 (Ubuntu)
Medium
Alberto Milone
Hardy
Undecided
Alberto Milone
Intrepid
Medium
Alberto Milone

Bug Description

USE-CASE:

For NVIDIA users - release highlights for 173.14.09:
Fixed aliased font rendering corruption on X.Org server 1.5.
Fixed a display corruption problem driving two dual-link DFPs with Quadro FX 1700 GPUs.
Fixed a regression that prevented the X driver from starting on some GeForce FX, 6 and 7 mobile GPUs.
Fixed a locale-interaction issue in the nvidia-settings X server configuration file parser.
Added preliminary support for Linux 2.6.26.

For ATI users - release highlights for 8.6:
Enemy Territory: Quake Wars: Playing the demo on a system running X no longer results in corruption being noticed. Further details can be found in topic number 737-35208
Maya 2008: An incorrect colormap is no longer displayed for texture selector on systems running X. Further details can be found in topic number 737-35207
Quake 3 Arena (demo): Segmentation faults no longer occur when attempting to play the game. Further details can be found in topic number 737-35206
Quake3: Corruption is no longer noticed when changing the display resolution when the game is running. Further details can be found in topic number 737-35209
SECAM, NTSC or PAL signal changes when using aticonfig or Catalyst Control Center and now gets applied to the TV display output. Further details can be found in topic number 737-34297
Running X server without a window manager no longer results in the X server flashing green for a moment, going black, and the computer becoming unresponsive. Further details can be found in topic number 737-34299
Corruption is no longer noticed when connecting a DFP display device to a system running X after setting the TV mode to 1080i. Further details can be found in topic number 737-34301
Clock Gating is now supported and enable under the Linux operating system. Further details can be found in topic number 737-35191
The desktop background color is no longer displayed incorrectly when using xcommgr. Further details can be found in topic number 737-35192
Using the wrong delimiter in aticonfig --set-dispattrib=<disp>,<attr>, <value> no longer results in a segmentation fault. Further details can be found in topic number 737-35194
Audio out is now functioning after the installation of the ATI graphics drivers for Ubuntu 7.10. Further details can be found in topic number 737-35196
Bandwidth corruption is no longer noticed when setting the desktop resolution to 2048x1536 on systems containing an ATI Radeon HD 3200 series of product. Further details can be found in topic number 737-33499
Playing a video clip using mplayer with the Xv extension enabled no longer results in an error indicating that Xv could not find a free Xv port. Further details can be found in topic number 737-35198
Corruption is no longer noticed when enabling Big Desktop on systems containing an ATI FireGL X1 series of product and running X. Further details can be found in topic number 737-35199
Running the X server generations test no longer results in the operating system failing to respond or a Kernel panic to occur after first server generation on SuSE 10.3 64 bit. Further details can be found in topic number 737-35200
Attempting to resize a 2D application window no longer results in poor performance being noticed when composing is enabled. Further details can be found in topic number 737-35201
Screen flicker is no longer noticed after running amdcccle in X. Further details can be found in topic number 737-35202
Corruption is no longer noticed when connecting a DFP display device to a system running X after setting the TV mode to 1080i. Further details can be found in topic number 737-35203
Glxgears corruption is no longer noticed in big desktop mode. Further details can be found in topic number 737-35204
Starting glxgears and/or fgl_glxgears no longer results in the gears failing to render on SuSE 10.2 x86_64. Further details can be found in topic number 737-35205
FGL_GLXGEARS or GLXGEARS: X no longer fails to respond when launching either of the applications. Further details can be found in topic number 737-35210

Changed in linux-restricted-modules-envy-2.6.24:
assignee: nobody → albertomilone
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

Thanks for the detailled list of changes! That's fine, and I'd accept new envy driver versions even without it (since that's what envy is for :) ). Where can I get the package for sponsoring?

Martin Pitt (pitti) wrote :

Oh, motu-sru, does -envy have a permanent ack, or do you want to ack each upload individually?

On Monday 07 July 2008 12:03, Martin Pitt wrote:
> Oh, motu-sru, does -envy have a permanent ack, or do you want to ack
> each upload individually?

Dunno. I'll ack this one.

Martin Pitt (pitti) wrote :

I think we won't put that fix into intrepid, due to the complete restructuring of nvidia-glx-VERSION.

Changed in linux-restricted-modules-envy-2.6.24:
status: In Progress → Won't Fix
Martin Pitt (pitti) wrote :

Uploading, thanks Alberto!

Changed in linux-restricted-modules-envy-2.6.24:
assignee: nobody → albertomilone
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-restricted-modules-envy-2.6.24:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Weird, the release-less task isn't supposed to be here any more. LP bug...

Changed in linux-restricted-modules-envy-2.6.24:
status: In Progress → Won't Fix
Luke12 (luca-venturini) wrote :

I have updated and I have been using the new driver since this morning. I am on a Hardy 32-bit box, using a GeForce 7300 (Dell notebook). It works reasonably well, seemingly with no improvements or regressions compared with the previous version. I however experienced a system freeze some hours ago, while I was burning a dvd ... I am not sure it is nvidia - related, but while the burning was going on, keyboard or mouse inputs seemed not to be received by the systems, and I obviously had to do a hard-reboot. Signaling it here because I witnessed similar behaviour in the past related to issues with memory and the nvidia driver ... if someone could point me where to find relevant clues if this was nvidia related, I would be grateful.

Bart Verwilst (verwilst) wrote :

I have updated to this driver a few hours ago because my ATI HD4850 wouldnt even start X with the 8.3 and 8.4 binary drivers. Now i'm working with my "big desktop" dual screen in perfect shape with just a few clicks of the button ( using amdcccle ), fully compizized! Great job! This has the Verwilst Certificate of Approval! ;)

Luke Yelavich (themuso) wrote :

Updated to this package from proposed, working perfectly here using a GeForce 8600GT.

Casey J Peter (caseyjp1) wrote :

Just updated on two seperate machines.
1. amd 3800 x2 dualcore nvidia 8800gts OC
2. amd 2400xp nvidia 7300GT

Absolutely no issues to report other than bravo as usual! :)

Jimi Eriksson (jimi-eriksson) wrote :

Tried the ATI driver with my integrated HD 3200 (AMD 780G chipset).

Compiz and desktop effects work, however AWN (avant-window-navigator) freezes whenever i mouse over it.

Turning off Compiz and launching World of Warcraft with Wine causes the graphics to become corrupt. You can see parts of what's supposed to be on the screen, but everything is chopped up in pieces and in the wrong place. Even if I manage to exit WoW it stays that way and I have to restart X to get back to a usable desktop.

Everything was working with the old Envy driver.

Jan Schneider (yunosh) wrote :

When running the actual update with EnvyNG, the protocol window seems to use ASCII, while the output being logged is UTF-8 encoded. Only cosmetics, but I thought I would let you know.

I used the proposed repos and installed the 8.6 fglrx driver to use with my ATI Radeon HD3870 (rv670 graphics chip).

Compiz worked fine, but running anything that required 3d acceleration or running just about anything through wine screwed up graphics -- totally fubar. The only way to fix that was to restart X or reboot the system. Similar to what "Jimi Erikssson" reports, launching World of Warcraft through wine (or actually just about anything through wine) screwed up the image by chopping up everything into randomly arranged pieces of what is supposed to be there in a mostly black screen.

Uninstalling the drivers through EnvyNG, disabling proposed and reinstalling the old ones (8.4) worked fine. Right now just about everything works properly.

Used EnvyNG from Hardy-Proposed to install 173.14.09 for a nVidia 8800 GTX based card.

Using a 2.6.24-19 real-time kernel, I have experienced no issues over several days of general use, including use of the advanced visual effects. Similarly, suspend and resume work as they did before (that is, works most of the time, but occasionally does not return from suspend).

Removing the driver also works as expected.

Thomas Lété (bistory) wrote :

It work perfectly on a Sony VAIO FZ-11E with a Nvidia Geforce 8400GT and on a Toshiba A300 with an ATI 3650 both on Hardy Heron up-to-date.
Thanks a lot Alberto !

FelixPiers (felixpiers) wrote :

Currently using the 8.6 FGLRX driver with my ATI Radeon 9600 installed via EnvyNG. Experiance the same issue's as "Jimi Eriksson" & "Steve Michalis", "launching World of Warcraft with Wine causes the graphics to become corrupt. You can see parts of what's supposed to be on the screen, but everything is chopped up in pieces and in the wrong place. Even if I manage to exit WoW it stays that way and I have to restart X to get back to a usable desktop."

Although I've not actually tried World of Warcraft this is the exact same issue I get with Guild Wars, some games like Dawn of War Soulstorm don't even run. Had problems trying to game with the fglrx drivers since running Hardy, seemed to be ok in Gutsy.

Compiz works fine, watching videos on youtube also works fine, however playing videos in totem doesn't work (sound but no video) untill I turn off compiz (via switching to metacity) then the videos play fine.

Elmo (elmo13) wrote :

Same problem, garbled screen with opengl apps, though I could mostly restore proper image by quitting the app in question. I'm on 64bit dual core AMD with HD 3650. Had to downgrade to 501.30 (8.4)

Martin Pitt (pitti) wrote :

Copied to hardy-updates

Changed in linux-restricted-modules-envy-2.6.24:
status: Fix Committed → Fix Released
Jimi Eriksson (jimi-eriksson) wrote :

What's the point of reporting bugs if you're just gonna copy things to hardy-updates without reading them? The Ati driver doesn't work, as reported by me and 3 other people.

How do I get back to 8.4 now? I can disable hardy-updates, but that just gives me 8.3 as an option.

Jimi Eriksson (jimi-eriksson) wrote :

Correction: I can't even go back to 8.3.

Alberto Milone (albertomilone) wrote :

Jimi Eriksson:

1) first of all, you can go back to a previous version of the driver and pinpoint that version. The documentation explains how to do it from Synaptic:
https://help.ubuntu.com/community/SynapticHowto#How to force the installation of a package version

Or you can simply go back to the drivers in the standard linux-restricted-modules and wait until ATI releases a new driver.

2) other users reported that the driver worked well for them here:
http://albertomilone.com/wordpress/?p=211#comments

3) Assuming that I don't read the comments here is not fair.

Jimi Eriksson (jimi-eriksson) wrote :

Thanks for the reply.

I apologize for the tone of my post, it's just annoying when something you and other people report on gets ignored.

Your blog post said report experiences here so that's what I did. The posts here that actually mentions Wine or OpenGl all say they don't work with the Ati driver. But then the update got moved to ubuntu-updates anyway, without even a comment on this page until after I complained.

I tried using synaptic to go back to the old version when I realized it was the same driver that didn't work in ubuntu-proposed. However the only package i can force a version on is envyng-core, and I can only chose between 2 versions: hardy and hardy-updates. Hardy is 8.3 which reports that it doesn't work with my integrated graphics (AMD 780G, HD3200) and hardy-updates is 8.6 which doesn't work with Wine.

Anyway, I appreciate the work you're doing so thank you for your time.

Jimi Eriksson (jimi-eriksson) wrote :

Don't know if this is the right place to post this, but this forum post has screenshots of the bug and lots of users reporting the same problems with Catalyst 8.6:

http://www.phoronix.com/forums/showthread.php?t=10940

Alberto Milone (albertomilone) wrote :

Jimi:
Please follow these steps:
1) Remove the packages by typing:
sudo apt-get remove --purge xorg-driver-fglrx-envy fglrx-kernel-source-envy

2) Install the old packages in the following way:

If you use Ubuntu 32bit, type:
wget -c http://launchpadlibrarian.net/15192591/xorg-driver-fglrx-envy_7.1.0-8-4%2B2.6.24.501-501.30_i386.deb

wget -c http://launchpadlibrarian.net/15192593/fglrx-kernel-source-envy_8-4%2B2.6.24.501-501.30_i386.deb

Otherwise type:
wget -c http://launchpadlibrarian.net/15192703/xorg-driver-fglrx-envy_7.1.0-8-4%2B2.6.24.501-501.30_amd64.deb

wget -c http://launchpadlibrarian.net/15192705/fglrx-kernel-source-envy_8-4%2B2.6.24.501-501.30_amd64.deb

3) Install the packages by typing:
sudo dpkg -i fglrx-kernel-source-envy*.deb
sudo dpkg -i xorg-driver-fglrx-envy*.deb

Then you should get the old driver. Restart your computer and it should work.

Please, remember not to update the fglrx.

Alberto Milone (albertomilone) wrote :

Jimi: and please report the problem to AMD so that they can fix this problem. You can do it here:
http://ati.cchtml.com

Bart Verwilst (verwilst) wrote :

Hm, 550+ bugs, almost all of them marked as NEW.. i guess you might as well report your bug to /dev/null :)

Bart Verwilst (verwilst) wrote :

Well, the 8.7 driver has just been released. Might be worthy of updating the package for this driver and check to see if this one solves at least some of your problems?
The changelog says something about a fix for X segfaults ive been seeing now and then so... :) Aaah, the joy of binary cra^Wdrivers.. :)

[NVIDIA DRIVER]

Hi,

Since upgrade to 173.14.09 games freezes continously and I see in dmesg:

[10224.617434] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001ac0 7e000000 00000005

[10224.617728] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001ac0 7e000000 00000005

[10575.262207] NVRM: Xid (0001:00): 6, PE0003

[10808.745435] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00000980 20120008 0000000c

[10808.745697] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00000980 20120008 0000000c

I hope this could be usefull.

Best regards.

Hi,
I forgot to detail my system:

Linux dixie 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

lspci:00:00.0 Host bridge: Intel Corporation 82X38/X48 Express DRAM Controller (rev 01)
00:01.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Primary PCI Express Bridge (rev 01)
00:06.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Secondary PCI Express Bridge (rev 01)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0612 (rev a2)
04:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
04:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
07:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

Intel Q6600 8GB DDR2 1066
Asus Nvidia 9800GTX
Gigabyte X48-DQ6

Best regards.

HI,

I've updated to

Linux dixie 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux

and the lastest 173.14.09 updates (22/07/2008) and the same happens.

Best regards.

vista killer (vistakiller) wrote :

After the update

kernel 2.6.24-20-generic

i have to reinstall manual the driver with envyng -t in recovery mode.

Alberto Milone (albertomilone) wrote :

vista killer: make sure that linux-headers-generic is installed.

Alberto Milone (albertomilone) wrote :

If you have problems with the NVIDIA driver 173.14.09, please try 173.14.12 and post your feedback here:
https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-envy-2.6.24/+bug/254596

My problem was current outage from the power supply. I've replaced the power supply with a powerful one and all problems solved.

Sorry for all the inconvenience.

Best regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers