[Broadcom] Upgrade 'wl' to latest version: 5.10.91.9

Bug #372425 reported by Tony Espy on 2009-05-05
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Dell Mini Project
Undecided
Unassigned
linux-restricted-modules (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned
Jaunty
Medium
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

SRU justification:

Impact: Broadcom has released a golden driver which claim to solve (at least the problem of association after 6 hours. As this driver contains binary only parts it can only be a best-effort support for that.

Fix: Upgrade the Broadcom driver in Hardy, Intrepid and Jaunty to the same version which simplifies maintenance.

---

Broadcom has released a new Gold version of their 'wl' Wi-Fi driver, 5.10.91.9.

It can be downloaded from:

http://www.broadcom.com/support/802.11/linux_sta.php

The release notes state that it fixes a problem with association failing after 6 hours ( that's the extent of the description ).

Also as part of this update, the MODULE_LICENSE needs to be set to "MIXED/Proprietary". It's currently empty.

James Schriver (dashua) wrote :

Built and installed on Jaunty 64 2.6.28-12-generic, since the linux-restricted-modules is currently broken in jaunty-proposed. Works very well. There are no more sporadic time outs.

Tony Espy (awe) wrote :

I'll be submitting the SRU/patch shortly. There's some house-cleaning that's taking place in the git trees before I do this.

dashua, thanks for the testing!

Stefan Bader (smb) on 2009-05-14
description: updated
Stefan Bader (smb) on 2009-05-14
Changed in linux-restricted-modules-2.6.24 (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux-restricted-modules-2.6.24 (Ubuntu Hardy):
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux-restricted-modules-2.6.24 (Ubuntu Intrepid):
status: New → Invalid
Changed in linux-restricted-modules-2.6.24 (Ubuntu Jaunty):
status: New → Invalid
Changed in linux-restricted-modules (Ubuntu Hardy):
status: New → Invalid
Changed in linux-restricted-modules (Ubuntu):
status: New → Invalid
Changed in linux-restricted-modules (Ubuntu Intrepid):
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux-restricted-modules (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux-restricted-modules into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Fix Committed → Invalid
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux-restricted-modules-2.6.24 into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux-restricted-modules into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Stefan Bader (smb) wrote :

Ok, pulled the proposed kernel and lrm for Jaunty and ran a loop of git clone for the kernel tree over wireless using the wl driver. So far it has done 42 iterations and is still running. I would say at least this seems not to have become worse.

HW: BCM 4328 802.11a/b/g/n (rev 03) on a Dell Inspiron 1521

Martin Pitt (pitti) on 2009-06-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 2.6.28-13.17

---------------
linux-restricted-modules (2.6.28-13.17) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Bump ABI to 13 for proposed kernel

  [ Tim Gardner ]

  * Update Broadcom wl to 5.10.91.9
    - LP: #372425

linux-restricted-modules (2.6.28-12.16) jaunty-proposed; urgency=low

  [Stefan Bader]

  * Bump ABI to 12 for proposed-kernel

 -- Stefan Bader <email address hidden> Wed, 13 May 2009 17:06:54 +0200

Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Still needs verification for the hardy update.

tags: added: verification-needed
removed: verification-done
Stefan Bader (smb) wrote :

Did basically the same test on Hardy as with Jaunty (git clone loop over night) stopped while doing the 124th repetition of that. Should I do the same for Intrepid, too or would it be valid to assume for simplicity that (as it is the same code) it will be the same?

Stefan Bader [2009-07-01 6:53 -0000]:
> Did basically the same test on Hardy as with Jaunty (git clone loop over
> night) stopped while doing the 124th repetition of that. Should I do the
> same for Intrepid, too or would it be valid to assume for simplicity
> that (as it is the same code) it will be the same?

Please test every package, we also need to guard against misbuilds,
toolchain bugs, etc. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.18-24.1

---------------
linux-restricted-modules-2.6.24 (2.6.24.18-24.1) hardy-proposed; urgency=low

  [Tim Gardner]

  * SAUCE: Patch broadcom MODULE_LICENSE
    - LP: #372425
  * SAUCE: Update Broadcom to 5_10_91_9
    - LP: #372425

 -- Stefan Bader <email address hidden> Mon, 04 May 2009 23:37:26 +0200

Changed in linux-restricted-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Stefan Bader (smb) wrote :

Successfully verified Intrepid LRM as well.

Martin Pitt (pitti) on 2009-07-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 2.6.27-14.20

---------------
linux-restricted-modules (2.6.27-14.20) intrepid-proposed; urgency=low

  [ Tim Gardner ]

  * Update Broadcom to 5.10.79.10
    - LP: #292450
  * wl: applied web site patch to 5.10.79.10
    - LP: #292450
  * Update Broadcom wl to 5.10.91.9
    - LP: #372425

 -- Stefan Bader <email address hidden> Thu, 09 Apr 2009 08:57:01 +0200

Changed in linux-restricted-modules (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Changed in dell-mini:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers