Current dir added as first element of LD_LIBRARY_PATH

Bug #323327 reported by Marko Lindqvist on 2009-01-30
258
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Mario Limonciello
Intrepid
Low
Kees Cook
Jaunty
Undecided
Mario Limonciello
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: xorg-driver-fglrx

At least in Intrepid Ibex, xorg-driver-fglrx version 2:8.543-0ubuntu4

/etc/X11/Xsession.d/10fglrx has line
"LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib32"

When LD_LIBRARY_PATH is previously empty, as it usually is, this results in ":/usr/lib32" i.e. empty first element which is same as current directory.

This LD_LIBRARY_PATH is exported to user X-session, most notably to xterm environment.

Marko Lindqvist (cazfi) on 2009-02-03
description: updated
Kees Cook (kees) wrote :

Thanks for this report. It looks like this regression was introduced in Intrepid (and still exists in Jaunty). We'll work to get this corrected.

Changed in fglrx-installer:
status: New → Invalid
Changed in fglrx-installer:
assignee: nobody → superm1
status: Invalid → Confirmed
Changed in linux-restricted-modules-2.6.24:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.573-0ubuntu3

---------------
fglrx-installer (2:8.573-0ubuntu3) jaunty; urgency=low

  * debian/10fglrx.in:
    - Check if LD_LIBRARY_PATH is empty when we append to it. (LP: #323327)

 -- Mario Limonciello <email address hidden> Mon, 09 Feb 2009 18:50:46 -0600

Changed in fglrx-installer:
status: Confirmed → Fix Released
Kees Cook (kees) on 2009-02-12
Changed in linux-restricted-modules-2.6.24:
status: New → Invalid
Changed in fglrx-installer:
assignee: nobody → kees
importance: Undecided → Low
status: New → Fix Committed
Bryce Harrington (bryce) wrote :

Can confirm kees' intrepid fglrx package works on Intrepid with an r6xx card, solves original problem, and I didn't spot any major regressions offhand. totem plays, compiz runs, glxgears glx'es.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.543-0ubuntu4.1

---------------
fglrx-installer (2:8.543-0ubuntu4.1) intrepid-security; urgency=low

  * debian/10fglrx.in: correctly append to LD_LIBRARY_PATH (LP: #323327).

 -- Kees Cook <email address hidden> Thu, 12 Feb 2009 10:14:20 -0800

Changed in fglrx-installer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers