restricted driver wl fails to load

Bug #243930 reported by Kinap on 2008-06-29
28
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Ben Collins

Bug Description

Binary package hint: linux-restricted-modules-2.6.24-19-generic

earlier package works ok. (2.6.24.13-19.42)

this one failes with the following errors (2.6.24.13-19.44)

if i try to use the lw restricted driver from this package i get:
Jun 29 11:42:18 earl kernel: [ 284.708423] wl: module license 'unspecified' taints kernel.
Jun 29 11:42:18 earl kernel: [ 284.708565] wl: Unknown symbol wlc_get
Jun 29 11:42:18 earl kernel: [ 284.708717] wl: Unknown symbol wf_channel2mhz
Jun 29 11:42:18 earl kernel: [ 284.708741] wl: Unknown symbol wlc_isr
Jun 29 11:42:18 earl kernel: [ 284.708784] wl: Unknown symbol wlc_set
Jun 29 11:42:18 earl kernel: [ 284.708824] wl: Unknown symbol wlc_statsupd
Jun 29 11:42:18 earl kernel: [ 284.708862] wl: Unknown symbol bcm_bprintf
Jun 29 11:42:18 earl kernel: [ 284.708981] wl: Unknown symbol wlc_dpc
Jun 29 11:42:18 earl kernel: [ 284.709042] wl: Unknown symbol wlc_chipmatch
Jun 29 11:42:18 earl kernel: [ 284.709084] wl: Unknown symbol wlc_reset
Jun 29 11:42:18 earl kernel: [ 284.709161] wl: Unknown symbol wlc_sendpkt
Jun 29 11:42:18 earl kernel: [ 284.709216] wl: Unknown symbol wlc_intrsrestore
Jun 29 11:42:18 earl kernel: [ 284.709240] wl: Unknown symbol wlc_init
Jun 29 11:42:18 earl kernel: [ 284.709267] wl: Unknown symbol bcm_parse_tlvs
Jun 29 11:42:18 earl kernel: [ 284.709357] wl: Unknown symbol wlc_down
Jun 29 11:42:18 earl kernel: [ 284.709397] wl: Unknown symbol wlc_iovar_getint
Jun 29 11:42:18 earl kernel: [ 284.709437] wl: Unknown symbol wlc_iovar_setint
Jun 29 11:42:18 earl kernel: [ 284.709472] wl: Unknown symbol wlc_up
Jun 29 11:42:18 earl kernel: [ 284.709537] wl: Unknown symbol bcm_qdbm_to_mw
Jun 29 11:42:18 earl kernel: [ 284.709563] wl: Unknown symbol bcm_mkiovar
Jun 29 11:42:18 earl kernel: [ 284.709596] wl: Unknown symbol wlc_intrsoff
Jun 29 11:42:18 earl kernel: [ 284.709623] wl: Unknown symbol bcm_mw_to_qdbm
Jun 29 11:42:18 earl kernel: [ 284.709663] wl: Unknown symbol wlc_intrsupd
Jun 29 11:42:18 earl kernel: [ 284.709688] wl: Unknown symbol wlc_ioctl
Jun 29 11:42:18 earl kernel: [ 284.709725] wl: Unknown symbol wf_mhz2channel
Jun 29 11:42:18 earl kernel: [ 284.709750] wl: Unknown symbol wlc_intrson
Jun 29 11:42:18 earl kernel: [ 284.709775] wl: Unknown symbol wlc_attach
Jun 29 11:42:18 earl kernel: [ 284.709825] wl: Unknown symbol wlc_iovar_op
Jun 29 11:42:18 earl kernel: [ 284.709852] wl: Unknown symbol wlc_detach
Jun 29 11:42:18 earl kernel: [ 284.709889] wl: Unknown symbol pktsetprio

asked info:
Description: Ubuntu 8.04.1
Release: 8.04

linux-restricted-modules-2.6.24-19-generic
Non-free Linux 2.6.24 modules on x86/x86_64

Felix

GravityGripp (gravitygripp) wrote :

I have this problem also. Dell XPS M1530

Michele (mikelito) wrote :

Having the same problem on a Dell inspiron. The culprit seems to be the latest restricted-modules update.
If you still have the 2.6.24-18 kernel in GRUB menu, you can boot that item until this problem is fixed.

Michele (mikelito) wrote :

I think we can confirm this one. The problem is clear, reproducible and the culprit is quite clearly the update of restricted modules.
see also https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/245159,
which is exactly the same. one of the two should be marked as a duplicate

Changed in linux-restricted-modules-2.6.24:
status: New → Confirmed

Confirmed on Hardy 8.04 32-bit - Wednesday's automatic updates of the following components broke the wireless on my HP Compaq 6720s laptop with Broadcom BCM 4310 chipset (wl driver):

linux-restricted-modules-2.6.24-19-generic (2.6.24.13-19.42) to 2.6.24.13-19.44
linux-restricted-modules-common (2.6.24.13-19.42) to 2.6.24.13-19.44

I have confirmed this behaviour on 2 different laptops, and 3 Hardy 8.04 installs.

dmesg gives:

[ 24.455862] wl: module license 'unspecified' taints kernel.
[ 24.455918] wl: Unknown symbol wlc_get
[ 24.456127] wl: Unknown symbol wf_channel2mhz
[ 24.456156] wl: Unknown symbol wlc_isr
[ 24.456203] wl: Unknown symbol wlc_set
[ 24.456246] wl: Unknown symbol wlc_statsupd
[ 24.456290] wl: Unknown symbol bcm_bprintf
[ 24.456430] wl: Unknown symbol wlc_dpc [ 24.456498] wl: Unknown symbol wlc_chipmatch
[ 24.456548] wl: Unknown symbol wlc_reset
[ 24.456634] wl: Unknown symbol wlc_sendpkt
[ 24.456703] wl: Unknown symbol wlc_intrsrestore
[ 24.456731] wl: Unknown symbol wlc_init
[ 24.456763] wl: Unknown symbol bcm_parse_tlvs
[ 24.456882] wl: Unknown symbol wlc_down
[ 24.456928] wl: Unknown symbol wlc_iovar_getint
[ 24.456973] wl: Unknown symbol wlc_iovar_setint [ 24.457016] wl: Unknown symbol wlc_up
[ 24.457094] wl: Unknown symbol bcm_qdbm_to_mw
[ 24.457124] wl: Unknown symbol bcm_mkiovar
[ 24.457161] wl: Unknown symbol wlc_intrsoff
[ 24.457191] wl: Unknown symbol bcm_mw_to_qdbm
[ 24.457238] wl: Unknown symbol wlc_intrsupd
[ 24.457267] wl: Unknown symbol wlc_ioctl
[ 24.457309] wl: Unknown symbol wf_mhz2channel
[ 24.457338] wl: Unknown symbol wlc_intrson
[ 24.457367] wl: Unknown symbol wlc_attach
[ 24.457426] wl: Unknown symbol wlc_iovar_op
[ 24.457454] wl: Unknown symbol wlc_detach
[ 24.457494] wl: Unknown symbol pktsetprio

I too have this problem - it seems this file was removed from restricted modules:

/lib/modules/2.6.24-19-generic/volatile_bcmwl/wl.ko

This breaks wireless for BCM4310 chips.

H&W (highandwild) wrote :

Me too, Dell Inspiron 1525

The changelog for linux-restricted-modules-2.6.24-19 shows:

linux-restricted-modules-2.6.24 (2.6.24.13-19.44) hardy-proposed; urgency=low

  * Just ditch bcmwl from nic-restricted udeb.

 -- Ben Collins <email address hidden> Thu, 26 Jun 2008 19:40:42 -0400

Kinap (felix-flux) wrote :

a workaround until the fix is in, on Ubuntu that is.

use synoptic and force a version.
at least i had 2 in them.

Felix

@Kinap

This fix didn't work for me, as I was unable to force the version of one of the packages as the "Force" option in Synaptic was greyed out. My oldest previous kernel was 2.6.24.13-16 - perhaps this fix works with 2.6.24.13-18 but I have no way of trying.

Tony Flury (anthony-flury) wrote :

@all

i deleted 2.6.24-19 (just to make sure) and booted 2.6.24-18 (which did work previously) - sadly no dice.

I don't get the error when i do modprobe wl - or the Unknown symbols in demsg - but Wireless connection still does not work.

I will try to reinstall 2.6.24-18 and see if that helps

Tony Flury (anthony-flury) wrote :

Something very odd - i have gone back to the 2.6.24-18 module - and even re-installed it - and still no joy.

wireless connection is not functioning correctly - but it might be me.

Kinap (felix-flux) wrote :

kinda wierd, as my notebook had a choise of 2 version of the generic-modules.

but my main computer don't have them

well i think i was lucky then :)
 44 as being the one from hardy-updates the 42 from some place else, can't see anymore where it is from i think, as it only says (now).

think it was hardy-proposed.

i have selected every think on the updates tab in software sources

Felix

Jason Evans (jasdevan) wrote :

Through the Synaptic Package Manager, I enabled the "hardy-backports" repository and was able to remove the 2.6.24-19 modules to install the 2.6.24-18.41 modules and it worked for me (granted, I'm on a 64-bit rather than a 32-bit).

Either way, if you aren't seeing more than one version of the restricted modules, make sure you have the backports repository enabled.

Ben Collins (ben-collins) wrote :

I've uploaded the fix for this to hardy-proposed. Needs to be processed.

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → ben-collins
status: Confirmed → Fix Committed
McB (makkbe) wrote :

What is the status on the fix?

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

McB (makkbe) wrote :

Confirmed to work on a HP 6720s with a Broadcom BCM4310 NIC, running 32-bit Ubuntu 8.04.

Ramy (ramy-daghstani) wrote :

i am also confirming it is working on a Dell vostro 1500 with a broadcom BCM4315 (aka Dell wlan 1395) with 32 bit ubuntu hardy

Also confirming that works fine on Ubuntu 8.04.1 32-bit, HP Compaq 6720s with a Broadcom BCM4310 chipset :-)

mike (miguel-villa) wrote :

Me too, confirming that the proposed fix work on Ubuntu 8.04.1 32 bit on a Dell Inspiron I1525-199B with a Dell 1395 Wireless minicard XD ...

mike (miguel-villa) wrote :

sorry a typo, its a Dell Inspiron I1525-119B

Kinap (felix-flux) wrote :

yup working on an Acer notebook hardy 64bit

floid (malte-p) wrote :

Working on a HP M530.

Martin Pitt (pitti) wrote :

Regression, overwhelming positive feedback, and a trivial one-liner patch in Makefile which only affects wl. Waiving the 7 day maturing period and copied to hardy-updates. Thanks to all for testing!

We will investigate how this could have happend to avoid it happening again.

Changed in linux-restricted-modules-2.6.24:
status: Fix Committed → Fix Released
sagyvolkov (sagyvolkov) wrote :

Working on Dell D630

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers