System Hang Randomly

Bug #235753 reported by Tito's on 2008-05-29
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 8.04 hangs randomly in no predictable way.

+ Sometimes running ff3
+ Sometimes running thunderbird
+ Sometimes running whatever application
+ Sometimes with compiz effects on and off
+ Sometimes just login to the desktop
+ 4 or 5 hangs in 5 hours
+ with usb mouse or without it
+ with openoffice or without it
+ with video player or without it
+ no SysReq keys, just power off

My system:
+ Laptop compaq presario V3117la
+ Ubuntu 8.04 (hardy)
+ kernel 2.6.24-17-rt and kernel 2.6.24-17
+ AMD Semprom 3400+
+ nvidia GeForce Go 6150

I read many posts about this hang, but no answer.

My solution: disable nvidia restricted drivers and no hang

Can you confirm this?

Does this problem occur when you use the 173 version of the Nvidia driver?

Tito's (rcarrasco) wrote :

Yesterday I upgraded from linux-restricted-modules-common 2.6.24.12-17.36 to 2.6.24.13-18.41, Then enabling restricted drivers I got
nvidia-glx-new 169.12+2.6.24.13-18.41 and my system is running 4 hours without freeze

My system is updated every day

My sources.list is untouched, only cairo-dock, cairo-dock-plug-ins, and gnomeartng are downloaded .deb packages, but I'm not using these apps.

Some links:
http://linuxtechie.wordpress.com/2007/10/15/annoying-freezes-caused-by-nvidia-driver/, is about cpu scaling and nvidia, In my laptop, powernowd is installed and running.
http://bugzilla.kernel.org/show_bug.cgi?id=10453, my problem is something like that

Thanks

Tito's (rcarrasco) wrote :

Returning from hibernate (laptop lid closed at home and opened at work) system freeze in 10 minutes.

Tito's (rcarrasco) wrote :

Using nvidia driver 173 from nvidia website: hang once in screensaver (6 hours without hang)

Uninstall nvidia driver 173.Now using kernel 2.6.24-18-generic with driver NVIDIA UNIX x86 Kernel Module 169.12 Thu Feb 14 17:53:07 PST 2008 from nvidia-glx-new. Hang 4-5 times

Tito's (rcarrasco) wrote :

6 days running with driver "nv" in xorg.conf and absolutly NO HANG.

Definitely, the problem is nvida restricted driver

My system is up to date as jun 10, 2008 15.00 gmt

Tito's (rcarrasco) wrote :

Enabling again nvidia restricted driver. System hangs in 10 hours.

System up to date as jun 12, 2008

Tito's (rcarrasco) wrote :

running just with "nv" Driver and no hang from June 12

I can verify this happens with both Nvidia proprietary drivers versions: 169.12+2.6,24,13-19.42 driver in Hardy Heron and 173.14.05 (from Nvidia's site)

I am running:

AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
2.6.24-19-generic
NVidia GeForce 7800 GS

When I switch to open-source 'nv' driver, the system will not crash.

It is very difficult to reproduce as the lockup happens completely randomly.

Once when it crashed while I was on console, I saw errors with respect to SMP_APIC_TIMER and such.

It could be a SMP bug in Nvidia proprietary driver.

Tito's (rcarrasco) wrote :

System freeze 3 times in 4 hours with 173.14.05 from envyng.
No mouse, no keyboard, gnome monitor applets frezzed , no caps lock light, no errors in logs
( may be nvidia + broadcom wireless is the problem ??? )

now I will try 173.14.09 from nvidia site

last system update jul 5, 2008

Tito's (rcarrasco) wrote :

system freeze with NVIDIA-Linux-x86-173.14.09-pkg1.run 4 times in 7 hours. Back to nv driver

Whilst using 'nv' driver, I found the system still locked up randomly (but not as often as when using the proprietary Nvdiai driver).

I remember when I was using Gutsy, I never had this issue. So, I decided to try using the latest Gutsy kernel (2.6.22-14-generic). I installed the Gutsy kernel .deb files manually, disabled and removed nvidia-glx-new (including modifying /etc/default/linux-restricted-modules-common and setting DISABLED_MODULES="fc fglrx ltm nv")

I installed the latest and greatest Nvidia driver (173.14.05) and no lockups in the 4 days, 5 hours and 13 minutes the machine has been online. (And gdm or my X session has been running the whole time!)

I think something between 2.6.22 and 2.6.24 broke SMP systems and Nvidia. The fact that my system still locked up while using the 'nv' driver proves it's a kernel issue.

Tito's (rcarrasco) wrote :

Using nv driver since july 06 and i have lockups playing dvd. No mouse, no SYSRQ keys, just power button

Guys, check out bug 204996. The problem is the 2.6.24 kernel. I switched from Hardy Heron to Debian Lenny and upgraded to 2.6.25 and have had no lockups on my system. (Nvidia GeForce 7800 GTS, Atheros PCI wireless card, Athlon64 dual core)

Maybe 2.6.25 will fix your problems?

Tito's (rcarrasco) wrote :

Solved

Adding nohz=off on grub solve the problem for me

Now, no hangs for 2 days: playing dvd, ripping and using jackd with qsynth and external midi controller.

Bryce Harrington (bryce) wrote :

Hi rcarrasco,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log?

Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
Tito's (rcarrasco) wrote :

No hangs since added nohz=off in grub.
Now i'm in intrepid. no need to add nohz in grub

I'll mark the problem as resolved

Jonathan Thomas (echidnaman) wrote :

Marking fixed.

Changed in linux-restricted-modules-2.6.24:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.