Ubuntu

X-Window-System crashes due to Kopete

Reported by Mebus on 2008-05-14
4
Affects Status Importance Assigned to Milestone
Kopete
Invalid
High
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Unassigned
nvidia-common (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
openSUSE
Invalid
Unknown
xorg (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

I am using Kopete (4:3.5.9-0ubuntu1) with Gnome on Ubuntu 8.04. As soon as these yellow bubbles of Kopete pop up to inform me about new messages and I click them, the X enviornment restarts and I have to log in to Ubuntu again.

I'm using the Nvidia drivers:

nvidia-glx-new, nvidia-kernel-common

Having X restartet from time to time may result in data loss.

Ogni (ogni) wrote :

I have the same problem using Kubuntu. It only crashes if i don't have a chat window opened already.

Dariel Dato-on (odd-rationale) wrote :

Perhaps you could supply more information to help triage this bug. /var/log/Xorg.0.log is a good place to look. Also, try starting "kopete" in a terminal and see if there are any error messages.

Hope that helps!

Mebus (mebus) wrote :

I have found this error message in: /var/log/gdm/:0.log

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x7e) [0x80c780e]
1: [0xb7f3e420]

Fatal server error:
Caught signal 11. Server aborting

Best wishes

Mebus

Mebus (mebus) wrote :

same here.

Chris Coulson (chrisccoulson) wrote :

This isn't a GDM problem, so reassigning to xorg.

Mebus (mebus) wrote :

I also found evidence of the bug in other distros:

http://bbs.archlinux.org/viewtopic.php?id=41525
http://www.nvnews.net/vbulletin/showthread.php?t=110416

The problems seems not to occur with the older nvidia drivers.

Ogni (ogni) wrote :

as there are references and logfiles and so on...confirmed

Changed in kopete:
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Confirmed against the wrong package though. This is a NVIDIA binary driver bug, so re-assigning.

Changed in nvidia-common:
status: New → Invalid
Changed in xorg:
status: New → Invalid
Changed in kopete:
status: Unknown → Invalid
Changed in kopete:
importance: Unknown → High
Bryce Harrington (bryce) wrote :

Current development version does not have this issue

Changed in xorg (Ubuntu Hardy):
status: New → Invalid
Changed in nvidia-common (Ubuntu Hardy):
status: New → Invalid
Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

I think the hardy task is likely wontfix due to the age, and the proprietariness of the driver, but will leave it as medium priority in case someone wants to propose a backport.

Changed in linux-restricted-modules-2.6.24 (Ubuntu Hardy):
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.