[nvidia] Incomplete desktop in GNOME (hardy) after boot [GeForce 8800 GTS]

Bug #211954 reported by whoop on 2008-04-04
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Medium
Unassigned

Bug Description

This happens with about 10% of all system boots. In 2.16.24-12, 2.16.24-13 and now 2.16.24-14. When I boot into GNOME my desktop is sometimes incomplete. I get top and bottom panel with everything on it but my desktop is black, there is no wallpaper, there are no icons. If I restart X via ctrl+alt+backspace it restarts correctly.

This doesn't seem to be a kernel bug. Reassigning to xorg since you mention restarting X resolves the issue. Care to take a look at https://wiki.ubuntu.com/X/Debugging and providing the requested log files mentioned there. Thanks.

Bryce Harrington (bryce) wrote :

Not enough info to troubleshoot; see the link Leann pointed to for what to include. (As a minimum, always include your Xorg.0.log when reporting an X issue.)

Changed in xorg:
status: New → Incomplete
whoop (whoopwhoop) wrote :

OK, guys this bug reporting thing is a new thing for me, sorry. However it only took me three boots to reproduce the problem. hope my attachment helps. Attached Xorg.0.log. Please tell me if you need any further information as it seems this bug is easily reproducible for me, and I got confirmation of other people getting this error in the forums. Cheers.

whoop (whoopwhoop) wrote :

Extra attachment of xorg.conf.

Bryce Harrington (bryce) wrote :

Thanks for including the xorg.conf and Xorg.0.log.

Looks like the chipset is nvidia - refiling against l-r-m
(--) PCI:*(1:0:0) nVidia Corporation G80 [GeForce 8800 GTS] rev 162
(II) PCI: 01:00:0: chip 10de,0193 card 1043,8234 rev a2 class 03,00,00 hdr 00

Changed in linux-restricted-modules-2.6.24:
importance: Undecided → Medium
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Could you also attach your ~/.xsession-errors file?

whoop (whoopwhoop) wrote :

I saved .xsession.errors from a previous failure. See attached.

Bryce Harrington (bryce) wrote :

Hmm, there's a couple interesting bits in your .xsession-errors file, one relating to CRTC assignments and monitors, the other relating to usershares. I'm guessing the former may be the main suspect. From the error messages it sort of sounds like Compiz is involved; I'll add that as a possible component in case the compiz folks recognize the issue.

Computed CRTC assignment in 0.00 ms
 ... no assignment found
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
Shutdown failed or nothing to shut down.
...
/usr/bin/compiz.real (core) - Warn: Unable to parse XML metadata from file "ccp.xml"
Initializing nautilus-share extension
11

** (nautilus:6350): WARNING **: Unable to add monitor: Not supported
...

Starting gtk-window-decorator
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

I/O warning : failed to load external entity "/home/whoop/.compiz/session/default0"

(gnome-panel:6349): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -12 and height 24

Changed in compiz:
assignee: nobody → compiz
importance: Undecided → Low
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Can you enable the hardy-proposed and hardy-updates repositories, install EnvyNG so as to install the latest release of the driver?

If it doesn't solve the problem, try to disable the desktop effects (Compiz).

little jo (littel-jo) wrote :

Hello,
I think I have the same bug...
If i disable Compiz, there is always the same bug (but desktop is not black but clear red).

Funto (funto66) wrote :

I've had the same bug since my update hardy -> intrepid.
I usually don't use Compiz, I'm not sure but I think the bug is still here when I use it.

Furthermore, some times I have neither the icons on my desktop, neither the wallpaper, and some times the GTK+ theme/icons don't work and I have the default ones.

FreeUser (ddwqrbgrbfig) wrote :

I can confirm this for Intrepid.

For me this started then I began to use Twinview mode in Ubuntu with nvidia x-server-settings.

Even if I try to use "try to fix X server" (to make a new xorg.conf) the problem still persist.

Hope this get fixed till Jaunty at least :-)

Bryce Harrington (bryce) on 2009-09-02
tags: added: hardy
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Incomplete → Expired
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
assignee: compiz packagers (compiz) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers