fwlanusb crashes the system

Bug #200589 reported by tuco on 2008-03-10
72
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
High
Unassigned
Hardy
High
Tim Gardner

Bug Description

Binary package hint: linux-restricted-modules-2.6.24-12-generic

AVM Fritz!WLAN USB Stick v1.1 crashes on module fwlanusb and freeze the system.
Stick works with ndiswrapper fine.

ProblemType: Bug
Architecture: i386
Date: Mon Mar 10 15:06:24 2008
DistroRelease: Ubuntu 8.04
Package: linux-restricted-modules-2.6.24-12-generic 2.6.24.10-12.30
PackageArchitecture: i386
SourcePackage: linux-restricted-modules-2.6.24
Uname: Linux 2.6.24-12-generic i686

tuco (meprivat) wrote :
tuco (meprivat) wrote :
tuco (meprivat) on 2008-03-12
Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
Nils Kassube (kassube) wrote :

I can confirm this bug. Here the system crashed with the command iwconfig.
Attached is part of the output of dmesg from insertion of the Fritz!WLAN USB Stick until crash.

I can confirm this.

Changed in linux-restricted-modules-2.6.24:
status: Incomplete → Confirmed
nclm (nclm) wrote :

Same problem here

micfawl (michael-hept) wrote :

same problem here too
hope there will be a fix

Nils Kassube (kassube) wrote :

Comparing the sources of the fwlanusb and ipw2200 drivers I found a workaround for the bug - see the attached patch. However I don't understand why this works. For me there should not be a difference.

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Confirmed → Triaged

Same problem here. I also see no difference in the strcpy and snprintf, except that snprintf copies max IFNAMSIZ characters to wrqu->name...
I am not much of a linux guy. How do I apply the patch?

Nils Kassube (kassube) wrote :

How to apply the patch:

You should uninstall the package linux-restricted-modules because the module from this package would be loaded instead of the newly compiled one.

Then enter the commands below in a terminal. Please note: The source code download is 150MB, i.e. several hours for dial-up.

sudo apt-get install build-essential checkinstall sharutils
mkdir fwlanusb
cd fwlanusb
wget 'http://launchpadlibrarian.net/13046036/fwlanusb.dif'
apt-get source linux-restricted-modules-2.6.24-12-386
cd linux-restricted-modules-2.6.24*/
patch -l -p1 < ../fwlanusb.dif
cd fritz/fwlanusb/lib/
uudecode fwlanusb-lib.o.uu
cd ../src
make
sudo checkinstall make install

The last command will ask a question or two, use the default. At the point where the 10 package options are displayed, change the package name to something useful like "fwlanusb".

KaiH (kaihoffmanns) wrote :

Hey - I've got no internet connection, so "apt-get" won't work!!!

Michael Jörg (mijoe) wrote :

Same problem for me.

exactt (giesbert) wrote :

sad this didn't make it into linux-restricted-modules-2.6.24-17 . the wires are really annoying...

LCID Fire (lcid-fire) wrote :

Same problem here.

MeTheN (4motu) wrote :

Same problem here.

Gathog (tigerus) wrote :

A big problem here.

exactt (giesbert) wrote :

please don't forget us on this one!!!

@Nils Kassube
Could you give intructions on how to create a .deb package? I hate to trash my system with a "make install"...

Has anybody else tested the patch of Nils?

Nils Kassube (kassube) wrote :

@exactt: The instructions I gave include the checkinstall command which makes a .deb package and installs it. That's why you should make the package name something useful like "fwlanusb".

Klaus Layer (klaus-layer) wrote :

same here. can someone from the ubuntu kernel team please give a status when this bug will probably be fixed. thanks

Changed in linux-restricted-modules-2.6.24:
status: Triaged → Confirmed
johnp (johnpronto) wrote :

The patch of Niles works perfectly but the problem is to apply it you need to remove linux-restricted-modules which might cause problems with other devices, supporting nvidia cards for example. Is there any workaround for this ?

Same problem. The stick works fine under ubuntu 7.10 Gutsy Gibbon.

SkyScrap (andreas-ebbert) wrote :

Hi,

this is nuts! A regression from a previously perfectly working fine piece of hardware. And a patch that can only be applied if you are connected with the internet!

The good news is that the patch by nils (https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/200589/comments/9) works for me, also with the network manager - only that it does not show the signal strength. When applying the patch make sure to download the correct sources for your current kernel version.

Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: fwusblan causes oops in kernel

Patch Description: Do not write beyond the end of the name string array.

Patch: http://launchpadlibrarian.net/13046036/fwlanusb.dif

Test case: see bug description

Tim Gardner (timg-tpi) wrote :

Uploaded linux-restricted-modules-2.6.24_2.6.24.14-21.49

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → timg-tpi
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Nils Kassube (kassube) wrote :

Have just tested the fwlanusb module with packages linux-restricted-modules-2.6.34-21-generic version 2.6.24.14-21.49 and linux-image-2.6.24-12-generic version 2.6.24-21.42. It works for me, i.e. I could connect to my wireless network and the iwconfig cammand works without crash now. Thanks for providing the new version.

Stefan Bader (smb) wrote :

Make states consistent

Changed in linux-restricted-modules-2.6.24:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

linux-restricted-modules-2.6.24 -21 copied to hardy-updates.

Changed in linux-restricted-modules-2.6.24:
status: Fix Committed → Fix Released
status: Fix Committed → Invalid
linuxcub (smusnmr) wrote :

>KaiH wrote on 2008-04-26: (permalink)
>Hey - I've got no internet connection, so "apt-get" won't work!!!

I've got no internet connection without the patch, too. To get the patch, I need an internet connection!!! Biiig problem!!!

Will this bug be fixed in kernel 2.6.27-7?

siggi

LCID Fire (lcid-fire) wrote :

@linuxcub: fwlanusb is not even included in 2.6.27...

SkyScrap (andreas-ebbert) wrote :

are there any instructions how to upgrade to intrepid with this manual patch installed? will a "sudo make uninstall" work, before installing from a fresh ISO Image?

LCID Fire (lcid-fire) wrote :

In theory it should. To be sure just check and delete all the file of the old kernel version (/boot, /lib/modules, ...) and update grub.

SkyScrap (andreas-ebbert) wrote :

ah, that was a mental connection I have not made before. Since this is a kernal module, it is gone with a new kernel. this explains, why me nephew's pc cannot connect to the net anymore and also hints that everything should be fine, when I just upgrade to the latest ubuntu. thanks :)

Nils Kassube (kassube) wrote :

The module for 2.6.24 doesn't work with 2.6.27 (Intrepid) and it seems you can't even compile the module with the new kernel any longer. You can try if it works with ndiswrapper (or keep the kernel and linux-restricted-modules from Hardy).

LCID Fire (lcid-fire) wrote :

The good news is thought that ndiswrapper works :)

SkyScrap (andreas-ebbert) wrote :

Enough of that nonsense. I will just buy my nephew a new sifi usb stick instead of hacking a buggy system. which one works out of the box? I'm sick of this.

See my report -> http://blog.karroum.dyndns.org/andreas/2008/12/22/how-to-upgrade-from-ubuntu-804-hardy-heron-to-810-intrepid-ibex-without-internet-access/

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers