System lags after resume due to high hard drive activity

Bug #190585 reported by Alexei Colin on 2008-02-10
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

System lags (to a point where it is not usable) after resuming from a suspend to RAM.
The lagging is due to extremely high hard-drive activity.

System:
Thinkpad T60 with ATI Radeon X1400
Ubuntu 7.10 (Kernel 2.6.24-4-generic)
Catalyst 8.01 video drivers (fglrx)
Compiz Fusion package v. 1:0.6.2+git20071119-0ubuntu1~gutsy1

To replicate the problem, the computer must be suspended when RAM use is above ~60%.
Then, upon resume there is mad harddrive activity, but almost no CPU usage and nothing
strange with memory usage. The system is extremely slow. I don't know which process is
accessing the harddrive so much (how do you check this?).

Running
sudo swapoff -a
sudo swapon -a
fixes the lagging and brings the system back to normal (but this takes a long time).

If suspend was done when the RAM usage was low, system is normal after resume.

The problem does not exist in Metacity -- hence the bug report in Compiz.

Thank you!

Alexei Colin (alexei.colin) wrote :
Iulian Udrea (iulian) wrote :

Thank you for your bug report. Can you please try to reproduce this with compiz disabled? Also please attach your ~/.xsession-errors ; /var/log/Xorg.0.log and the output of lspci -vvnnn as separate attachments to your bug report.

Thanks!

Changed in compiz:
assignee: nobody → iulian
status: New → Incomplete
Iulian Udrea (iulian) wrote :

I'm sorry. Please use lspci -vvnn (with double "n").

Mark Baas (mark-baas123) wrote :

This is not due to compiz, i have it with metacity either. Basically i always have it.

Iulian and Mark, thank you for replying!

It just so happened that I added some RAM to my computer a few days
ago: from 1GB
to 2GB. With 2GB, I cannot reproduce the bug. I've maxed out RAM usage
and had lots
of swap usage, but even though this would have caused the bug before,
now the system
resumes fine every time (under Compiz). I did not try it under
metacity with new RAM.

I swear the bug was consistent on my system before. But I cannot
guarantee that the
RAM upgrade was what fixed it because I also rebuilt swap (mkswap) a
few times between
now and then.

If it is worth it, I would be willing to take out the new 1GB of RAM
and try to reproduce
the bug again. Let me know if that would be helpful.

Mark, if this is not a Compiz bug, which project should we report it under?

-Alexei

On Fri, Feb 15, 2008 at 11:27 AM, Mark Baas <email address hidden> wrote:
> This is not due to compiz, i have it with metacity either. Basically i
> always have it.
>
>
>
> --
> System lags after resume due to high hard drive activity
> https://bugs.launchpad.net/bugs/190585
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexei Colin (alexei.colin) wrote :

Iulian and Mark, thank you for replying!

It just so happened that I added some RAM to my computer a few days ago: from 1GB
to 2GB. With 2GB, I cannot reproduce the bug. I've maxed out RAM usage and had lots
of swap usage, but even though this would have caused the bug before, now the system
resumes fine every time (under Compiz). I did not try it under metacity with new RAM.

I swear the bug was consistent on my system before. But I cannot guarantee that the
RAM upgrade was what fixed it because I also rebuilt swap (mkswap) a few times between
now and then.

If it is worth it, I would be willing to take out the new 1GB of RAM and try to reproduce
the bug again. Let me know if that would be helpful.

Mark, if this is not a Compiz bug, which project should we report it under?

-Alexei

Iulian Udrea (iulian) on 2008-02-18
Changed in compiz:
assignee: iulian → nobody
importance: Undecided → Low
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

This isn't a compiz bug.

Changed in compiz:
status: New → Invalid
Thomas Kluyver (takluyver) wrote :

Putting this under linux-restricted-modules, as I suspect it's related to fglrx.

Re-opening, because I see the same thing in Hardy, using kwin-kde4 with compositing features enabled. I suspect that it may be related to 3d acceleration, hence why Alexei found it didn't occur with metacity.

Kubuntu-KDE4 Hardy, ATI Mobility Radeon X600 with fglrx drivers from repositories (hardy-backports).

Changed in compiz:
status: Invalid → New
Bryce Harrington (bryce) wrote :

Hi alexei.colin,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in linux-restricted-modules-2.6.24:
status: Incomplete → Invalid
Thomas Kluyver (takluyver) wrote :

Have replicated on Intrepid recently. Dropping to a terminal and running "top" (eventually) revealed low (0.7%, I think) but consistent CPU use by kswapd0 (pid 180) which is not normally there, as far as I'm aware. Killing that process appeared to have no effect--presumably it respawned instantly with the same pid.

Changed in linux-restricted-modules-2.6.24:
status: Invalid → Confirmed
Zak (zak-wilson) wrote :

Confirmed on Intrepid with a Thinkpad Z61m using fglrx. CPU usage is low, but IO wait is near 100%. Another bug report mentioned swapoff/swapon as a solution. This doesn't work for me: the problem continues after swapoff/swapon completes.

Bazon (bazonbloch) wrote :

I'm also effected on Intrepid with a Fujitsu Siemens Amilo M6453, 1GB RAM and using fglrx.

Thomas Kluyver (takluyver) wrote :

I suspect that this may be the same issue as the much older report of bug 15372.

It seems like everyone here has an ATI card. This may be more like bug 391628.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers