dependencies installs -386 kernel which hangs on boot

Bug #188287 reported by Timo Aaltonen on 2008-02-02
24
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
High
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
mickdido

Bug Description

I'm not sure if this is the right place to "complain", but I upgraded my desktop to alpha4 and it installed the -386 flavor of the kernel for some reason. Since grub lists -386 as the first entry, it was booted by default and the computer hung while usplash was still visible.

Anyway, I was wondering why I got the kernel in the first place? Jockey-common depends on restricted-modules, but AFAICT the order is correct (generic | 386). I have nvidia-glx-new installed which depends on nvidia-kernel-169.09, and searching for pacakges that provide it lists l-r-m-ver-386 as first, don't know if it matters or not.

hope this report makes any sense.

Martin Pitt (pitti) wrote :

At first sight I have no idea why the -i386 kernel was pulled in. Where did you upgrade from, Gutsy? An earlier Hardy? Was it a temporary package inconsistency, i. e. can you still reproduce this behaviour on current hardy?

Changed in jockey:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

It was earlier Hardy, and jockey was added then I guess. I haven't tried to reproduce it yet, but remember seeing similar issues with edgy and feisty netboot (which would suggest dependancy priority problems with lrm).

Mario Limonciello (superm1) wrote :

We got caught by this on a few dist-upgrades today from gutsy to hardy. It's not jockey doing it. It's because of a dep to nvidia-glx-new

Mario Limonciello (superm1) wrote :
Mario Limonciello (superm1) wrote :
Mario Limonciello (superm1) wrote :
Mario Limonciello (superm1) wrote :
Mario Limonciello (superm1) wrote :

Personally, I believe this should be a high priority. Folks with nvidia cards that upgrade are getting stuck with no sound on a reboot because of LUM for the 386 kernel not getting installed.

Changed in linux-restricted-modules-2.6.24:
status: Incomplete → Confirmed
Changed in dell:
importance: Undecided → High
status: New → Confirmed
Changed in mythbuntu:
importance: Undecided → High
status: New → Confirmed
Mario Limonciello (superm1) wrote :

Adding the mythbuntu project for visibility in bugs that keep getting filed there and marked as invalid without logs.

Mario Limonciello (superm1) wrote :

Particular comment from apt.log:

"Installing linux-restricted-modules-2.6.24-12-386 as dep of nvidia-glx-new"

Timo Aaltonen (tjaalton) wrote :

It takes the first kernel that provides "nvidia-kernel-$VERSION", and I'm not sure how to work around it..

Martin Pitt (pitti) wrote :

it currently has a pure virtual dependency, which is actually violating policy. Aside of this, you could change the preference by depending on l-r-m-2.6.24-generic | nvidia-kernel-169.12, but of course this would then break upgrades into the other direction.

Mario Limonciello (superm1) wrote :

I would think that Martin's suggestion is the lesser of two evils in this case if a better solution doesn't come up. The generic kernel is the default one upon installation. Folks choosing the 386 kernel should be a lot less.

http://lists.debian.org/debian-devel/2002/10/msg00841.html

pdragon (pdragon) wrote :

I ran into a similar issue, but am having a different problem as a result. The 386 kernel boots fine, but then my tuner and sound don't work. When I try and boot the generic kernel, then my computer hangs. I turned the splash and quiet kernel off to watch it boot, and it is hanging at

"Begin: Waiting for root file system..."

If I just wait, it eventually drops to a busy box prompt saying my root partition (/dev/sda1) does not exist.

pdragon (pdragon) wrote :

Talked with Mario on IRC and he got me up and working again. If you have the same issue I did (generic not booting, hangs at splash screen) type this at the command line:

sudo update-initramfs -k 2.6.24-12-generic -u

Reboot and force it to use the generic kernel and everything shoot be wroking again. Edit the grub menu.lst to use the generic kernel then instead of the i386.

harvest316 (harvest316) wrote :

Referred here from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/194816

Heron upgrade killed my sound (kernel version 2.6.24-12-386), fixed by installing linux-ubuntu-modules-2.6.24-12-386.

Seems like a dependency issue.

Harvest316:

The "proper" fix is to switch to the "2.6.24-12-generic" kernel. Your
linux-ubuntu-modules got installed automatically for that kernel. It's
an accident that the -386 kernel was even installed.
On Tue, 2008-03-25 at 10:46 +0000, harvest316 wrote:

> Referred here from
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/194816
>
> Heron upgrade killed my sound (kernel version 2.6.24-12-386), fixed by
> installing linux-ubuntu-modules-2.6.24-12-386.
>
> Seems like a dependency issue.
>

---
Mario Limonciello
Dell | Linux Engineering
<email address hidden>

Timo Aaltonen (tjaalton) wrote :

I've done the change so it would be included in the next upload, but that affects also -rt and -server, so when people using those upgrade they get -generic by default?

Changed in linux-restricted-modules-2.6.24:
status: Confirmed → In Progress
Timo Aaltonen (tjaalton) on 2008-04-02
Changed in linux-restricted-modules-2.6.24:
assignee: nobody → tjaalton
Daniel Hahler (blueyed) wrote :

Yes, Timo. See also bug 188579, where it affected virtualbox-ose.
Just for info, I've filed a bug about it in apt, linked from bug 188579.

Timo Aaltonen (tjaalton) wrote :

Actually, infinity gave another proposal: drop the nvidia-kernel-FOO dependancy altogether. Fglrx is doing just fine without such a dep, and it's pointless to keep anyway, since there are ways to break that dependancy.. for instance by upgrading the driver and then restarting X ("boom").

The first proposal would have broken upgrades for the other flavours, so this one should be safer.

Comments before I upload?-) (which is soon)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.12-14.32

---------------
linux-restricted-modules-2.6.24 (2.6.24.12-14.32) hardy; urgency=low

  * ABI bump to 14.
  * Madwifi 0.9.4 (LP: #208754):
    - fixes compilation for recently released kernel 2.6.24
    - introduces Minstrel rate control algorithm
    - introduces switch to turn ANI (Ambience Noise Immunity) off, which
      can help to improve performance (see also #705)
    - several bug fixes to improve stability
    - now defaults to radiotap headers in monitor mode
    - adds support for variable number of VAPs, tunable via module
      parameter
  * control: Drop the nvidia-kernel-ABIVER dependencies from nvidia-glx*, since
    fglrx is doing just fine without them, and they only create problems
    during upgrades when apt selects the first package to provide the
    virtual package. (LP: #188287)
  * ltmodem/serial.c: Modify to compile with 2.6.24. Enable ltmodem again.
    (LP: #210652)
  * Add openvz flavour.

 -- Timo Aaltonen <email address hidden> Thu, 03 Apr 2008 01:45:22 +0300

Changed in linux-restricted-modules-2.6.24:
status: In Progress → Fix Released
Changed in mythbuntu:
status: Confirmed → Fix Released
Changed in dell:
status: Confirmed → Fix Released

I had the same problem and used pdragon's advice, but now my sound is playing through my pc speaker!

mickdido (mickdido) on 2009-11-20
Changed in linux-restricted-modules-2.6.24 (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → mickdido (mickdido)
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306062

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions