nVidia: Display resolution randomly starts at low resolution

Bug #179020 reported by Stanley Sokolow on 2007-12-28
16
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.12 (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-restricted-modules-2.6.24.2

I have a random display resolution problem which also has been mentioned by others on the Ubuntu Forums. I have been using the nVidia restricted driver. 30% of the times I start up, the resolution is low (probably 640x480 or 800x600) at the "greeter" screen (login screen), and the other 70% of the startups have the resolution I actually have set in the preferences. When I login and get the Gnome desktop, the resolution is the same as it was at the login screen. When it is in the low-res mode, the top panel is very confused. The normal "System" menu is missing (probably overlaid by other icons on the panel). When I hover, the wrong tooltip pops up for some of the panel items as though there is something very wrong with the mapping between mouse pointer position and the icon positions. This happens on Ubuntu 7.10 and 8.04 alpha 2 with the same probabilities, when using the nVidia restricted driver. That is, for 10 startups, I get 3 of the wrong resolution, randomly. When I use ctrl-alt-backspace to shutdown the X server and it restarts without doing a complete warm boot of the system, the same thing happens randomly. My computer has a Celeron processor and a GeForce FX 5500 nVidia graphics adapter, using the nVidia restricted driver. I tried it again with the open-source driver just to see if it is a driver bug rather than an X.org bug. That is, I used Restricted Drivers Manager to remove the nVidia proprietary driver and revert to the open source driver for nVidia graphics adapters. Then I re-booted 10 consecutive times on the same computer as before. This time there were no low-resolution startup mistakes; every time the resolution was correct at the login (greeter) screen and on the desktop after I logged in. My conclusion: This is probably a bug in the nVidia restricted (proprietary) driver.

description: updated
Stanley Sokolow (overbyte) wrote :

nVidia released an update to the restricted driver on Dec. 20, 2007. http://www.nvidia.com/object/linux_display_ia32_169.07.html . This should be incorporated into Hardy 8.04 alpha-3 for testing. Maybe this problem has been fixed by nVidia. Also, the restricted driver package description should include the version number of the nVidia (and other) drivers included in that package.

Today, many updates were available from system update, including the new nVidia driver. I installed the updates, which went normally. I restarted. I got a popup message informing me that a restricted driver was available. I activated it. It downloaded from the Ubuntu repository again and installed. I restarted. I activated the "Normal" effects. They work. Then I did 10 consecutive warm restarts of Ubuntu. All 10 detected the screen resolution correctly. No low resolution startups. This problem seems to have been fixed by nVidia's new driver. (Updated title of this bug.)

Compaq F572, NVIDIA GeForce Go 6100. I had good resolution until January 7, 2008 when new software was downloaded. Since then I have been only able to get 640 x 480. I reinstalled the restricted drivers without success. I also tried the new NVIDIA driver without success.

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Steven Mitnick - Are you also running Hardy Heron? If so could you open a new bug report and include the information requested at https://wiki.ubuntu.com/X/Debugging

Changed in linux-restricted-modules-2.6.12:
status: New → Fix Released
MaxFox (m-fox2k) wrote :

hello
i still have this problem.

if pc was off about 8~ hours and i turn it on, ubuntu booting with 640x480 resolution at login screen and continue with low resolution.
after restarting graph system (ctrl+alt+bk space) it work with normal resolution.

using Ubuntu 8.04 (hardy) with new nvidia driver.

which files i need to submit here?

Ilari Oras (ilarioras) wrote :

Same me (alpha-4 and beta)
Try to open krandrtray and its crash:
http://paste.ubuntu.com/55000/

summary: [Hardy 8.04 alpha-2, nVidia proprietary driver] Display resolution
randomly starts at low resolution instead of the chosen resolution when
using nVidia proprietary driver but not a problem with open-source
- driver. New nVidia proprietary driver is in the updated Ubuntu
- restricted repository. It fixes the problem.
+ driver.
Thomas Hotz (thotz) on 2012-12-03
summary: - [Hardy 8.04 alpha-2, nVidia proprietary driver] Display resolution
- randomly starts at low resolution instead of the chosen resolution when
- using nVidia proprietary driver but not a problem with open-source
- driver.
+ nVidia: Display resolution randomly starts at low resolution
Changed in linux-restricted-modules-2.6.12 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers