Gnome terminal crashes when using desktop effects

Bug #134563 reported by biketrials on 2007-08-24
14
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

In gutsy tribe 5... upon enabling desktop effects gnome terminal crashes upon opening. Worked fine in feisty.

Click on open terminal quick launch icon and the terminal appears for a brief second and then closes.

Nvidia graphics card w/ intel dual core 2.4

Sitsofe Wheeler (sitsofe) wrote :

(Might be related to Bug #58232 ...)

Sitsofe Wheeler (sitsofe) wrote :

biketrials:
Can you add your
/etc/X11/xorg.conf
to launchpad?

Changed in compiz:
status: New → Incomplete
biketrials (morleyw) wrote :
Download full text (4.5 KiB)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Jun 13 18:39:30 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

 # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "extmod"
    Load "freetype"
    Load "int10"
    Load "vbe"
    Load "glx"
EndSection

Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

       # /dev/input/event
       # for USB
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

       # /dev/input/event
       # for USB
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

       # /dev/input/event
       # for USB
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "cursor"...

Read more...

Sitsofe Wheeler (sitsofe) wrote :

Looks like "AddARGBGLXVisuals" is already present but the problem remains. Just for the record, "Render Accel" (note the space) isn't a real option (I don't know what driver you are using but see http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-d.html for a list of options). Additionally can you attach (using the launchpad web interface) your
/var/log/Xorg.0.log
file (please don't paste the contents into a comment).

biketrials (morleyw) wrote :

xorg.0.log

Sitsofe Wheeler (sitsofe) wrote :

Setting back to New as report has added all requested information.

biketrails:
Just to rule something out can you confirm that the problem happens with a brand new user using desktop effects too?

Changed in compiz:
status: Incomplete → New
biketrials (morleyw) wrote :

Created a new user, desktop effects were enabled by default. Gnome-terminal crashed when opened.

Disabled desktop effects, then restarted desktop effects and this also caused gnome-terminal to crash when opening.

Manuel Ludwig (luigi-smarty-s) wrote :

Similar here...
In Gnome i prefer to use nautilus-open-terminal, and today i enabled under Desktop Effects "extra effects".
Since then I was not able to use the open-terminal plugin! When i try to, nautilus comes up to 100%.
The problem still exists when i disable desktop effects, and i can reproduce the problem with a new user!

How to solve:
After some debugging i found out that a key is missing in gconf
open gconf-editor and navigate to /desktop/gnome/applications/terminal
In case the exec Value is empty, fill in
gnome-terminal

Sitsofe Wheeler (sitsofe) wrote :

biketrials:
OK this is extreme but it might lead to a better explanation. Can you press alt-f2 and run xterm and within that type gnome-terminal and post the output here?

biketrials (morleyw) wrote :

Also crashed see attached crash file I pulled using strace.

Sitsofe Wheeler (sitsofe) wrote :

strace output contains the following:
Gdk-ERROR **: The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1288 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Graphics driver is 100.14.11 .

biketrials:
What is the output of
dpkg -l *nvidia* | grep ii
?

Additionally, does disabling Xinerama by adding
Option "Xinerama" "false"
to your xorg.conf ServerLayout section then restarting X make any difference (I'm assuming you don't use dual monitors with separate cards)?

Changed in compiz:
status: New → Incomplete
biketrials (morleyw) wrote :

This was the output, and I only have a single monitor at this time.

ii nvidia-glx-new 100.14.11+2.6.22.3-10.1 NVIDIA binary XFree86 4.x/X.Org 'new' driver
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files
ii nvidia-kernel-source 1:1.0.9639+2.6.22.3-10.1 NVIDIA binary kernel module source

biketrials (morleyw) wrote :

Disabling Xinerama made no difference.

Travis Watkins (amaranth) wrote :

Switch to nvidia-glx, the nvidia-glx-new driver is horrible.

Sitsofe Wheeler (sitsofe) wrote :

biketrials:
Does using an xterm and running
XLIB_SKIP_ARGB_VISUALS=1 gnome-terminal
let gnome terminal start?

biketrials (morleyw) wrote :

using the compand XLIB_SKIP_ARGB_VISUALS=1 gnome-terminal it works fine, however the image in the background remains static.

Timo Aaltonen (tjaalton) wrote :

I'm closing this bug as fixed in Hardy, since there hasn't been any activity here or similar bugs opened.

Changed in linux-restricted-modules-2.6.22:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers