Nvidia restricted drivers segfault in _nv001174X+0x36

Bug #162109 reported by Peter on 2007-11-12
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Nvidia Restricted Drivers cause a Signal 11 Fatal Server Error when trying to start X.

Configuration and steps taken:

Motherboard: Asrock 939 Dual Sata II
Processor: AMD Athlon64 3200
Memory: 1Gb OCZ

Fresh install of Kubuntu Gutsy Gibbon 7.10. Allowed Adept to install all pending updates and then switched on the Nvidia restricted drivers from system settings. Nv driver works OK, but on restart get a blank screen when starting Xserver.

The following is the final few lines of Xorg.0.log

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6d) [0x48670d]
1: /lib/libc.so.6 [0x2aaebc32e7d0]
2: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv001174X+0x36) [0x2aaebe7e0986]

Fatal server error:
Caught signal 11. Server aborting

I have tried multiple alternatives e.g. manual install of Nvidia drivers, using Envy etc. Nothing tried so far solves the problem.

Peter (user1) wrote :
Peter (user1) wrote :
Peter (user1) wrote :
Peter (user1) wrote :

Forgot to mention - using amd64 version of Kubuntu

Bryce Harrington (bryce) wrote :

Hi user1,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in linux-restricted-modules-2.6.22:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in linux-restricted-modules-2.6.22:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers