Ubuntu

suspend in Gutsy doesn't work

Reported by Ladislav Lhotka on 2007-10-24
6
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

I installed Ubuntu 7.10 on my notebook HP Compaq nc6230 and the suspend function that worked flawlessly in feisty now blanks the screen but the machine appears not to get to the suspended state (the power button light is on, whereas in the suspended state it blinks). I have to turn off the machine afterwards.

The kernel is
Linux missotis 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

I am using the ATI proprietary Xorg driver fglrx.

Sandra Dismar (sdismar) wrote :

confirmed on a Thinkpad R52. Hibernate doesn't work, either!

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested at [WWW] https://wiki.ubuntu.com/DebuggingACPI as separate attachments.

OK, I followed all the instructions on the DebuggingACPI page:
1. BIOS upgrade to version F.13 date 02/27/2007 did not help
2. Output of the lspci and dmidecode programs and contents of /var/log/kern.log.0 are in the preceding attachments.

Output of "uname -a" is in my original bug report.

The problem is related to the proprietary ATI driver fglrx. With the free Xorg driver, the laptop suspends and wakes up properly. However, in feisty everything worked with fglrx, too.

Changed in linux-source-2.6.22:
importance: Undecided → Medium
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers