no nvidia-glx or fglrx for server kernels

Bug #153011 reported by Mellotron on 2007-10-15
18
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by catullus
linux-restricted-modules-2.6.24 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by catullus

Bug Description

The bug:
When attempting to open the Restricted Drivers Manager, a dialogue box returns this message:
[quote]
You need to install the package

linux-restricted-modules-2.6.22-14-server

for this program to work.[/quote]
No such package exists to what I could find. Confirmation of a forum user confirmed that he could not find the package in either fiesty, or gutsy. Furthermore, a search on google returns a single sight written in chinese. He has no response yet.
This bug is also tied to the "Screens and Graphics" utility, and the "nvidia-settings" program as well.

My original goal that led to this problem:
Setup dual monitors in gutsy, having fusion on both, but generating a seperate cube for both.
My setup:
Amd64 version of gutsy, thus amd64 repositories
2 * Nividia geforce 7600gs's, one crt monitor plugged into each.

My drivers were originally working nicely with proprietary version, however setting up dual monitors originally through "Screens and Graphics" was a heartfelt pain, as it led to many a crash, and many a altered/botched xorg.conf. A suspicion I have leading to some of the errors I was getting is the fact that my crt drivers arent found in the default repo, and I had to download them. Because of this, everytime I run the util, I have to re-add them again. It would be nice if the program could let me know where to save my drivers, and furthermore, if it would add mine automatically.

I was trying everything to get this to work, and eventually decided to try swapping the glx drivers with the glx-new drivers. Once I did this, is when I gander that my programs started returning these wierd errors.

nvidia-settings returned this error
[quote]You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. [/quote] When I run the suggested command however, it does nothing but botch my xorg for next time I want to log in.

I am following this problem here: http://ubuntuforums.org/showthread.php?p=3537848#post3537848

Tien Nguyen (tienhn) wrote :

I too having this problem.
================
You need to install the package

  linux-restricted-modules-2.6.22-14-server

for this program to work.
==============

Where do we get this package?
Regards,

shellex (stefanwehrmeyer) wrote :

This is not a real bug. You probably just messed with kernel packages you don't need.
Uninstall the linux-image-[kernelversion]-server package and reinstall linux-image-[kernelversion]-generic. This should do the trick.

catullus (vergil+launchpad) wrote :

This is still a bug for those who want linux-image-server _and_ restricted packages!

Will Saxon (saxonww) wrote :

linux-image-server was installed when I originally installed the server image for Feisty. It was retained when I updated to Gutsy. The -server kernel images seem to track the -server distribution images (gee).

If you uninstall the -server image, you also have to uninstall other -server related packages which you may/may not need.

So there ought to be a matching linux-restricted-modules-2.6.22-14-server. It should not be a big deal.

captive (salvo-schifani) wrote :

+1
It's really annoing if you need the -server flavour (in order to use ram >3Gb, for example) *and* you need restricted modules, such as nvidia.
You can solve it doing the following:
    * Install the nvidia-kernel-source package. Make sure nvidia-glx, nvidia-kernel-common are already installed as well. And install the linux-headers-server package.
    * Follow the instructions for METHOD #1 in /usr/share/doc/nvidia-kernel-sources/README.Debian.gz
    * Once you have installed the new package, the module should now be in /lib/modules/2.6.22-14-server/nvidia/, I had to cd into /lib/modules/2.6.22-14-server and run depmod manually as root.

(as seen on http://blog.0xb.org/2007/05/ubuntu-server-kernel-and-nvidia-driver.html)

Henrik Nilsen Omma (henrik) wrote :

This will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-restricted-modules-2.6.22:
status: Confirmed → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
Jacob Emcken (jacob-emcken) wrote :

According to this packages.ubuntu.com there is still no linux-restricted-modules-server package.

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=linux-restricted-modules&searchon=names&subword=1&version=hardy&release=all

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Eric Work (ework) wrote :

+1
Having to install the nvidia driver from the module source package is a pain. I was also unable to get madwifi working with gusty using the server kernel. I've switch back to Fedora just because of this bug. Fedora has a PAE specific kernel with nvidia + madwifi drivers for it using Livna. I want 32-bit with 4GB memory and the restricted drivers, is that too much to ask.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.9-8.20

---------------
linux-restricted-modules-2.6.24 (2.6.24.9-8.20) hardy; urgency=low

  [ Timo Aaltonen ]
  * nvidia-glx*:
    - When using the nvidia-settings binary for storing
      values in xorg.conf it clutters up the file with unneeded settings,
      and some are just plain wrong nowadays (the mouse device for
      instance). So, don't ship the version included in the drivers, instead
      Suggest nvidia-settings -package (again), and fix the issues there.
    - Don't ship nvidia-settings.desktop, only the .png file.
      Nvidia-settings will include the desktop-file.
  * rules:
    - Enable fglrx for -rt (LP: #182242)
  * rules, control.stub.in:
    - Enable -server flavor. (LP: #153011)
  * dvb:
    - Add dvb-usb-bluebird-01.fw (LP: #90723)
    - Add dvb-fe-tda10046.fw (LP: #107090)
  * ati: Update fglrx to 8-02. (LP: #173663, #189772)
  * {nvidia-glx,nvidia-glx-dev,xorg-driver-fglrx}.postrm.in
    - Check that the diverted file actually belongs to the current package
      before trying to remove the diversion. Thanks to Kirk Turner and
      Alberto Milone for patches, and Michael Vogt for review!
      (LP: #36625, #130208, #175789)
  * nvidia-glx.{preinst,postrm}.in, rules:
    - Fix the path of libglx.so.
  * rules:
    - Unexport CFLAGS and LDFLAGS to cope with the new dpkg-buildpackage.

  [ Alberto Milone ]
  * debian/lrm-video: Add support for EnvyNG.

 -- Timo Aaltonen <email address hidden> Thu, 14 Feb 2008 17:57:44 +0200

Changed in linux-restricted-modules-2.6.24:
status: Triaged → Fix Released
Eric Work (ework) wrote :

YAHOO!!

Peter Funk (pf-artcom-gmbh) wrote :

What should I do on a Gutsy system with 8GB-RAM and NVidia-GPU if
I need the restricted-modules and the server kernel and don't want
to upgrade the whole system to Hardy now?

Thanks in advance,
Peter

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions