gutsy: xen restricted modules: madwifi broken / ath_hal missing

Bug #152755 reported by phaidros on 2007-10-14
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-restricted-modules-2.6.22-14-xen

modprobe ath_pci

[ 3962.369100] ath_pci: Unknown symbol _ath_hal_attach
[ 3962.369319] ath_pci: Unknown symbol ath_hal_process_noisefloor
[ 3962.370054] ath_pci: Unknown symbol ath_hal_computetxtime
[ 3962.370675] ath_pci: Unknown symbol ath_hal_mhz2ieee
[ 3962.370909] ath_pci: Unknown symbol ath_hal_detach
[ 3962.371961] ath_pci: Unknown symbol ath_hal_probe
[ 3962.373322] ath_pci: Unknown symbol ath_hal_init_channels
[ 3962.373877] ath_pci: Unknown symbol ath_hal_getwirelessmodes

modprobe ath_hal
FATAL: Module ath_hal not found.

Victor Sergienko (singalen) wrote :

Same here, latest hardy.
I grepped for the symbols and found ath_hal.

*** modprobe ath_hal didn't load it. ***

Though insmod ath_hal.ko worked.
Afterwards modprobe ath_pci worked.

Victor Sergienko (singalen) wrote :

One more detail: I use 2.6.22-14-generic, as 2.6.24 soft-lockups for me.
lspci attached, dmesg is available from me.

Bryce Harrington (bryce) wrote :

Hi phaidros,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in linux-restricted-modules-2.6.22:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in linux-restricted-modules-2.6.22:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments