Averatec 2150 ATI x200 fglrx Edgy Feisty Gutsy Screen Flicker

Bug #148345 reported by mozzwald on 2007-10-03
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a problem with my Averatec 2150 (aka MSI MS-1030 / MSI Megabook S270) and it's ATI x200 video chipset. The screen has a very annoying flicker. I started using Ubuntu 6.10 Edgy back in Nov 2006. In Jan 07 I switched to Kubuntu 6.10 and the problem seemed to get worse. Since May I've been battling Feisty with this problem. I haven't installed Gutsy, but ran the live cd and the problem was still there. The default drivers loaded with all versions of Ubuntu cause the problem.

I have tried several different versions of the ATI Proprietary drivers on fresh installs of Ubuntu. I have tried the default Ubuntu fglrx drivers. I have tried different modelines for the 1280x800 lcd screen as suggested by this site (http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide#HP_zt3000_.2F_Compaq_nx7000). I have seen a few posts in the Ubuntu Forums about changing the sideport memory for the video card in the bios to use system ram. The only option I have for the video ram is the size (ie 32-128 mb). There is no mention of sideport. I am at a loss here. Is there anyone with something else that I could try? Here's some info:

uname -a: Linux mozz-laptop 2.6.20-16-generic #2 SMP Fri Aug 31 00:55:27 UTC 2007 i686 GNU/Linux

I will post my dmesg and lspci shortly

[lspci]
00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
     Subsystem: Micro-Star International Co., Ltd. Unknown device [1462:0131]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE) [1002:5955] (prog-if 00 [VGA])
     Subsystem: Micro-Star International Co., Ltd. Unknown device [1462:0131]

mozzwald (mozzwald) wrote :
mozzwald (mozzwald) wrote :
balak (balak) wrote :

I confirm this bug. I also have the same laptop and have been dealing with this issue for several months (edgy and now feisty). Let me know if you need any information from my setup.

Thanks!

avatar (gtujan) wrote :

I had this bug as well but it was fixed when I installed Gutsy and compiled the latest ATI fglrx driver

Bryce Harrington (bryce) wrote :

Hi mozzwald,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in linux-restricted-modules-2.6.22:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

[This is an automated message]

As of Intrepid (8.10), we have a dedicated package 'fglrx-installer' for fglrx bugs, which now includes a process for upstreaming bugs to AMD.

  http://bugs.launchpad.net/ubuntu/+source/fglrx-installer

To transition your bug into the new fglrx-package, we need your help. Please do the following:

 a. Verify the bug occurs in Intrepid.
     (Intrepid ISOs: http://cdimage.ubuntu.com)
 b. If you haven't already, please include in the bug:
     * Your /var/log/Xorg.0.log
     * The output of `lspci -vvnn`
     * Steps to reproduce the issue
 c. Click 'Also affects distribution'
 d. Set 'Source Package Name' to 'fglrx-installer'
 e. Click Continue

Thank you. This will assist us in reviewing and upstreaming your fglrx bug, as appropriate.

[We'll expire the fglrx bugs in l-r-m-* in a month or so.]

Bryce Harrington (bryce) on 2009-01-16
description: updated
Jonathan Thomas (echidnaman) wrote :

Closing since this was reported fixed.

Changed in linux-restricted-modules-2.6.22 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers