Ubuntu

xen amd64 nvidia module missing or broken

Reported by Todd Deshane on 2007-09-21
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

The package linux-restricted-modules-2.6.22-11-xen seems to be missing the modules ore dpkg -L is reporting incorrectly. Either way the nvidia modules doesn't load.

$ dpkg -L linux-restricted-modules-2.6.22-11-xen
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/linux-restricted-modules-2.6.22-11-xen
/usr/share/doc/linux-restricted-modules-2.6.22-11-xen/copyright
/usr/share/doc/linux-restricted-modules-2.6.22-11-xen/changelog.Debian.gz
$

$ls /lib/linux-restricted-modules/
2.6.22-10-generic 2.6.22-11-generic
$

I would expect the modules to be in /lib/linux-restricted-modules... but there is no 2.6.22-11-xen as I would expect.

Todd Deshane (deshantm) wrote :

Now, most of the xen modules are there, but the nvidia and nvidia_legacy directories are missing.

$ ls /lib/linux-restricted-modules$ ls 2.6.22-12-*

2.6.22-12-generic:
ath_hal fcdslsl fcdslusb fcpci nvidia nvidia_new
fcdsl2 fcdslslusb fcdslusb2 fglrx nvidia_legacy

2.6.22-12-xen:
ath_hal fcdslsl fcdslusb fcpci nvidia_new
fcdsl2 fcdslslusb fcdslusb2 fglrx

Excerpt of the /var/log/Xorg.0.log

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "MetaModes" "DFP-0: 1680x1050 +1680+0, DFP-1: 1680x1050 +0+0; DFP-0: NULL, DFP-1: nvidia-auto-select +0+0"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TwinView enabled
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Full log attached

Todd Deshane (deshantm) wrote :

attaching strace startx output

Martin Hoefling (martoss) wrote :

I compiled the nvidia module from source (nvidia and nvidia_new). 9639 nvidia module fails as well as the self compilec 100.x.x modules (both patched for xen)

Todd Deshane (deshantm) wrote :

The module is no longer missing it is simply broken. I think now that this is a duplicate of bug # 150192

I will update the summary and mark this a duplicate of that one

Todd Deshane (deshantm) wrote :

I either don't have access or can't find the place to change the summary. I guess it is not a big issue now that this is a duplicate of bug 150192

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers