Unknown symbol in module fcpci.ko

Bug #121978 reported by Fedi73 on 2007-06-24
24
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-restricted-modules-2.6.22-6-generic

Is impossible to install the module fcpci on kernel 2.6.22 (proved with 2.6.22-6-generic and 2.6.22-6-386)

root@kubuntu:~# modprobe fcpci
FATAL: Error inserting fcpci (/lib/modules/2.6.22-6-generic/volatile/fcpci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
root@kubuntu:~# dmesg
[ 1212.240701] fcpci: Unknown symbol pci_module_init

Johannes Rohr (jorohr) wrote :

The fix is to replace pci_module_init() by pci_register_driver. See http://student.physik.uni-mainz.de/~reiffert/fcpci.php (bottom of page)

Christian Assig (chrassig) wrote :

Setting to confirmed as I am affected by this as well

Changed in linux-restricted-modules-2.6.22:
status: New → Confirmed
Christian Assig (chrassig) wrote :

My temporary workaround is to use feisty's 2.6.20 kernel with gutsy.
This also meant I had to disable nvidia-glx for now.

Christian Assig (chrassig) wrote :

I was able to fix this the way Johannes described, see attached patch

Christian Assig (chrassig) wrote :
Christian Assig (chrassig) wrote :

Assigned to ubuntu-kernel-team following an advice on #ubuntu-bugs

Changed in linux-restricted-modules-2.6.22:
assignee: nobody → ubuntu-kernel-team
Changed in linux-restricted-modules-2.6.22:
assignee: ubuntu-kernel-team → nobody
importance: Undecided → Medium
status: Confirmed → Triaged
assignee: nobody → ubuntu-kernel-team
manya (untitled2-gmx) on 2007-10-09
Changed in linux-restricted-modules-2.6.22:
status: Triaged → Confirmed
Christian Assig (chrassig) wrote :

Unfortunately, there have been three new releases of linux-restricted-modules-2.6.22 since I posted the patch, and none of them contained the patch.
I am starting to get tired of manually integrating the patch into the each new release and compiling it on my own.

Is there anyone who can explain to me why the patch was not included in the past releases?
Please tell me if there is anything I can do to accelerate the progress.

Wladimir Krasnov (wk2001) wrote :

I can confirm this bug and also waiting for the fix...

Wladimir Krasnov (wk2001) wrote :

@Christian:

can you tell me how you have permanently installed the module, so it is loading at boot time?

i have compiled it, but i have to copy the compiled fcpci.ko after every boot to the /lib/modules/2.6.22-14-generic/volatile/ directory and after that make depmod fcpci.
make install or checkinstall didn't help...

thank you for advise!

Marc Cheng (bdgraue) wrote :

i'm also affected by this bug and would like to see it fixed.

Christian Assig (chrassig) wrote :

@Wladimir,

I built and installed a patched version of the linux-restricted-modules deb package.

The steps in detail:

Download everything you need to build the package:
sudo apt-get build-dep linux-restricted-modules-2.6.22-14-generic

Download the source code of linux-restricted-modules:
apt-get source linux-restricted-modules-2.6.22-14-generic

Download the patch posted here by me:
wget http://launchpadlibrarian.net/9584032/linux-restricted-modules-2.6.22-2.6.22.4.patch

Apply the patch:
patch -p1 < linux-restricted-modules-2.6.22-2.6.22.4.patch

If patch does not find the file to patch, tell it to patch the following file:
linux-restricted-modules-2.6.22-2.6.22.4/fritz/fcpci/src/main.c

Add a comment about your changes and build all packages related to the restricted modules:
cd linux-restricted-modules-2.6.22-2.6.22.4/
debchange -i
dpkg-buildpackage -rfakeroot -b
(this will take a few minutes)

Finally, install the package you just built:
cd ..
sudo dpkg -i linux-restricted-modules-2.6.22-14-generic.deb

Marc Cheng (bdgraue) wrote :

there are 6 days up to final, is there a fix on its way?
i have still

$ modprobe fcpci
FATAL: Error inserting fcpci (/lib/modules/2.6.22-14-generic/volatile/fcpci.ko): Unknown symbol in module, or unknown parameter (see dmesg)

$ dmesg | grep fcpci
[47780.096000] fcpci: Unknown symbol pci_module_init

if there is anything i can do, tell me that.

Wladimir Krasnov (wk2001) wrote :

@Christian: thank you, but for me it worked not for this reason: i have an amd64 system and kernel... after looking a little bit around i found out that for 64bit systems there is an extra module, so i had to change not this file:

linux-restricted-modules-2.6.22-2.6.22.4/fritz/fcpci/src/main.c

but this one:

linux-restricted-modules-2.6.22-2.6.22.4/fritz64/fcpci/src/main.c

i did it manually and then followed your instructions. now everything works fine.

don't understand why it wasn't patched by the developers :(

so here for other people having the problem with fcpci and amd64 my deb package compiled after applying the patch

Wladimir Krasnov (wk2001) wrote :

again the deb package with corrected type

Does anyone know when it will be really fixed?

Klaus Layer (klaus-layer) wrote :

I successfully used the workaround described by Christian Assig above (thanks to Christian) but this error should be resolved, particularly because an fix exists which can be easily included.

Thanks Klaus

informix (informix) wrote :

@klaus

Yes, of course - It's also quiet annoying that apt-get want's to download the buggy package all the time!

Martin Pitt (pitti) wrote :

LaMont, thank you for your upload to fix this. However, please reupload to gutsy-proposed, not gutsy-updates (see https://wiki.ubuntu.com/StableReleaseUpdates). I rejected the -updates upload.

Ebbo (s-t-e-e-l) wrote :

Another i386 Build, the one posted above didn't work for me.

Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test. Thanks, Lamont!

Changed in linux-restricted-modules-2.6.22:
status: Confirmed → Fix Committed
b2ag (thomas-b2ag) wrote :

linux-restricted-modules-2.6.22-14-rt in version 2.6.22.4-14.9 is still affect and newest version :(

Klaus Layer (klaus-layer) wrote :

Can someone from the Ubuntu kernel team please give an estimation when we can expect the fix to be shipped. This makes it easier for those waiting...

Thanks,

Klaus

Christian Assig (chrassig) wrote :

I don't know anything about the official release date, but you can already download the updated version 2.6.22.4-14.10 which contains the fix from the official Ubuntu servers,
e.g. for the generic i386 kernel
ftp://archive.ubuntu.com/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.22/linux-restricted-modules-2.6.22-14-generic_2.6.22.4-14.10_i386.deb

or for the real time kernel from
ftp://archive.ubuntu.com/ubuntu/pool/multiverse/l/linux-restricted-modules-2.6.22/linux-restricted-modules-2.6.22-14-rt_2.6.22.4-14.10_i386.deb

Packages for other kernels are available as well.

b2ag (thomas-b2ag) wrote :

linux-restricted-modules-2.6.22-14-rt_2.6.22.4-14.10_i386.deb works fine for me.
fcpci.ko loaded successfully

Martin Pitt (pitti) wrote :

Thanks for testing. Considering verification-done, but more feedback is always appreciated.

Egon Frerich (e-frerich) wrote :

Still a bug with capi.

Yesterday I've installed avm-fritz-firmware-2.6.22-14_3.11+2.6.22.4-14.10_amd64.deb for gutsy and a Fritz!Card USB 1.0. After restart syslog contains:

Nov 22 23:37:52 Baldur kernel: [ 37.270775] ISDN subsystem Rev: 1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
Nov 22 23:37:52 Baldur kernel: [ 37.283002] CAPI Subsystem Rev 1.1.2.8
Nov 22 23:37:52 Baldur kernel: [ 37.286279] capidrv: Rev 1.1.2.2: loaded
Nov 22 23:37:52 Baldur kernel: [ 37.290258] capifs: Rev 1.1.2.3
Nov 22 23:37:52 Baldur kernel: [ 37.293184] capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)

But capisuite.error tells me:

Thu Nov 22 23:37:59 2007 CapiSuite 0x7fff76f448d0: CapiSuite 0.4.5 started.
Thu Nov 22 23:37:59 2007 CapiSuite 0x7fff76f448d0: Can't start Capi abstraction. The given error message was: CapiError: Error in CAPI20_ISINSTALLED: CAPI not installed. occured in Capi::getCapiInfo()

And capisuite.log says:

Thu Nov 22 23:37:59 2007 CapiSuite 0x7fff76f448d0: CapiSuite 0.4.5 started.
Thu Nov 22 23:37:59 2007 Capi 0x65ae20: Capi object created

I tried capiinstall and get the message capiinstall is not installed.

During shutdown it was logged:

Nov 23 00:16:52 Baldur kernel: [ 2378.114615] capi: Rev 1.1.2.7: unloaded
Nov 23 00:16:52 Baldur kernel: [ 2378.122418] capidrv: Rev 1.1.2.2 : unloaded
Nov 23 00:16:52 Baldur kernel: [ 2378.123363] ISDN-subsystem unloaded

What should I do?

Egon Frerich (e-frerich) wrote :

I posted my problem as a new bug.

Martin Pitt (pitti) wrote :

This is in gutsy-updates.

Changed in linux-restricted-modules-2.6.22:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers