Comment 245 for bug 121653

Rocko (rockorequin) wrote :

I managed to get resume working intermittently with Ubuntu 7.10 and the 2.6.24-4 kernel, Catalyst 8.01 when I set SAVE_VBE_STATE and POST_VIDEO both false as suggested earlier.

It worked fine the first time but it failed to resume the second time.

I also tried on Hardy alpha 4 with the 2.6.24-5 kernel and Catalyst 8.01, but couldn't get resume to work. I tried

(a) the default acpi settings,

(b) both SAVE_VBE_STATE and POST_VIDEO set to false,

(c) POST_VIDEO set to true, and

(d) with the command 'vbetool post' in /etc/acpi/sleep.sh immediately after the echo command that puts the system to sleep (since I found in Gutsy tribe 5 that this was the only way to get it to resume with the open-source drivers).

But in all cases in Hardy I just got a blank screen on resume, although it seemed (judging by the USB activity) that my drives were mounting etc.

By the way, it seems that compiz/fglrx doesn't work in Hardy because fglrx doesn't support AIGLX on xorg-server v1.4 - see bug 173663. (Gutsy uses xorg-server v1.3.)