Comment 172 for bug 121653

David: is your 3D acceleration working?

I tried the latest FGLRX with Gutsy, and /var/log/Xorg.log.0 said that it couldn't load DRI because it requires a more recent version of the X server. If DRI doesn't load, then perhaps suspend/resume might work, but you might as well be using RadeonHD if there's no 3D acceleration.